X
Tap here to go to the mobile version of the site.

Support Forum

Blank FireFox screen on bootup

Posted

I'm getting a blank (white) screen when my Win 7 pc boots up to the desktop (see attached screen shot). It has a small FireFox logo at the upper left corner. After about a minute this window will close revealing the desktop. If you try to close it, it says it isn't responding. As a test, I uninstalled FF and then rebooted. This window didn't open up. I can't tell if it is a FF issue or if some program is trying to use FF on startup but failing. Has anyone else had this issue?

I'm getting a blank (white) screen when my Win 7 pc boots up to the desktop (see attached screen shot). It has a small FireFox logo at the upper left corner. After about a minute this window will close revealing the desktop. If you try to close it, it says it isn't responding. As a test, I uninstalled FF and then rebooted. This window didn't open up. I can't tell if it is a FF issue or if some program is trying to use FF on startup but failing. Has anyone else had this issue?
Attached screenshots

Chosen solution

Pkshadow THANKS! That did it... no more FF screen at boot up. In addition, once FF was back up and running with my Bookmarks, I decided to try and put the Profile back, and it still worked just fine with no FF boot up screen. It must have been something with the FF install itself. Anyway, thanks for the help. FF is back to working like it should.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

Shadow110 1072 solutions 14836 answers

Hi, when you made the question you did not share any information so I have nothing to work with.

Please scan : https://www.malwarebytes.com/ and if that fails to fix the issue : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Performance > Uncheck to view)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

Hi, when you made the question you did not share any information so I have nothing to work with. Please scan : https://www.malwarebytes.com/ and if that fails to fix the issue : SAFE MODE *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Performance > Uncheck to view) *plugins are not affected *preferences are not affected TEST'''''''''is issue still there ?

Question owner

System Details

   Windows 7 Ultimate
   Firefox 62.0

Installed Plug-ins

   Shockwave Flash 30.0 r0 

Application

   User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Malwarebytes found nothing. How do I get FF to start in SafeMode when rebooting? Doesn't FF revert back to normal on reboot?

System Details Windows 7 Ultimate Firefox 62.0 Installed Plug-ins Shockwave Flash 30.0 r0 Application User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0 Malwarebytes found nothing. How do I get FF to start in SafeMode when rebooting? Doesn't FF revert back to normal on reboot?
Shadow110 1072 solutions 14836 answers

Try Firefox Safe Mode to TEST & see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

'''Try Firefox Safe Mode''' to '''TEST''' & see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.
Shadow110 1072 solutions 14836 answers

Can you go up the Start Menu and find Startup and see if Firefox is in the Menu. It sorta looks like booting with Firefox to start up at boot in full screen.

Can you go up the Start Menu and find Startup and see if Firefox is in the Menu. It sorta looks like booting with Firefox to start up at boot in full screen.

Question owner

I clicked on Programs/Startup. There is nothing in there...it says empty and yet as you said, FF seems to open in full screen mode but then closes, usually within approximately 45 seconds. This just started happening. Very odd behavior.

I clicked on Programs/Startup. There is nothing in there...it says empty and yet as you said, FF seems to open in full screen mode but then closes, usually within approximately 45 seconds. This just started happening. Very odd behavior.
cor-el
  • Top 10 Contributor
  • Moderator
17522 solutions 158442 answers
See also: *https://support.mozilla.org/en-US/kb/firefox-starts-automatically-when-i-restart-window

Question owner

Cor-el

After reading your link, and seeing that toolkit.winRegisterApplicationRestart was set to True in my copy of FF, I thought this is going to work. Unfortunately...even after changing it to False, the blank FireFox window still opens as the computer boots to the desktop. Darn!

Cor-el After reading your link, and seeing that toolkit.winRegisterApplicationRestart was set to True in my copy of FF, I thought this is going to work. Unfortunately...even after changing it to False, the blank FireFox window still opens as the computer boots to the desktop. Darn!
Shadow110 1072 solutions 14836 answers

Helpful Reply

Please check if it is in the main place for start at boot. https://www.howtogeek.com/74523/how-to-disable-startup-programs-in-windows/ If Not Try : try this, backup and save below some where safe away from  :

Uninstall Firefox with :

Reinstall with a fill version Installer :

You may just choose to but your bookmarks in so do not transfer issues from the profile.

Please check if it is in the main place for start at boot. https://www.howtogeek.com/74523/how-to-disable-startup-programs-in-windows/ If Not Try : try this, backup and save below some where safe away from : *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles Uninstall Firefox with : *https://www.revouninstaller.com/revo_uninstaller_free_download.html Reinstall with a fill version Installer : *https://www.mozilla.org/firefox/all/ You may just choose to but your bookmarks in so do not transfer issues from the profile.

Chosen Solution

Pkshadow THANKS! That did it... no more FF screen at boot up. In addition, once FF was back up and running with my Bookmarks, I decided to try and put the Profile back, and it still worked just fine with no FF boot up screen. It must have been something with the FF install itself. Anyway, thanks for the help. FF is back to working like it should.

Pkshadow THANKS! That did it... no more FF screen at boot up. In addition, once FF was back up and running with my Bookmarks, I decided to try and put the Profile back, and it still worked just fine with no FF boot up screen. It must have been something with the FF install itself. Anyway, thanks for the help. FF is back to working like it should.