X
Tap here to go to the mobile version of the site.

Support Forum

webgl messed up in firefox 62.0

Posted

My 3D models on Sketchfab and Artstation are scrambled in Firefox 62.0 They looked fine in the previous version of Firefox and in Chrome.


edit: fixed version from 6.2 to 62.0

My 3D models on Sketchfab and Artstation are scrambled in Firefox 62.0 They looked fine in the previous version of Firefox and in Chrome. edit: fixed version from 6.2 to 62.0

Modified by James

Chosen solution

bisenberger said

My 3D models on Sketchfab and Artstation are scrambled in Firefox 62.0 They looked fine in the previous version of Firefox and in Chrome.

Fixed in FireFox 62.0.2

~Pj

Read this answer in context 0

Question owner

Thread about the Firefox bug on the Sketchfab forum:

https://forum.sketchfab.com/t/3d-viewer-broken/23356

Thread about the Firefox bug on the Sketchfab forum: https://forum.sketchfab.com/t/3d-viewer-broken/23356
Pkshadow 1072 solutions 14836 answers

Sorry to hear that. https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration Try updating and reinstalling you WebGL as most times they are corrupted when I see them. Since you chose not to share information when you made your question I can not see what would have helped you.

So good luck with reinstalling them.

Sorry to hear that. https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration Try updating and reinstalling you WebGL as most times they are corrupted when I see them. Since you chose not to share information when you made your question I can not see what would have helped you. So good luck with reinstalling them.

Question owner

Pkshadow said

Sorry to hear that. https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration Try updating and reinstalling you WebGL as most times they are corrupted when I see them. Since you chose not to share information when you made your question I can not see what would have helped you. So good luck with reinstalling them.

Looks like we were posting at the same time. See this link:

https://forum.sketchfab.com/t/3d-viewer-broken/23356

''Pkshadow [[#answer-1151779|said]]'' <blockquote> Sorry to hear that. https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration Try updating and reinstalling you WebGL as most times they are corrupted when I see them. Since you chose not to share information when you made your question I can not see what would have helped you. So good luck with reinstalling them. </blockquote> Looks like we were posting at the same time. See this link: https://forum.sketchfab.com/t/3d-viewer-broken/23356
philipp
  • Top 25 Contributor
  • Moderator
5251 solutions 23225 answers

Helpful Reply

this problem is also tracked at https://bugzilla.mozilla.org/show_bug.cgi?id=1489099

Question owner

Thanks philipp.

This image shows what the model should look like and what it looks like in FF62.0.

Thanks philipp. This image shows what the model should look like and what it looks like in FF62.0.

Modified by bisenberger

evgenfed 0 solutions 4 answers

The same problem. Grey-white areas appeared on canvas. Any other browser work correctly.

The same problem. Grey-white areas appeared on canvas. Any other browser work correctly.
Pj
  • Top 25 Contributor
43 solutions 868 answers

Chosen Solution

bisenberger said

My 3D models on Sketchfab and Artstation are scrambled in Firefox 62.0 They looked fine in the previous version of Firefox and in Chrome.

Fixed in FireFox 62.0.2

~Pj

''bisenberger [[#question-1232932|said]]'' <blockquote> My 3D models on Sketchfab and Artstation are scrambled in Firefox 62.0 They looked fine in the previous version of Firefox and in Chrome. </blockquote> Fixed in FireFox 62.0.'''2''' ~Pj