X
Tap here to go to the mobile version of the site.

Support Forum

Running Win 7 64 bit. Firefox ver 52.9.0 (32 bit). Cannot upgrade.

Posted

Received message that I cannot upgrade. It appears that FF thinks I am running XP or Vista. How can I convince FF that the OS is Win 7 and upgrade to latest version of FF? I am currently having no issues, but, would like to get security updates.

Received message that I cannot upgrade. It appears that FF thinks I am running XP or Vista. How can I convince FF that the OS is Win 7 and upgrade to latest version of FF? I am currently having no issues, but, would like to get security updates.

Chosen solution

Could you turn off any compatibility settings on your Firefox shortcut?

To do that, find the icon you use the start Firefox, and either:

  • Right-click a desktop shortcut, then click Properties
  • Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties

You should clear all the boxes on the Compatibility tab for best results (giant screenshot below).

Any difference the next time you start Firefox?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.0"
  • Cortona2D Viewer Plug-in for Mozilla-based Browsers
  • Cortona3D Plug-in for Mozilla-based Browsers (8, 0, 0, 196)
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Netscape(1,0,2,35)
  • Shockwave Flash 26.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.8.158
  • 5.1.50907.0

Application

  • Firefox 52.9.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
  • Support URL: https://support.mozilla.org/1/firefox/52.9.0/WINNT/en-US/

Extensions

  • Activity Stream 1.14.3 (@activity-streams)
  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • LastPass: Free Password Manager 4.17.0.4 (support@lastpass.com)
  • Multi-process staged rollout 1.10 (e10srollout@mozilla.org)
  • Open With Adobe PDF Reader 1.2.3 ({21a1b1c3-5029-4660-bfa4-0274adc69439})
  • Page Shot 5.2.201701261751 (jid1-NeEaf3sAHdKHPA@jetpack)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Test Pilot 3.0.5vfed9863 (@testpilot-addon)
  • UAControl 0.1.3.1.1-signed.1-signed (uacontrol@qz.tsugumi.org)
  • Wayback Machine 1.8.6 (wayback_machine@mozilla.org)
  • Weather 0.0.9 (@Weather)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 380d17aa
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22164
  • driverDate: 8-4-2015
  • driverDate2:
  • driverVersion: 10.18.14.4264
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D9 API
  • webgl2Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8695 solutions 71074 answers

Chosen Solution

Could you turn off any compatibility settings on your Firefox shortcut?

To do that, find the icon you use the start Firefox, and either:

  • Right-click a desktop shortcut, then click Properties
  • Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties

You should clear all the boxes on the Compatibility tab for best results (giant screenshot below).

Any difference the next time you start Firefox?

Could you turn off any compatibility settings on your Firefox shortcut? To do that, find the icon you use the start Firefox, and either: * Right-click a desktop shortcut, then click Properties * Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties You should clear all the boxes on the Compatibility tab for best results (giant screenshot below). <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-07-25-13-24-46-baad8f.png"> Any difference the next time you start Firefox?
jscher2000
  • Top 10 Contributor
8695 solutions 71074 answers

If the updater doesn't migrate you to 64-bit Firefox, you could update manually. Please see this article for tips on that: How to switch from 32-bit to 64-bit Firefox.

If you use Microsoft Office: Please temporarily switch your default browser to Internet Explorer before uninstalling 32-bit Firefox to avoid the problem described in this article: https://www.slipstick.com/problems/this-operation-has-been-cancelled-due-to-restrictions/

If the updater doesn't migrate you to 64-bit Firefox, you could update manually. Please see this article for tips on that: [[How to switch from 32-bit to 64-bit Firefox]]. '''If you use Microsoft Office:''' Please temporarily switch your default browser to Internet Explorer before uninstalling 32-bit Firefox to avoid the problem described in this article: https://www.slipstick.com/problems/this-operation-has-been-cancelled-due-to-restrictions/
DavidBassPlayer 4 solutions 26 answers

"Could you turn off any compatibility settings on your Firefox shortcut?" No compatibility boxes are checked.

"Could you turn off any compatibility settings on your Firefox shortcut?" No compatibility boxes are checked.
jscher2000
  • Top 10 Contributor
8695 solutions 71074 answers

Helpful Reply

Hi DavidBassPlayer, what version of Windows are you running now? In a January post you wrote "Windows 7 Home Premium 64 bit" but your browser reported itself as running on Vista. If Firefox was not confused because of compatibility settings, try this: How to reset the default user agent on Firefox.

Hi DavidBassPlayer, what version of Windows are you running now? In a January post you wrote "Windows 7 Home Premium 64 bit" but your browser reported itself as running on Vista. If Firefox was not confused because of compatibility settings, try this: [[How to reset the default user agent on Firefox]].
James
  • Moderator
1596 solutions 11250 answers

DavidBassPlayer said

"Could you turn off any compatibility settings on your Firefox shortcut?" No compatibility boxes are checked.

You should actually have started a new thread instead of asking for help in two existing threads.

This way we can what your useragent is also.

Based on your past threads over the last four years it appears as you had a useragent showing as if you have Vista (NT 6.0) and not Windows 7 (NT 6.1) each time in More System Details on right of OP. /questions/1200908 /questions/1082238 /questions/1019781

So either you have been running Firefox in Windows Vista compatibility mode or the useragent was modified over time either by a useragent related extension or manually by you.

''DavidBassPlayer [[#answer-1152605|said]]'' <blockquote> "Could you turn off any compatibility settings on your Firefox shortcut?" No compatibility boxes are checked. </blockquote> You should actually have started a new thread instead of asking for help in two existing threads. This way we can what your useragent is also. Based on your past threads over the last four years it appears as you had a useragent showing as if you have Vista (NT 6.0) and not Windows 7 (NT 6.1) each time in More System Details on right of OP. [/questions/1200908] [/questions/1082238] [/questions/1019781] So either you have been running Firefox in Windows Vista compatibility mode or the useragent was modified over time either by a useragent related extension or manually by you.
DavidBassPlayer 4 solutions 26 answers

First thank you all for quick and useful responses.

I have not yet had opportunity to do as suggested above, "try this: How to reset the default user agent on Firefox." (link didn't survive, please see above.) I will do at the earliest opportunity.

I have not changed any settings. W7 was installed at the factory in 2011, and Firefox soon thereafter, in spite of being badgered by my tech friends to use Chrome. I trust Firefox. It doesn't report to "big brother"

I have never run Vista, my OS claims to be 64 bit W7 Home Premium. but a number of other programs seem think it is not W7 and refuse to update. 

Finally, I am a real neophyte with Mozilla Support. I know not to hijack a thread, and thought my issue was the one being discussed.

I have had very few issues wth Firefox other than run away memory use with this version of Firefox. I'm hoping the new version will fix that. I don't post much.

First thank you all for quick and useful responses. I have not yet had opportunity to do as suggested above, "try this: How to reset the default user agent on Firefox." (link didn't survive, please see above.) I will do at the earliest opportunity. I have not changed any settings. W7 was installed at the factory in 2011, and Firefox soon thereafter, in spite of being badgered by my tech friends to use Chrome. I trust Firefox. It doesn't report to "big brother" I have never run Vista, my OS claims to be 64 bit W7 Home Premium. but a number of other programs seem think it is not W7 and refuse to update. Finally, I am a real neophyte with Mozilla Support. I know not to hijack a thread, and thought my issue was the one being discussed. I have had very few issues wth Firefox other than run away memory use with this version of Firefox. I'm hoping the new version will fix that. I don't post much.
DavidBassPlayer 4 solutions 26 answers

I took the time to do as suggested, but there was no mechanism indicated to tell whether I was successful. "Help" still says I cannot perform further updates to Firefox on this system. Suggestions?

I took the time to do as suggested, but there was no mechanism indicated to tell whether I was successful. "Help" still says I cannot perform further updates to Firefox on this system. Suggestions?
DavidBassPlayer 4 solutions 26 answers

WInver, run from the command line, says Windows 7 Home Premium NT 6.1 build 7601 Service Pack 1 But FF still says I cannot do more updates.

I want to update to Quantum. I in fact have downloaded the FF Quantum installer but am concerned about untoward consequence of running it.

WInver, run from the command line, says Windows 7 Home Premium NT 6.1 build 7601 Service Pack 1 But FF still says I cannot do more updates. I want to update to Quantum. I in fact have downloaded the FF Quantum installer but am concerned about untoward consequence of running it.
jscher2000
  • Top 10 Contributor
8695 solutions 71074 answers

Hi DavidBassPlayer, could you check the Troubleshooting Information page. Either:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the OS row, what does Firefox show? For reference, Windows_NT 6.1 = Windows 7.

Hi DavidBassPlayer, could you check the Troubleshooting Information page. Either: * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, on the OS row, what does Firefox show? For reference, Windows_NT 6.1 = Windows 7.
DavidBassPlayer 4 solutions 26 answers

Thank you. I did as you suggest, results say FF thinks I'm running Vista:

User Agent Mozilla/5.0 (Windows NT 6.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

OS Windows_NT 6.0

If asked, I can post a screen shot of winver output stating that I'm running NT 6.1, as I state above.

I attempted to fix this as someone suggested earlier, but that did not help.

Thank you. I did as you suggest, results say FF thinks I'm running Vista: User Agent Mozilla/5.0 (Windows NT 6.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 OS Windows_NT 6.0 If asked, I can post a screen shot of winver output stating that I'm running NT 6.1, as I state above. I attempted to fix this as someone suggested earlier, but that did not help.
jscher2000
  • Top 10 Contributor
8695 solutions 71074 answers

Hi DavidBassPlayer, when Firefox queries Windows to find out what version is running on, it is being told Vista. The only way I know of to fool Firefox into thinking it is running on an older version of Windows is the Compatibility settings which you can access through its shortcut. (Windows version is the top setting in the Windows 7 screenshot above.) There could be another way that I'm not aware of. But I'm not aware of it.

Hi DavidBassPlayer, when Firefox queries Windows to find out what version is running on, it is being told Vista. The only way I know of to fool Firefox into thinking it is running on an older version of Windows is the Compatibility settings which you can access through its shortcut. (Windows version is the top setting in [https://prod-cdn.sumo.mozilla.net/uploads/images/2018-07-25-13-24-46-baad8f.png the Windows 7 screenshot above].) There could be another way that I'm not aware of. But I'm not aware of it.
DavidBassPlayer 4 solutions 26 answers

Thank you , jscher2000 I really am running NT 6.1 I see no compatibilty settings when I right click the shortcut, but I'll right click again and see if the compatibilty mode includes the possibility of running NT 6.1 I'll also go to the binary in C:\program files (x86) and right click the binary.

I'll also do another google search and see if there's another way.

Meanwhile, I'm hoping someone can tell me how to make FF report the truth.

Thank you , jscher2000 I really am running NT 6.1 I see no compatibilty settings when I right click the shortcut, but I'll right click again and see if the compatibilty mode includes the possibility of running NT 6.1 I'll also go to the binary in C:\program files (x86) and right click the binary. I'll also do another google search and see if there's another way. Meanwhile, I'm hoping someone can tell me how to make FF report the truth.
DavidBassPlayer 4 solutions 26 answers

Happy Happy, Joy Joy!! I realized there is one link that I have NOT looked at: The one in the start menu, that the task bar icon links through to the .exe.

And THERE IS WAS' exactly as suggested "run in compatibility mode: Vista". I changed that to Window 7 Here's what trouble shooting infomation says now:

Update Channel esr User Agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 OS Windows_NT 6.1

THANK YOU! THANK YOU!

Happy Happy, Joy Joy!! I realized there is one link that I have NOT looked at: The one in the start menu, that the task bar icon links through to the .exe. And '''THERE IS WAS'''' exactly as suggested "run in compatibility mode: Vista". I changed that to Window 7 Here's what trouble shooting infomation says now: Update Channel esr User Agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 OS Windows_NT 6.1 THANK YOU! THANK YOU!

Modified by DavidBassPlayer

James
  • Moderator
1596 solutions 11250 answers

DavidBassPlayer said

And THERE IS WAS' exactly as suggested "run in compatibility mode: Vista". I changed that to Window 7

So instead of unchecking the [] Run this program in compatibility mode box, you set it to run in Windows 7 compatibility mode?

Now that you fixed what windows mode Firefox is running as, if you were to do a internal software update in Firefox it will serve you the Firefox 60.2.0 ESR.

So if you want the current Release download from www.mozilla.org/firefox/all/

''DavidBassPlayer [[#answer-1152884|said]]'' <blockquote> And '''THERE IS WAS'''' exactly as suggested "run in compatibility mode: Vista". I changed that to Window 7 </blockquote> So instead of unchecking the [] Run this program in compatibility mode box, you set it to run in Windows 7 compatibility mode? Now that you fixed what windows mode Firefox is running as, if you were to do a internal software update in Firefox it will serve you the Firefox 60.2.0 ESR. So if you want the current Release download from www.mozilla.org/firefox/all/