X
Tap here to go to the mobile version of the site.

Support Forum

Firefox uses too much memory cause slowdown

Posted

I use firetox to browse youtube, FB, and some blog. But, when I use for a while time, I felt my PC slow down, and check task manager, it shows that Superfetch is using my disk to release some memory for Firefox, and my Firefix use 17% of CPU and about 5G memory in one process(there are more than one process), it almost use 99% memory I have, and suddenly the usage goes down to hundreds of megabyte.

I have tried disable addons, refresh Firefox.

Firefox is up to date P.S. It is hard to open about:memory because I will get stuck when it happened.

I use firetox to browse youtube, FB, and some blog. But, when I use for a while time, I felt my PC slow down, and check task manager, it shows that Superfetch is using my disk to release some memory for Firefox, and my Firefix use 17% of CPU and about 5G memory in one process(there are more than one process), it almost use 99% memory I have, and suddenly the usage goes down to hundreds of megabyte. I have tried disable addons, refresh Firefox. Firefox is up to date P.S. It is hard to open about:memory because I will get stuck when it happened.
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Android 8.0.0; Mobile; rv:61.0) Gecko/61.0 Firefox/61.0

More Information

Pkshadow 1070 solutions 14836 answers

Hi, seems you are a phone, not sure about releases for phones version 62 released today for Desktops/laptops/notepads which is where you are. You need over here : https://support.mozilla.org/en-US/products/mobile

Hi, seems you are a phone, not sure about releases for phones version 62 released today for Desktops/laptops/notepads which is where you are. You need over here : https://support.mozilla.org/en-US/products/mobile
Was this helpful to you?
Quote
Pkshadow 1070 solutions 14836 answers

If you have just entered the wrong information :

To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Only Disable as last resort.

Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Only move to esr if low ram and old system.

Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do please :

If you have just entered the wrong information : '''''To be Checked and turned off unless needed for accessibility : ''''' Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. '''''Multi-Processor Support : ''''' Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. Only Disable as last resort. '''''Multi-processor Can completely disable it this way in about:config :''''' dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false *http://kb.mozillazine.org/About:config Only move to esr if low ram and old system. '''''Firefox Extended Release Version :''''' Firefox ESR does not come with the latest features but it has the latest security and stability fixes. *https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr If do please : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer
Was this helpful to you?
Quote

Question owner

Pkshadow said

Hi, seems you are a phone, not sure about releases for phones version 62 released today for Desktops/laptops/notepads which is where you are. You need over here : https://support.mozilla.org/en-US/products/mobile

I meant the desktop, sorry, I just use phone to post the

questionPkshadow said

If you have just entered the wrong information : To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. Only Disable as last resort. Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false Only move to esr if low ram and old system. Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes. If do please :

I changed the multi-processor setting from 4(default) to 2, If the situation improves, I will mark this as solved

''Pkshadow [[#answer-1150145|said]]'' <blockquote> Hi, seems you are a phone, not sure about releases for phones version 62 released today for Desktops/laptops/notepads which is where you are. You need over here : https://support.mozilla.org/en-US/products/mobile </blockquote> I meant the desktop, sorry, I just use phone to post the question''Pkshadow [[#answer-1150146|said]]'' <blockquote> If you have just entered the wrong information : '''''To be Checked and turned off unless needed for accessibility : ''''' Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. '''''Multi-Processor Support : ''''' Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. Only Disable as last resort. '''''Multi-processor Can completely disable it this way in about:config :''''' dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false *http://kb.mozillazine.org/About:config Only move to esr if low ram and old system. '''''Firefox Extended Release Version :''''' Firefox ESR does not come with the latest features but it has the latest security and stability fixes. *https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr If do please : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer </blockquote> I changed the multi-processor setting from 4(default) to 2, If the situation improves, I will mark this as solved
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16655 solutions 150534 answers

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems *https://support.mozilla.org/en-US/kb/performance-settings

Modified by cor-el

Was this helpful to you?
Quote

Question owner

OK, it slowed down again. And I got some memory reports.

As you can see in the picture, the audio of media cost 5G memory when I was watching some stream video, I think the format type is .ts. What should I do? Thanks.

OK, it slowed down again. And I got some memory reports. As you can see in the picture, the audio of media cost 5G memory when I was watching some stream video, I think the format type is .ts. What should I do? Thanks.
Was this helpful to you?
Quote
Pkshadow 1070 solutions 14836 answers

Follow the instructions of my 2nd post, the long one.

Follow the instructions of my 2nd post, the long one.
Was this helpful to you?
Quote
Pkshadow 1070 solutions 14836 answers

If you had posted with the cpu and shared info I would have seen your video card drivers.

Remove them, Reinstall them as Audio is mostly HTML5

If you had posted with the cpu and shared info I would have seen your video card drivers. Remove them, Reinstall them as Audio is mostly HTML5
Was this helpful to you?
Quote
Pkshadow 1070 solutions 14836 answers

Can also disable Hardware Acceleration which is right at where you lowered the processors.

This is possibly a older system am thinking.... Move to the ESR if still issues.

Can also disable Hardware Acceleration which is right at where you lowered the processors. This is possibly a older system am thinking.... Move to the ESR if still issues.
Was this helpful to you?
Quote

Question owner

Pkshadow said

Follow the instructions of my 2nd post, the long one.

Which one? FF54 or carshes? and these are my spec:

CPU: i5-8400 MB: Gigabyte B360M DS3H Graphic: Gigabyte Geforce GTX1050 OC 2G with driver 399.24 (release at 09/10/2018) Audio driver: 6.0.1.8228 DirectX 12 plugged at 3.5mm

add-on I installed: uBlock Origin 1.16.20 IDM integration module 6.31.2

FireFox version: 62.0 Windows version: Windows 10 edu 1803(OS 17164.285)

''Pkshadow [[#answer-1154055|said]]'' <blockquote> Follow the instructions of my 2nd post, the long one. </blockquote> Which one? FF54 or carshes? and these are my spec: CPU: i5-8400 MB: Gigabyte B360M DS3H Graphic: Gigabyte Geforce GTX1050 OC 2G with driver 399.24 (release at 09/10/2018) Audio driver: 6.0.1.8228 DirectX 12 plugged at 3.5mm add-on I installed: uBlock Origin 1.16.20 IDM integration module 6.31.2 FireFox version: 62.0 Windows version: Windows 10 edu 1803(OS 17164.285)
Was this helpful to you?
Quote
Pkshadow 1070 solutions 14836 answers

Hi, ok let's start at the very beginning : Please give your self a scan with : https://www.malwarebytes.com/

Please look at your Specs for Audio or the CD that came with the System and figure out what drivers/program is being used and if it was Realtek. If the Realtek and the icon is not in the Task Bar then figure out why your sound program is not there. This maybe the issue.

We can not shoot in the dark.

Go back to the beginning an look at what you should be running. f need some help great but, find the info that came with your computer for answers.

Hi, ok let's start at the very beginning : Please give your self a scan with : https://www.malwarebytes.com/ Please look at your Specs for Audio or the CD that came with the System and figure out what drivers/program is being used and if it was Realtek. If the Realtek and the icon is not in the Task Bar then figure out why your sound program is not there. This maybe the issue. We can not shoot in the dark. Go back to the beginning an look at what you should be running. f need some help great but, find the info that came with your computer for answers.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16655 solutions 150534 answers

.ts files are streams

You didn't make changes to media*cache prefs on the about:config page since it is sometimes suggested to modify prefs in order to cache the whole vidoe.

You can check these pref s on the about:config page and make sure they all have the default value, if necessary reset user set (bold) media*cache prefs via the right-click context menu to the default value.

  • media.cache_readahead_limit
  • media.cache_resume_threshold
.ts files are streams You didn't make changes to <b>media*cache</b> prefs on the <b>about:config</b> page since it is sometimes suggested to modify prefs in order to cache the whole vidoe. You can check these pref s on the <b>about:config</b> page and make sure they all have the default value, if necessary reset user set (bold) media*cache prefs via the right-click context menu to the default value. *media.cache_readahead_limit *media.cache_resume_threshold
Was this helpful to you?
Quote

Question owner

cor-el said

.ts files are streams You didn't make changes to media*cache prefs on the about:config page since it is sometimes suggested to modify prefs in order to cache the whole vidoe. You can check these pref s on the about:config page and make sure they all have the default value, if necessary reset user set (bold) media*cache prefs via the right-click context menu to the default value.
  • media.cache_readahead_limit
  • media.cache_resume_threshold

Yeah, they are all default, 60 and 30.

''cor-el [[#answer-1154643|said]]'' <blockquote> .ts files are streams You didn't make changes to <b>media*cache</b> prefs on the <b>about:config</b> page since it is sometimes suggested to modify prefs in order to cache the whole vidoe. You can check these pref s on the <b>about:config</b> page and make sure they all have the default value, if necessary reset user set (bold) media*cache prefs via the right-click context menu to the default value. *media.cache_readahead_limit *media.cache_resume_threshold </blockquote> Yeah, they are all default, 60 and 30.
Was this helpful to you?
Quote

Question owner

Pkshadow said

Hi, ok let's start at the very beginning : Please give your self a scan with : https://www.malwarebytes.com/ Please look at your Specs for Audio or the CD that came with the System and figure out what drivers/program is being used and if it was Realtek. If the Realtek and the icon is not in the Task Bar then figure out why your sound program is not there. This maybe the issue. We can not shoot in the dark. Go back to the beginning an look at what you should be running. f need some help great but, find the info that came with your computer for answers.

driver vertion is Realtek 6.0.1.8228, and there is an icon in my taskbar.

''Pkshadow [[#answer-1154499|said]]'' <blockquote> Hi, ok let's start at the very beginning : Please give your self a scan with : https://www.malwarebytes.com/ Please look at your Specs for Audio or the CD that came with the System and figure out what drivers/program is being used and if it was Realtek. If the Realtek and the icon is not in the Task Bar then figure out why your sound program is not there. This maybe the issue. We can not shoot in the dark. Go back to the beginning an look at what you should be running. f need some help great but, find the info that came with your computer for answers. </blockquote> driver vertion is Realtek 6.0.1.8228, and there is an icon in my taskbar.
Was this helpful to you?
Quote
FFus3r
  • Top 10 Contributor
50 solutions 757 answers

scan your system for malwares, antivirus, toolbars, adwares, clean your system from unwanted registries.

try these:


and try to reduce the number of Multiprocesses:

Go to the 3-bar menu > Options (General) - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to 1 or 2.

scan your system for malwares, antivirus, toolbars, adwares, clean your system from unwanted registries. try these: * https://www.malwarebytes.com/mwb-download/ * https://www.malwarebytes.com/adwcleaner/ * https://www.ccleaner.com/ccleaner * https://www.hitmanpro.com/en-us/hmp.aspx * https://www.iobit.com/en/advancedsystemcarefree.php ------------------------------ and try to reduce the number of Multiprocesses: Go to the 3-bar menu > Options (General) - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to 1 or 2.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.