Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why can't I create an exception for "Your connection is not secure"?

  • 1 reply
  • 1 has this problem
  • 15 views
  • Last reply by cor-el

more options

Hi, I have access to my CISCO router through the web management console on a specific port (let's say port 12345). When I try to access https://files.mydomain.com:12345, I get:

Your connection is not secure

The owner of files.nextscantechnology.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox may only connect to it securely. As a result, it is not possible to add an exception for this certificate.

I can't create an exception!

When I try to access https://support.mydomain.com:12345, I get:

Your connection is not secure

The owner of nws.nextscantechnology.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

And I can create an exception! I know the warning is because the certificate in my router is a self-signed certificate by CISCO, but why can't I create an exception in the first case? Both domains point to the same router.

Tom

Chosen solution

If you previously stored an exception then try to remove this exception in the Certificate Manager on the Servers tab.

  • Options/Preferences -> Privacy & Security
    Certificates: View Certificates

You can check the SiteSecurityServiceState.txt file in the profile folder for references for this domain and remove the corresponding lines. Make sure that Firefox is closed when you make changes to files in the profile folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

If you previously stored an exception then try to remove this exception in the Certificate Manager on the Servers tab.

  • Options/Preferences -> Privacy & Security
    Certificates: View Certificates

You can check the SiteSecurityServiceState.txt file in the profile folder for references for this domain and remove the corresponding lines. Make sure that Firefox is closed when you make changes to files in the profile folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.