X
Tap here to go to the mobile version of the site.

Support Forum

YouTube videos go to the right side and not their intended position

Posted

This just recently happened to me, when using the old YouTube layout, YouTube videos go to the right side, and not their intended position, I'm not sure if this is completely YouTube's problem, or is it Firefox's, I've already cleared my cookies and login information, turned off TamperMonkey (the add-on which gives the old YouTube layout), switched scripts, restarted (multiple times) and I still get the same issue. When zoomed out the video goes waaaayy to the right side, going to the default zoom doesn't fix anything. New YouTube does seem to work, but I just don't overall like it.

This just recently happened to me, when using the old YouTube layout, YouTube videos go to the right side, and not their intended position, I'm not sure if this is completely YouTube's problem, or is it Firefox's, I've already cleared my cookies and login information, turned off TamperMonkey (the add-on which gives the old YouTube layout), switched scripts, restarted (multiple times) and I still get the same issue. When zoomed out the video goes waaaayy to the right side, going to the default zoom doesn't fix anything. New YouTube does seem to work, but I just don't overall like it.

Chosen solution

On Reddit, someone posted a style rule workaround. The easiest way to apply style rule workarounds to websites is to use the Stylus extension. However, I don't know if it is annoying enough to do that:

Read this answer in context 2
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 29.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

jscher2000
  • Top 10 Contributor
7867 solutions 64113 answers

Google is always changing things on their sites... You've already tried some of the things on the following "general stuff to try" list, so skip over things that you've already done:

Double-check content blockers: Firefox's Tracking Protection feature and extensions that counter ads and tracking may break websites that weren't built to operate normally without the blocked components.

Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content Blocking (formerly Tracking Protection).

Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Google is always changing things on their sites... You've already tried some of the things on the following "general stuff to try" list, so skip over things that you've already done: '''Double-check content blockers:''' Firefox's Tracking Protection feature and extensions that counter ads and tracking may break websites that weren't built to operate normally without the blocked components. Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: [[Tracking Protection]]. Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data" * (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data" * click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7867 solutions 64113 answers

Helpful Reply

Oh hey, here's a similar thread from this afternoon, still unsolved:

I have a strange kind of problem with Youtube layout wide

Oh hey, here's a similar thread from this afternoon, still unsolved: [https://support.mozilla.org/questions/1229976 I have a strange kind of problem with Youtube layout wide]
Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
7867 solutions 64113 answers

In case there's a delay before the Tampermonkey script is updated, some other possible options to revert YouTube to the old layout are:

In case there's a delay before the Tampermonkey script is updated, some other possible options to revert YouTube to the old layout are: * https://www.youtube.com/?disable_polymer=1 * https://addons.mozilla.org/firefox/addon/youtube-classic/ (I haven't tried this myself)
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7867 solutions 64113 answers

Chosen Solution

On Reddit, someone posted a style rule workaround. The easiest way to apply style rule workarounds to websites is to use the Stylus extension. However, I don't know if it is annoying enough to do that:

On Reddit, someone posted a style rule workaround. The easiest way to apply style rule workarounds to websites is to use the Stylus extension. However, I don't know if it is annoying enough to do that: * https://www.reddit.com/r/firefox/comments/97wiow/youtube_layout_bug_suddenly_appeared/ <br>&nbsp;&nbsp;#player {<br>&nbsp;&nbsp;&nbsp;&nbsp;max-width: none !important;<br>&nbsp;&nbsp;} * https://addons.mozilla.org/firefox/addon/styl-us/
Was this helpful to you? 2
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.