Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps spontaneously crashing/quitting on Mac

  • 1 reply
  • 1 has this problem
  • 12 views
  • Last reply by Shadow110

more options

Firefox spontaneously quits on me, multiple times a day, sometimes once an hour. I am not on the same website or doing the same tasks each time it happens. Sometimes I won't have any windows open, but when I go to use it, it's not open. I've even had windows in the background or minimized when it happens. I've had my IT person look at it, but he can't figure it out the problem. I've tried resetting FF, uninstalling and reinstalling, updating my operating system, changing my preferences, disabling my extensions, started in safe mode, etc.—but nothing works. When I go to about:crashes, the page says "No crash reports have been submitted." It's like FF doesn't even know it crashed, yet when I go to reopen it after it has, it will ask if I want to restore my session.

I am on an iMac with OS High Sierra and Firefox Quantum 61.0.2.

Someone please help. This is getting really frustrating!

All Replies (1)

more options

HI, Please do a scan 1st : https://www.malwarebytes.com/mac/

SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st:

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :