Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to set file type .swf to open in shockwave plugin

  • 5 replies
  • 1 has this problem
  • Last reply by amos083

more options

Firefox 61 on Ubuntu. When I try to open .swf files, it tries to use the system's video display application, which cannot handle it (because it's not a video).

In Preferences->Applications there are 3 entries for SWF file type: application/x-shockwave-flash and application/futuresplash which are assigned to Shockwave Flash plugin, and application/, which is assigned to Videos (and does not has an option for the plugin in its drop-down menu).

Somehow, all SWF files are assumed to be of the last type, which does not work. How can I assign all SWF files to the plugin?

Chosen solution

Found the answer here Basically, it requires changing the mime type in /usr/share/mime/packages/

Read this answer in context 👍 0

All Replies (5)

more options

This may be your problem,

Firefox v52+ Releases disables all plugins except for Flash Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work? {web link}

more options

FredMcD said

This may be your problem,

Shockwave Flash is old name for Flash Player so no it s not related.

more options

You can check the handlers.json file in the profile folder.

You can also check all involved MIME types in the OS.

  • xdg-mime query default <MIME type>
more options

Thanks everyone. I should have said that I'm aware that newer versions of Firefox block the Shockwave plugin by default; I have already taken care of that. This plugin did work before, it's just that the mime type which is assigned to SWF file type does not use it.

xdg-mime query shows that indeed all .swf files are assigned to mime type application/ It seems the trouble had started with installation of a new video application, which might have messed up file type.

So the question is really how to restore the association of .swf file extension with mime type application/x-shockwave-flash, and / or how to convince Firefox to use the plugin for all mime types which are associated with SWF files?

Thanks much.

more options

Chosen Solution

Found the answer here Basically, it requires changing the mime type in /usr/share/mime/packages/