X
Tap here to go to the mobile version of the site.

Support Forum

"Check spelling as I type" spell checker/autocorrect not working

Posted

I've had Firefox installed for months, but this weekend the spell checker/auto correct (red squiggly lines under the words I spell wrong), has stopped working. I haven't installed any new plugins/add ons or changed anything in Firefox.

I've even completely re-installed Firefox this morning in the hope to solve the problem - no luck.

I'm on Mac OSX High Sierra (10.13.6).

The tick box to check my spelling as I type is checked.

Screenshot shows I have my correct language selected.

I'm all out of ideas - please help :D

I've had Firefox installed for months, but this weekend the spell checker/auto correct (red squiggly lines under the words I spell wrong), has stopped working. I haven't installed any new plugins/add ons or changed anything in Firefox. I've even completely re-installed Firefox this morning in the hope to solve the problem - no luck. I'm on Mac OSX High Sierra (10.13.6). The tick box to check my spelling as I type is checked. Screenshot shows I have my correct language selected. I'm all out of ideas - please help :D
Attached screenshots

Modified by linziloop

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

FredMcD
  • Top 10 Contributor
4267 solutions 59838 answers

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar. Type: '''layout.spellcheckDefault''' Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes. Also, check the '''spellchecker.dictionary''' entry. https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

Question owner

FredMcD said

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes. Also, check the spellchecker.dictionary entry. https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

If everything is set up correctly, what value should I be seeing? 1, or 2? I did this this morning, and the value said "1"

''FredMcD [[#answer-1138401|said]]'' <blockquote> Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar. Type: '''layout.spellcheckDefault''' Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes. Also, check the '''spellchecker.dictionary''' entry. https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker </blockquote> If everything is set up correctly, what value should I be seeing? 1, or 2? I did this this morning, and the value said "1"
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

Your screenshot shows the setting for the request header that is send to the server. This has nothing to do with the spelling checker.

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

Note that you need a dictionary and not a language pack (string translations for the user interface).

You can check the layout.spellcheckDefault pref on the about:config page. You can reset the layout.spellcheckDefault pref via the right-click context menu.

Your screenshot shows the setting for the request header that is send to the server. This has nothing to do with the spelling checker. Do you have a dictionary installed and selected? You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected. *open the "Add Dictionaries" link to install a dictionary if you do not have one. The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark. You can enable or disable spell checking globally: *Options/Preferences -> General: Browsing: "Check my spelling as I type" You can look here for dictionaries: *https://addons.mozilla.org/firefox/language-tools/ Note that you need a dictionary and not a language pack (string translations for the user interface). You can check the layout.spellcheckDefault pref on the <b>about:config</b> page. You can reset the layout.spellcheckDefault pref via the right-click context menu.

Question owner

cor-el said

Your screenshot shows the setting for the request header that is send to the server. This has nothing to do with the spelling checker. Do you have a dictionary installed and selected? You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.
  • open the "Add Dictionaries" link to install a dictionary if you do not have one.
The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark. You can enable or disable spell checking globally:
  • Options/Preferences -> General: Browsing: "Check my spelling as I type"
You can look here for dictionaries: Note that you need a dictionary and not a language pack (string translations for the user interface). You can check the layout.spellcheckDefault pref on the about:config page. You can reset the layout.spellcheckDefault pref via the right-click context menu.

When I right click in a text area, I don't get a 'languages' option (see attached screenshot)

I have 'check spelling as I type" selected (see second attached screenshot)

I guess I need to check if I have a dictionary installed (although I don't see why it would have been working a couple of weeksa ago and not now), but how do I do that?

''cor-el [[#answer-1138453|said]]'' <blockquote> Your screenshot shows the setting for the request header that is send to the server. This has nothing to do with the spelling checker. Do you have a dictionary installed and selected? You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected. *open the "Add Dictionaries" link to install a dictionary if you do not have one. The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark. You can enable or disable spell checking globally: *Options/Preferences -> General: Browsing: "Check my spelling as I type" You can look here for dictionaries: *https://addons.mozilla.org/firefox/language-tools/ Note that you need a dictionary and not a language pack (string translations for the user interface). You can check the layout.spellcheckDefault pref on the <b>about:config</b> page. You can reset the layout.spellcheckDefault pref via the right-click context menu. </blockquote> When I right click in a text area, I don't get a 'languages' option (see attached screenshot) I have 'check spelling as I type" selected (see second attached screenshot) I guess I need to check if I have a dictionary installed (although I don't see why it would have been working a couple of weeksa ago and not now), but how do I do that?
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

You need to right-click in the text area like "Post a reply" used on this forum and check the Languages sub menu like posted above.

You need to right-click in the text area like "Post a reply" used on this forum and check the Languages sub menu like posted above.