Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

OpenSuse system total freeze

  • 5 replies
  • 4 have this problem
  • 735 views
  • Last reply by Marouane87

more options

Hello,

I'm using Firefox 61.0.1 64bit with Opensuse Tumbleweed (Gnome). Recently (Not sure but maybe everything started after a distribution upgrade including Firefox and some drivers), Firefox causes the whole system to freeze when visiting some websites (including Yahoo email login, this page while trying to post a question here or even the command about:support) and the only solution is to hard reset.

I tried everything (a clean reinstall, a new profile, disabling Hardware acceleration, disabling the plugins and the add-ons) but nothing seems to work except the safe mode (that I'm using right now).

Any help would be appreciated. Thank you very much.

Modified by Marouane87

Chosen solution

Pkshadow said

Hi, In Firefox Safe mode these changes are effective:
  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
  • https://support.mozilla.or/kb/Troubleshooting+extensions+and+themes

Thank you. I tried disbaling the javascript option (like shown in the attached image) but the problem still there. So, please, how can I change the settings for:

  • userChrome.css and userContent.css are ignored (chrome folder)

Thank you again.

Edit: I just tried Waterfox which is based on Firefox 56 (I suppose) and Firefox 62 Beta, and they have the same behavior. Firefox 56 used to work fine. So, I think it's somehow related to kernel/graphic card update incompatibility with one of Firefox services which is not used in safe mode... Again any suggestions are welcome and thank you. Edit 2 (Solution!): When webgl.disabled is set to True (in about:config) the problem does not occur anymore... Maybe someone can explain what is this suppose to mean :)

Read this answer in context 👍 1

All Replies (5)

more options

Hi, In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
  • https://support.mozilla.or/kb/Troubleshooting+extensions+and+themes
more options

Chosen Solution

Pkshadow said

Hi, In Firefox Safe mode these changes are effective:
  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
  • https://support.mozilla.or/kb/Troubleshooting+extensions+and+themes

Thank you. I tried disbaling the javascript option (like shown in the attached image) but the problem still there. So, please, how can I change the settings for:

  • userChrome.css and userContent.css are ignored (chrome folder)

Thank you again.

Edit: I just tried Waterfox which is based on Firefox 56 (I suppose) and Firefox 62 Beta, and they have the same behavior. Firefox 56 used to work fine. So, I think it's somehow related to kernel/graphic card update incompatibility with one of Firefox services which is not used in safe mode... Again any suggestions are welcome and thank you. Edit 2 (Solution!): When webgl.disabled is set to True (in about:config) the problem does not occur anymore... Maybe someone can explain what is this suppose to mean :)

Modified by Marouane87

more options

I had the same issue also with Tumbleweed. Tried disable webgl and it works. But this is just a workaround.

more options

Maybe this is the same bug with openSUSE Bugzilla .

more options

流浪猫 said

Maybe this is the same bug with openSUSE Bugzilla .

I think so, as it is the same behavior with the same web pages producing the freeze. The good new, it seems that a patch in on its way :)