Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Option to search via navigation bar doesn't work

  • 5 replies
  • 1 has this problem
  • 5 views
  • Last reply by cor-el

more options

I have clicked the radial button "Use address bar for search and navigation" in settings, but every time I enter a search query in the bar, I get an invalid URL, and I have to change back the settings to add a separate search bar and retry. This is annoying, so I regularly retry to set the field to use address bar for both purposes and it hasn't worked in weeks. I have updated Firefox, restarted, tried over and over again, it still doesn't work. It worked a few weeks ago without any effort on my part (it must have been the default setting). It stopped working suddently, so I tried changing back-and-forth in settings but no cigar. What is going wrong?

All Replies (5)

more options

HI, no idea, possible a corrupted file during a update or a shut down.

Please : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.1 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

You could check on the about:config page if the value to the preference keyword.enabled is still set to true ......

In case you've never visited the 'about:config' page before, here's how :

Type in the address bar about:config and press Enter. Promise to be careful, if asked.

Type in the sear bar keyword.enabled and look for that preference. Should the value not be set to 'true', then change it. Close and restart Firefox afterwards.

Also see : https://support.mozilla.org/en-US/kb/search-web-address-bar

more options

This was helpful, but unfortunately that field is locked, and won't allow changes. Is there anything else I can do?

more options

searchbar_assistance said

This was helpful, but unfortunately that field is locked, and won't allow changes. Is there anything else I can do?

Bummer  ! But it explains why your setting in Options won't work. I must admit that I don't know how to unlock prefs - keeping my fingers crossed that somebody else does, and will come to your rescue ....

I found this (look under 2.4 Undoing) : http://kb.mozillazine.org/Locking_preferences#Undoing

And I found this thread (see 'Chosen Solution') : https://support.mozilla.org/en-US/questions/1103268

more options

Do you have a computer that is setup by an IT department?

If that is the case then you should contact them about how to proceed.

Note that you can move the search bar to the overflow (>>) area on the Navigation Toolbar for easier access.