X
Tap here to go to the mobile version of the site.

Support Forum

Can't play .m3u files from FF, worked in past

Posted

I have a html page, which references local .m3u files using file:/// In the past, clicking on such a link ran Winamp (default mp3/m3u player on my system) Currently, files are opened as a plain text, and Firefox does not care about the extension.

Opening .m3u from webserver works, as the webserver sends the correct mimetype.

So the question is more precisely: How to convince FFox, that file:///*.m3u has filetype audio/x-mpegurl

Handlers.json does contain this: "audio/x-mpegurl":{"action":2,"handlers":[{"name":"wInAmP","path":"D:\\Program Files (x86)\\Winamp\\winamp.exe"}],"extensions":["m3u"]}

I have a html page, which references local .m3u files using file:/// In the past, clicking on such a link ran Winamp (default mp3/m3u player on my system) Currently, files are opened as a plain text, and Firefox does not care about the extension. Opening .m3u from webserver works, as the webserver sends the correct mimetype. So the question is more precisely: How to convince FFox, that file:///*.m3u has filetype audio/x-mpegurl Handlers.json does contain this: "audio/x-mpegurl":{"action":2,"handlers":[{"name":"wInAmP","path":"D:\\Program Files (x86)\\Winamp\\winamp.exe"}],"extensions":["m3u"]}

Chosen solution

Okay, so I kinda solved it by myself. When I generate the file to have links to local m3u files, I did this: <a href="file:///something.m3u"> changing it to <a href="file:///something.m3u" type="audio/x-mpegurl"> convinces Firefox to handle the file correctly as m3u playlist.

So there is definitely some change in processing the local files - because this explicit mime type was not needed in the past, but this does override it.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

Shadow110 1072 solutions 14836 answers

HI, possibly reinstall Winamp at let it hook to everything when asked when do a custom install. That I would hope would shove the file type into Options --> Applications. If not looked there please do so and see if it is. If is tell Firefox what to do with it it not do with it.

HI, possibly reinstall Winamp at let it hook to everything when asked when do a custom install. That I would hope would shove the file type into Options --> Applications. If not looked there please do so and see if it is. If is tell Firefox what to do with it it not do with it.

Question owner

That's not my problem - it's in the Options/Applications and it works, if the m3u file is served from http:// link. It does not work when it's served by local file:/// link. For some reason FFox thinks it has mimetype text/plain.

That's not my problem - it's in the Options/Applications and it works, if the m3u file is served from http:// link. It does not work when it's served by local file:/// link. For some reason FFox thinks it has mimetype text/plain.
WestEnd 60 solutions 5387 answers

That to me indicates the link to the right file isn't the link FF sees when it downloads. That's what I'm get from the read here.

That to me indicates the link to the right file isn't the link FF sees when it downloads. That's what I'm get from the read here.

Question owner

Bump. On the latest FFox (61.0.1, 64bit, eng), local .m3u files are still considered by Firefox to be plain text, and not good enough to be sent to mp3 player.

Bump. On the latest FFox (61.0.1, 64bit, eng), local .m3u files are still considered by Firefox to be plain text, and not good enough to be sent to mp3 player.

Chosen Solution

Okay, so I kinda solved it by myself. When I generate the file to have links to local m3u files, I did this: <a href="file:///something.m3u"> changing it to <a href="file:///something.m3u" type="audio/x-mpegurl"> convinces Firefox to handle the file correctly as m3u playlist.

So there is definitely some change in processing the local files - because this explicit mime type was not needed in the past, but this does override it.

Okay, so I kinda solved it by myself. When I generate the file to have links to local m3u files, I did this: <a href="file:///something.m3u"> changing it to <a href="file:///something.m3u" type="audio/x-mpegurl"> convinces Firefox to handle the file correctly as m3u playlist. So there is definitely some change in processing the local files - because this explicit mime type was not needed in the past, but this does override it.