Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Change search results from to

  • 4 replies
  • 1 has this problem
  • Last reply by Shadow110

more options

For some reason when I search using the address bar, or the search box in top right of the screen. Both bring back results. The only way I can search with is going to my hompage and searching from there.

This seems to be quite a new thing, but it's really annoying. Does anyone know a way to change back to

Also is there a way to get your homepage to open, everytime you open a new tab?


All Replies (4)

more options

Separate Security Issue, please update your Flash 28.0 r0 Flash Player Version: Current Version Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Hi, you do not say what your Homepage is. Is it all the Tiles as that would be extreme bandwidth use if loading them each time. If have all the tiles turned off can use this to set it up how ever you would like :

This should be what you are looking for :

Please let us know if this solved your issue or if need further assistance.

more options

Hi blades740, for years and years, if you were a U.K. user and Firefox sent a search to the main .com site, Google would redirect you. That seems to have changed at some point this year, so you could install a custom Google search plugin directed to the U.K. site as a workaround. Pkshadow linked to one on the Add-ons site, and here's another source if that one doesn't suit:

more options


Thanks for replies. Surely this is a problem that has effected every UK user of Firefox.

Just seem really strange that you can't set Firefox up for the UK. Everytime I search I don't want US results.

Anyway I have added the add on and all seems to working fine.


more options

HI, am in Canada and when I clicked the Google Icon in the Search Bar I would get a Canadian Doodle. So it even though says .com I was getting Canada search results. Can not say for others but was what was going on for me and still does, The minus - tag while searching is a good one. so search keywords - minus USA or what ever you do not want to get into the results. ie blankets - (minus) red.

Happy Searching, glad is fixed.

If you could please Mark the Solution next to the question that solved the issue so others can find it.