Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't get Gmail 2-step verification "Don't ask me again on this computer" box to not be checked by default-it is a cookie issue, please advise

  • 2 replies
  • 1 has this problem
  • 414 views
  • Last reply by jscher2000

more options

I have Gmail 2-step verification turned on. When I go to enter the code to login, by default the "Don't ask me again on this computer" box is always checked. Then the laptop is trusted for future logins and Gmail doesn't ask me for a code again. Google Forum is saying it is some setting with my cookies whereby Firefox is remembering to always check that "Don't ask me again on this computer". Please advise-thanks

Chosen solution

If you think an existing Google cookie is triggering Firefox to check a box it doesn't normally check, you can remove some or all of the Google cookies.

While viewing the page, call up the Storage Inspector using either

  • "3-bar" menu button > Web Developer > Storage Inspector
  • (menu bar) Tools > Web Developer > Storage Inspector
  • (Windows) Shift+F9

In the panel, there is a cookies section where you can see what cookies are used in the page. The right-click context menu lets you clear individual cookies or all of them.

To force a change to the page after deleting its cookies, reload the page in the top part of the tab.

Any improvement?

Read this answer in context 👍 0

All Replies (2)

more options

Check you FF settings also you should use the Google apps mobile verification that is faster and better.

more options

Chosen Solution

If you think an existing Google cookie is triggering Firefox to check a box it doesn't normally check, you can remove some or all of the Google cookies.

While viewing the page, call up the Storage Inspector using either

  • "3-bar" menu button > Web Developer > Storage Inspector
  • (menu bar) Tools > Web Developer > Storage Inspector
  • (Windows) Shift+F9

In the panel, there is a cookies section where you can see what cookies are used in the page. The right-click context menu lets you clear individual cookies or all of them.

To force a change to the page after deleting its cookies, reload the page in the top part of the tab.

Any improvement?