Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cookies in "Cookies and Site Data" not taking effect until you restart

more options

When I go into "Manage Data" under the "Cookies and Site Data" section in "Privacy and Security" I type in the Top Level Domain of my Localhost to show me the cookies I have stored for them.

When I delete them I refresh the page with the associated cookie I have just deleted and it does not log you out or remove the custom features.

The new Cookie Management process is horrid and long winded with extra click boxes, in the previous version you just clicked "Remove Individual Cookies" search for my TLD and delete them and it took effect right away!

Modified by CleverleyDone

Chosen solution

I think that you need to refresh the about:preferences page to update data shown in the Manage Data pop-up.

Read this answer in context 👍 1

All Replies (4)

more options

You have to refresh the about:preferences#privacy page to get the cookies to appear or disappear.

more options

Hmm, usually if you select the site, click Remove Selected, then click Save Changes in the lower right corner, when you re-open that dialog they will be done gone. But I believe you do need to reload the page to show any new cookies.

Some users reported they cannot see the Cancel and Save Changes buttons. This could occur if the zoom level is high (try holding down Ctrl and tapping the - key), or if the box needs to be expanded (click and drag down on the "grippy" at the lower right corner of the box).


By the way, if you want to more quickly remove cookies for a page you're viewing, you can try the Storage Inspector. It opens in the developer tools panel in the lower part of the tab. It has a reload arrow above the list for times when it, too, is stubbornly showing cookies you know you removed.

https://developer.mozilla.org/docs/Tools/Storage_Inspector

Modified by jscher2000

more options

Chosen Solution

I think that you need to refresh the about:preferences page to update data shown in the Manage Data pop-up.

more options

jscher2000 said

Great help, thanks :)