Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

turn off recently bookmarked

  • 11 replies
  • 3 have this problem
  • 5372 views
  • Last reply by jscher2000

more options

How do you not display recently bookmarked? It's annoying that anyone can see your recently bookmarked websites. I don't want anyone to see what I recently bookmarked. OS Name Microsoft Windows 10 Home Version 10.0.17134 Build 17134 Firefox 60.0.2 (64-bit) Thank you Mike

Chosen solution

The filename needs to be userChrome.css (case sensitive) and the file needs to be in the chrome folder that shows in the screenshot. This is the content of userChrome.css. You can leave out sections that you do not want to remove


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* hide Recently Bookmarked */
#panelMenu_recentBookmarks,
#panelMenu_bookmarksMenu {
  display:none!important;
}

/* hide Recent History */
#PanelUI-history label[value="Recent History"],
#appMenu_historyMenu {
  display:none!important;
}

/* hide Recent Highlights */
#appMenu-libraryView label[value="Recent Highlights"],
#appMenu-library-recentHighlights {
  display:none!important;
}

/* hide recently closed tabs/windows */
#appMenuRecentlyClosedTabs,
#appMenuRecentlyClosedWindows {
  display:none!important;
}
Read this answer in context 👍 0

All Replies (11)

more options

TyDraniu said

https://support.mozilla.org/questions/1140009

That thread is from 09/2016 with the Australis User Interface, it's different now with Quantum in Firefox 57 and later builds.


mikehowse, See if this more recent Solution from after Firefox 57 was released achieves your goal. A different "bookmarks" button. https://support.mozilla.org/en-US/questions/1198446#answer-1060626

more options

Thank you TyDraniu, But I have already tried both options. That’s why this is so frustrating. Solution 1. When I right click on Recently Bookmarked nothing happens, and nothing happens when I right click on it either. I do not get the menu in your screen shot.

Solution 2. I enter about:config in a new tab I enter book in the search and wait. Well browser.bookmarks.showRecentlyBookmarked Is not in the list.

So now what? Uninstall and start over? Thank you Mike

more options

Hi, it is pretty baked in. I do not delete mine but the Right Click Option is available from the Menu Bar. Options --> Customize --> bottom of page Toolbars and turn on Menu Bar or mouse to top of browser and Right Click to turn it on.

So ya, delete is a option for me there but never done it.

more options

See:

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* hide Recently Bookmarked */
#panelMenu_recentBookmarks,#panelMenu_bookmarksMenu {display:none!important;}
/* hide Recent History */
#PanelUI-history label[value="Recent History"], #appMenu_historyMenu {display:none!important;}
/* hide Recent Highlights */
#appMenu-libraryView label[value="Recent Highlights"], #appMenu-library-recentHighlights {display:none!important;}
/* hide recently closed tabs/windows */
#appMenuRecentlyClosedTabs, #appMenuRecentlyClosedWindows {display:none!important;}

Modified by cor-el

more options

Whoops, cor-el beat me to it.

Hi Mike, the old solutions do not work in Firefox 57+, as mentioned by the-edmeister.

In order to hide the list that appears on the Library button, Bookmarks section, you can use a custom style rule in a userChrome.css file. I realize what I just said is a bit of a foreign language, but if you have 10 minutes to focus on it, here's how it works, and a screenshot with a "before and after" comparison:

(A) Create a new chrome folder in your profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)

https://www.userchrome.org/how-create-userchrome-css.html

I have voiceover videos for both Windows and Mac, on that same page.

If you already have this folder, skip to (B).

(B) Set your OS to show file extensions

See Step #4 in the above article.

(C) Download the following blank file and move it into your new chrome folder

https://www.userchrome.org/samples/userChrome.css

(D) Open the file in Notepad or another text editor and add style rules

Don't let Microsoft Word or another word processor add formatting codes.

/* Library Button > Bookmarks: Hide "Recently Bookmarked" */
#PanelUI-bookmarks #panelMenu_recentBookmarks, 
#PanelUI-bookmarks #panelMenu_bookmarksMenu {
  display: none !important;
}

/* Library button: Hide Bookmarks in "Recent Highlights" */
#appMenu-library-recentHighlights [type="highlight-bookmark"] {
  display: none !important;
}

The next time you quit Firefox and start it up again, it should discover that file and apply the rules.

Success?

Modified by jscher2000

more options

I know you are as tired of me as I am trying to do this. I think I followed the instructions correctly. My results are the same. Maybe I misunderstood the instructions IDK. My attempt at this is in the attached. So after you get through laughing, tell me what I did wrong. Thank you for your patience! Mike

more options

Chosen Solution

The filename needs to be userChrome.css (case sensitive) and the file needs to be in the chrome folder that shows in the screenshot. This is the content of userChrome.css. You can leave out sections that you do not want to remove


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* hide Recently Bookmarked */
#panelMenu_recentBookmarks,
#panelMenu_bookmarksMenu {
  display:none!important;
}

/* hide Recent History */
#PanelUI-history label[value="Recent History"],
#appMenu_historyMenu {
  display:none!important;
}

/* hide Recent Highlights */
#appMenu-libraryView label[value="Recent Highlights"],
#appMenu-library-recentHighlights {
  display:none!important;
}

/* hide recently closed tabs/windows */
#appMenuRecentlyClosedTabs,
#appMenuRecentlyClosedWindows {
  display:none!important;
}

Modified by cor-el

more options

Duh, Thank YOU, for the filename correction. It works PERFECT. Can't THANK YOU enough, I appreciate your efforts to resolve this for me. Mike

more options

I'm not a programmer, and I don't have time to figure it out. Easy solution is to use a different browser. I expect the Recently Bookmarked program is a deal breaker for many clients.

Even Tor browser uses Firefox, and so it has the tell-tale Recently Bookmarked list for anyone who opens your browser. You can't delete the list, it's separate from History. It's pretty stupid when you think about it.

more options

Hi Greycatz, why are people opening your browser that you don't want to see your bookmarks? Shouldn't you lock your computer so they at least need a password to access it?

Anyway, you do not have to use the Library button if you don't like its lists and don't want to go through the hassle of hiding them. You can remove it from the toolbar and instead use the separate Bookmarks Menu and History buttons. That all takes about 60 seconds in the Customize tab. See: Customize Firefox controls, buttons and toolbars.

Or if it's faster for you, use a different browser. Is there a browser where you can't view the bookmarks/favorites and sort by date added? Hmm...