Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 60 blocking many sites recuiring security certificates

  • 4 replies
  • 1 has this problem
  • 32 views
  • Last reply by EF80

more options

Installed latest Firefox on a new win 10 installation and many websites are blocked with security certificate error.... ITV News was one of them along with Facebook, the date and time are right, as well as the year.

The sites work OK 'on this' Win 7 computer with Firefox 46.0.1 - Yes I KNOW it's out of date - it works flawless 'for me' this is not the issue!

Can anything be done? Dave.

All Replies (4)

more options

Are they all giving the same error message? Different messages? What is the exact error message(s)?

more options

You can check if there is more detail available about the issuer of the certificate.

  • click the "Advanced" button show more detail
  • click the blue SEC_ERROR_UNKNOWN_ISSUER message to show the certificate chain
  • click "Copy text to clipboard" and paste the base64 certificate chain text in a reply

If clicking the SEC_ERROR_UNKNOWN_ISSUER text doesn't provide the certificate chain then try these steps to inspect the certificate.

  • open the Server tab in the Certificate Manager
    • Options/Preferences -> Privacy & Security
      Certificates: View Certificates -> Servers: "Add Exception"
  • paste the URL of the website (https://xxx.xxx) in it's Location field.

Let Firefox retrieve the certificate -> "Get Certificate"

  • click the "View" button and inspect the certificate

You can see detail like the issuer of the certificate and intermediate certificates in the Details tab.

See also:

more options

Just blocked Sky news-:

Google has just configured their website improperly, to protect your info from being stolen FF has not connected you.

The site uses HTTP Strict Transport Security (HSTS) to specify Firefox can only connect to it securely.... it's not possible to add a certificate.

Report this to help Mozilla.


Edit: Also while tryng to download Libre Office I get-: Mozilla PKIX error not got valid issuer certificate.

Firefox is certainly secure.... I get an error when reporting it to them! Its as for as I got at the moment, Dave

Modified by EF80

more options

I THINK I've sorted it, time will tell.

On Windows 10 (and any other windows platforms) go to Internet Options simply typing Internet Options in the run bar will get you there, you'll be greeted with a 'Internet properties' window.

Click the far right 'Advance' tab and scroll down to SSL3 tick the box and reboot.... thats it done!

The sites that were blocked wasn't so after doing this.... time will tell.

Thanks for your time and patience, Dave

I'll give a tip..... keep a book near the computer with all the passwords AND log all the changes you make to the machine.

Modified by EF80