Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Graphics applications blocked since update yesterday in Windows 10 - why? How to fix this?

  • 3 replies
  • 2 have this problem
  • Last reply by rwarson

more options

Since a Windows 10 update on 13th June 2018, graphics applications have been blocked in Firefox (v60.0.2), e.g. Google maps display a black screen.

Attached screenshots

Chosen solution

Problem seems to have been solved by restarting Firefox!

Read this answer in context 👍 0

All Replies (3)

more options

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

This problem appears to have occurred as a result of the recent Windows 10 update. A message was received in the notification area that graphics applications had been blocked in Firefox. Is this being caused by Windows or Firefox? The same version of Firefox on another machine running Windows 7 does not have the problem. Or is the problem with the graphics driver (which is up to date)?

more options

Chosen Solution

Problem seems to have been solved by restarting Firefox!