X
Tap here to go to the mobile version of the site.

Support Forum

After update to 60.0.2(64 bit) get "Secure Connection Failed" and "Error code: SSL_ERROR_RX_RECORD_TOO_LONG" messages

Posted

Firefox automatically updated itself and installed "Firefox Quantum" 60.0.2 I see - 64 bit - on Windows 10 on a Dell laptop.

Never had this problem before - but when loading Ebay pages, the main body of the advert page fails to load and the full message I get instead is below - I've tried switching the proxy settings to "No proxy" or "Use system settings" and sometimes page loads correctly once but then it fails again! Have cleared cache/cookies, have refreshed, have restarted ...

Very frustrating and this is about to lead me to give up finally on Firefox and move to Chrome.

"Secure Connection Failed

An error occurred during a connection to vi.vipr.ebaydesc.com. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.
Firefox automatically updated itself and installed "Firefox Quantum" 60.0.2 I see - 64 bit - on Windows 10 on a Dell laptop. Never had this problem before - but when loading Ebay pages, the main body of the advert page fails to load and the full message I get instead is below - I've tried switching the proxy settings to "No proxy" or "Use system settings" and sometimes page loads correctly once but then it fails again! Have cleared cache/cookies, have refreshed, have restarted ... Very frustrating and this is about to lead me to give up finally on Firefox and move to Chrome. "Secure Connection Failed An error occurred during a connection to vi.vipr.ebaydesc.com. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

FredMcD
  • Top 10 Contributor
4185 solutions 58414 answers

Those type of errors means there is a problem with the certificate.

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate.

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

http://kb.mozillazine.org/Error_loading_websites


‘ssl_error_rx_record_too_long’ or ‘cannot display the webpage’ Internet search; More often than not, you have something misconfigured!

Those type of errors means there is a problem with the certificate. There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate. https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message http://kb.mozillazine.org/Error_loading_websites ‘ssl_error_rx_record_too_long’ or ‘cannot display the webpage’ '''Internet search; ''' More often than not, you have something misconfigured!
FredMcD
  • Top 10 Contributor
4185 solutions 58414 answers

I call for more help.

Note: I tried to go to http://vi.vipr.ebaydesc.com/ but was redirected to an error page.

Also, I looked up that web page and saw others were having problems. Some even thought it was a bad website, others say it's a page only those on eBay already can access.

https://www.bing.com/search?q=vi.vipr.ebaydesc.com&pc=MOZI&form=MOZSBR

I call for more help. Note: I tried to go to http://vi.vipr.ebaydesc.com/ but was redirected to an error page. Also, I looked up that web page and saw others were having problems. Some even thought it was a bad website, others say it's a page only those on eBay already can access. https://www.bing.com/search?q=vi.vipr.ebaydesc.com&pc=MOZI&form=MOZSBR

Question owner

So I've not changed ANY settings prior to this happening.

I've refreshed Firefox, disabled add-ons, I've checked Windows internet options and firewall.

Am about ready to join the 80%+ who've given up on Firefox.

So bad now that Virgin Atlantic specifically ignored Firefox when developing their new website and despite protests, as it doesn;t work - try booking a flight!, they are not going to correct it!

So I've not changed ANY settings prior to this happening. I've refreshed Firefox, disabled add-ons, I've checked Windows internet options and firewall. Am about ready to join the 80%+ who've given up on Firefox. So bad now that Virgin Atlantic specifically ignored Firefox when developing their new website and despite protests, as it doesn;t work - try booking a flight!, they are not going to correct it!

Question owner

Thanks - I've been through ALL those pages and checked/tried the many suggestions.

No change!

The page I'm having the trouble with is all Ebay auction item pages.

I see some Chrome users also are complaining about the "vi.vipr.ebaydesc.com" link failing.

Looking at my version history I was moved from 60.0.1 to 60.0.2 so it's not that but something else that happened in last day or so.

Thanks - I've been through ALL those pages and checked/tried the many suggestions. No change! The page I'm having the trouble with is all Ebay auction item pages. I see some Chrome users also are complaining about the "vi.vipr.ebaydesc.com" link failing. Looking at my version history I was moved from 60.0.1 to 60.0.2 so it's not that but something else that happened in last day or so.

Question owner

I *think* the solution in the end - as things are now displaying correctly (for now!) is that one must turn OFF the Tracking Protection in Firefox. (and of course shut down, restart PC and restart Firefox to be sure).

But strangely Chrome has also started behaving itself over the same issue!

I wonder if this was a genuine case of the web site ( Ebay in this case) having a problem - the "vi.vipr.ebaydesc.com"" link is apparently some back-link to track where you've been on Ebay so you can see recently viewed items etc in a list.

I *think* the solution in the end - as things are now displaying correctly (for now!) is that one must turn OFF the Tracking Protection in Firefox. (and of course shut down, restart PC and restart Firefox to be sure). But strangely Chrome has also started behaving itself over the same issue! I wonder if this was a genuine case of the web site ( Ebay in this case) having a problem - the "vi.vipr.ebaydesc.com"" link is apparently some back-link to track where you've been on Ebay so you can see recently viewed items etc in a list.
FredMcD
  • Top 10 Contributor
4185 solutions 58414 answers

FredMcD said

Those type of errors means there is a problem with the certificate.

Sometimes the certificate itself is bad. Other times it's the computers protection programs causing the issue.

''FredMcD [[#answer-1122549|said]]'' <blockquote> Those type of errors means there is a problem with the certificate. </blockquote> Sometimes the certificate itself is bad. Other times it's the computers protection programs causing the issue.
jscher2000
  • Top 10 Contributor
8568 solutions 70051 answers

UKbasedbrit said

I *think* the solution in the end - as things are now displaying correctly (for now!) is that one must turn OFF the Tracking Protection in Firefox. (and of course shut down, restart PC and restart Firefox to be sure).

Tracking Protection is something of a work in progress. If you use the "shield" icon toward the left end of the address bar to temporarily disable Tracking Protection for the current page, Firefox should reload the page. If the page progressed beyond the desired point, for example, to an error page, you might also need to use the Back button to return to the intended page or the page with the link. And in some cases you might need to do a full reload (Ctrl+Shift+r or Shift-click the reload button) bypassing the cache. You might even need to clear cookies for the site if it has marked you as an undesirable.

But you shouldn't need to exit Firefox or shut down the PC just for this.

''UKbasedbrit [[#answer-1122849|said]]'' <blockquote> I *think* the solution in the end - as things are now displaying correctly (for now!) is that one must turn OFF the Tracking Protection in Firefox. (and of course shut down, restart PC and restart Firefox to be sure). </blockquote> Tracking Protection is something of a work in progress. If you use the "shield" icon toward the left end of the address bar to temporarily disable Tracking Protection for the current page, Firefox should reload the page. If the page progressed beyond the desired point, for example, to an error page, you might also need to use the Back button to return to the intended page or the page with the link. And in some cases you might need to do a full reload (Ctrl+Shift+r or Shift-click the reload button) bypassing the cache. You might even need to clear cookies for the site if it has marked you as an undesirable. But you shouldn't need to exit Firefox or shut down the PC just for this.
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156710 answers

Maybe also check the connection settings to make sure that you aren't using a proxy or other software that acts as a man-in-the-middle.

Maybe also check the connection settings to make sure that you aren't using a proxy or other software that acts as a man-in-the-middle.
Travelingelk 0 solutions 13 answers

I am having this same problem except it doesn't involbe E-Bay. This just started a day or so ago when I would try to do a search (either google or bing) using either the address bar or the search bar. I just checked my version and it says that I am running version 61.0b (64-bit) and that I am on the beta update channel. I have been using Firefox for lmost 5-years now but, this is getting ridiculous. I have donated money the the Mozilla cause, but no more. I am about ready to switch to Chrome!

I am having this same problem except it doesn't involbe E-Bay. This just started a day or so ago when I would try to do a search (either google or bing) using either the address bar or the search bar. I just checked my version and it says that I am running version 61.0b (64-bit) and that I am on the beta update channel. I have been using Firefox for lmost 5-years now but, this is getting ridiculous. I have donated money the the Mozilla cause, but no more. I am about ready to switch to Chrome!
FredMcD
  • Top 10 Contributor
4185 solutions 58414 answers

AZCowboy

Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new Select the product for what the problem is (Firefox or whatever).

Now select the category for the problem. At the bottom is Other.

Describe the problem in brief (one line). Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; None Of These Solve My Problem.

Now enter all the relative information on the problem. At the bottom of this, you can Add Images.

Under this is Troubleshooting Information. Please press the Share Data button. This will let us look at your system details. No Personal Information Is Collected.

'''AZCowboy''' Please go to the top of any '''support.mozilla.org''' web page and use the '''Ask A Question link; https://support.mozilla.org/en-US/questions/new''' Select the product for what the problem is (Firefox or whatever). Now select the category for the problem. At the bottom is Other. Describe the problem in brief (one line). Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; '''None Of These Solve My Problem.''' Now enter all the relative information on the problem. At the bottom of this, you can Add Images. Under this is '''Troubleshooting Information.''' Please press the '''Share Data button.''' This will let us look at your system details. '''No Personal Information Is Collected.'''
jscher2000
  • Top 10 Contributor
8568 solutions 70051 answers

Hi AZCowboy, the SSL_ERROR_RX_RECORD_TOO_LONG message is relatively uncommon and based on threads I've seen, usually temporary with no clear cause or solution.

To work around possible cache issues, could you test Google and Bing in a private window? (If you always use private browsing, then you could quit/restart Firefox to test.)

P.S. If you are getting a different SEC_ERROR or SSL_ERROR code, please start a new thread.

Hi AZCowboy, the SSL_ERROR_RX_RECORD_TOO_LONG message is relatively uncommon and based on threads I've seen, usually temporary with no clear cause or solution. To work around possible cache issues, could you test Google and Bing in a private window? (If you always use private browsing, then you could quit/restart Firefox to test.) P.S. If you are getting a different SEC_ERROR or SSL_ERROR code, please start a new thread.
jscher2000
  • Top 10 Contributor
8568 solutions 70051 answers

Helpful Reply

In recent days, this error code has surfaced much more frequently, so I'll copy/paste here in case you still have this issue:

"SSL_ERROR_RX_RECORD_TOO_LONG" occurs when Firefox and a website try to negotiate a connection using the latest TLS protocol (version 1.3) and the man-in-the-middle (Avast Web Shield or AVG Web Shield) somehow messes it up.

Until this is sorted out, I think your two workarounds are:

(1) Remove the man in the middle (disable Web Shield for secure connections).

See the Avast section of: How to troubleshoot security error codes on secure websites.

(2) Disable TLS 1.3 in Firefox so it connects using an older protocol. To do that:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste TLS and pause while the list is filtered

(C) Double-click the security.tls.version.max preference to display a dialog where you can change the value from 4 to 3 (this corresponds to TLS 1.2) and then click OK

''In recent days, this error code has surfaced much more frequently, so I'll copy/paste here in case you still have this issue:'' "SSL_ERROR_RX_RECORD_TOO_LONG" occurs when Firefox and a website try to negotiate a connection using the latest TLS protocol (version 1.3) and the man-in-the-middle (Avast Web Shield or AVG Web Shield) somehow messes it up. Until this is sorted out, I think your two workarounds are: '''(1)''' Remove the man in the middle (disable Web Shield for secure connections). See the Avast section of: [[How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites]]. '''(2)''' Disable TLS 1.3 in Firefox so it connects using an older protocol. To do that: ''(A)'' In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. ''(B)'' In the search box above the list, type or paste '''TLS''' and pause while the list is filtered ''(C)'' Double-click the '''security.tls.version.max''' preference to display a dialog where you can change the value from '''4''' to '''3''' (this corresponds to TLS 1.2) and then click OK
Travelingelk 0 solutions 13 answers

I changed the TLS 1.3 to TLS 1.2 and we will see what happens. I assume that you folks will notify us when we should change things back? Thanks a bunch for your help. - AZCowboy

I changed the TLS 1.3 to TLS 1.2 and we will see what happens. I assume that you folks will notify us when we should change things back? Thanks a bunch for your help. - AZCowboy
jscher2000
  • Top 10 Contributor
8568 solutions 70051 answers

AZCowboy said

I assume that you folks will notify us when we should change things back?

Honestly, I may not remember. You could make a note on your calendar to try changing it back around July 15th to see whether it is all sorted by then.

''AZCowboy [[#answer-1126946|said]]'' <blockquote> I assume that you folks will notify us when we should change things back? </blockquote> Honestly, I may not remember. You could make a note on your calendar to try changing it back around July 15th to see whether it is all sorted by then.