X
Tap here to go to the mobile version of the site.

Support Forum

multiple (6+) firefox.exe running in process manager when I open Firefox

Posted

I'm having the same issue described in this thread: https://support.mozilla.org/en-US/questions/1147868 and have tried the recommended fix. I have changed the setting reccommended in about:config to false, but about:support still shows 1/1 for multiprocess windows, and I have 6 instances of Firefox running in the process manager (screenshot shows 5, but it has been as many as 7 at once).

Is there anything else I can try to fix this issue? Any help is much appreciated!

I'm having the same issue described in this thread: https://support.mozilla.org/en-US/questions/1147868 and have tried the recommended fix. I have changed the setting reccommended in about:config to false, but about:support still shows 1/1 for multiprocess windows, and I have 6 instances of Firefox running in the process manager (screenshot shows 5, but it has been as many as 7 at once). Is there anything else I can try to fix this issue? Any help is much appreciated!
Attached screenshots

Modified by kcru

Chosen solution

That is tons left. Ya that is normal. Firefox, add-ons, Sandbox.

You want to get the E10's down 0/1 Think this should do it as no notes, other cpu motherboard died.

in about:config

  • browser.tabs.remote.autostart *set it to false
  • browser.tabs.remote.autostart.2 *set to false
  • dom.ipc.processCount *set to 1
Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

More Information

Shadow110 1072 solutions 14836 answers

Hi, Please go to Options --> Privacy & Security --> Permissions and make sure there is a Check Mark in the Box to Prevent Accessibility Services from accessing your browser.

What you want to do may no longer be necessary.

Turning down Multi-processor support can now be done from Options but it is recommend not to turn off but lower the settings.

So please head up to General left side menu and then go down to Performance and remove the Check Mark in the box for Use recommended performance settings. Then lower the Content Processes to 2, maybe go higher, find the sweet spot Reboot after making changes.

The amount of ram being used in total is not that great. Actually pretty good. I do not know your total ram size though.

Note : that Extensions take aprox 20megs of ram each, give or take.

Hi, Please go to Options --> Privacy & Security --> Permissions and make sure there is a Check Mark in the Box to Prevent Accessibility Services from accessing your browser. What you want to do may no longer be necessary. Turning down Multi-processor support can now be done from Options but it is recommend not to turn off but lower the settings. So please head up to General left side menu and then go down to Performance and remove the Check Mark in the box for Use recommended performance settings. Then lower the Content Processes to 2, maybe go higher, find the sweet spot Reboot after making changes. *https://www.howtogeek.com/334594/stop-complaining-that-your-browser-uses-lots-of-ram-its-a-good-thing/ The amount of ram being used in total is not that great. Actually pretty good. I do not know your total ram size though. Note : that Extensions take aprox 20megs of ram each, give or take.

Question owner

Unfortunately, this did nothing for me. The "Use Recommended Performance Settings" was set at 4, so I lowered it to 2. I restarted and it it still showing just as many processes running. Is there anything else I can try? It really slows down Firefox for me.

I forgot to add that it is showing 5 instances running when I only have 2 tabs open.

Unfortunately, this did nothing for me. The "Use Recommended Performance Settings" was set at 4, so I lowered it to 2. I restarted and it it still showing just as many processes running. Is there anything else I can try? It really slows down Firefox for me. I forgot to add that it is showing 5 instances running when I only have 2 tabs open.

Modified by kcru

Shadow110 1072 solutions 14836 answers

Hi, if your system is low ram and not ever had updates to the motherboard and video card no longer gets updates you may want to think about switching to the Extended Release Version. There are 2 versions at this time but since the 50 series will be discontinued in July you might want to think about changing to 60esr as it will be less demanding on your system.

Firefox ESR does not come with the latest features but it has the latest security and stability fixes. If you are having issues with the latest version of Firefox, you can install Firefox ESR as an alternative to downgrading Firefox to a previous version.

Make a copy of your Profile :

Hi, if your system is low ram and not ever had updates to the motherboard and video card no longer gets updates you may want to think about switching to the Extended Release Version. There are 2 versions at this time but since the 50 series will be discontinued in July you might want to think about changing to 60esr as it will be less demanding on your system. Firefox ESR does not come with the latest features but it has the latest security and stability fixes. If you are having issues with the latest version of Firefox, you can install Firefox ESR as an alternative to downgrading Firefox to a previous version. *https://www.mozilla.org/en-GB/firefox/organizations/all/ Make a copy of your Profile : *https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data#w_finding-your-profile-without-opening-firefox

Question owner

I have 8G of ram with 7.67G usable.

I have 8G of ram with 7.67G usable.
Shadow110 1072 solutions 14836 answers

Chosen Solution

That is tons left. Ya that is normal. Firefox, add-ons, Sandbox.

You want to get the E10's down 0/1 Think this should do it as no notes, other cpu motherboard died.

in about:config

  • browser.tabs.remote.autostart *set it to false
  • browser.tabs.remote.autostart.2 *set to false
  • dom.ipc.processCount *set to 1
That is tons left. Ya that is normal. Firefox, add-ons, Sandbox. You want to get the E10's down 0/1 Think this should do it as no notes, other cpu motherboard died. in about:config *browser.tabs.remote.autostart *set it to false *browser.tabs.remote.autostart.2 *set to false *dom.ipc.processCount *set to 1

Modified by Shadow110

Shadow110 1072 solutions 14836 answers

Forgot, some of your add-ons may no longer work with e10's turned off. https://www.ghacks.net/2016/07/22/multi-process-firefox/

Info from given from a previous post of mine : https://support.mozilla.org/en-US/questions/1183859

Forgot, some of your add-ons may no longer work with e10's turned off. https://www.ghacks.net/2016/07/22/multi-process-firefox/ Info from given from a previous post of mine : https://support.mozilla.org/en-US/questions/1183859

Question owner

This worked! Thank you so much for your help. My internet runs much faster this way.

This worked! Thank you so much for your help. My internet runs much faster this way.
Shadow110 1072 solutions 14836 answers

Glad it helped. Do suggest that you move to the Extended Release Version 61esr

if you do (below should be done monthly anyways, :

Please Select Solved for the question that was the solution so others may find it.

Glad it helped. Do suggest that you move to the Extended Release Version 61esr *https://www.mozilla.org/en-US/firefox/organizations/ if you do (below should be done monthly anyways, : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Please Select Solved for the question that was the solution so others may find it.