X
Tap here to go to the mobile version of the site.

Support Forum

Firefox uses a lot of CPU

Posted

Firefox is my go-to browser on all my computers, but for some reason on my Win10 laptop it uses 30-60% CPU at all times, while my opera browser uses 1-5%. Both idle with same amount of tabs, or zero tabs. I've tried reinstalling multiple times, many versions, did the safe mode, did the refresh button.

Firefox is my go-to browser on all my computers, but for some reason on my Win10 laptop it uses 30-60% CPU at all times, while my opera browser uses 1-5%. Both idle with same amount of tabs, or zero tabs. I've tried reinstalling multiple times, many versions, did the safe mode, did the refresh button.

Chosen solution

hi, can you try if the following improves the performance problem: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser.

Read this answer in context 2

Additional System Details

Application

  • Firefox 61.0b4
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
  • Support URL: https://support.mozilla.org/1/firefox/61.0/WINNT/en-US/

Extensions

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 620
  • adapterDescription2:
  • adapterDeviceID: 0x5916
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 200
  • contentUsesTiling: False
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: True
  • directWriteVersion: 10.0.16299.334
  • driverDate: 8-13-2017
  • driverDate2:
  • driverVersion: 22.20.16.4771
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'blocked', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
philipp
  • Top 25 Contributor
  • Moderator
5306 solutions 23424 answers

Chosen Solution

hi, can you try if the following improves the performance problem: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser.

hi, can you try if the following improves the performance problem: go to the firefox ''menu ≡ > options > privacy & security'' panel and under permissions check the setting to '''prevent accessibility services from accessing your browser'''.
Shadow110 1072 solutions 14836 answers

Helpful Reply

Hi, as running a beta anything can and will happen. Please go to Options --> Privacy & Security --> Permissions and put a check mark in the box to Prevent Accessibility Services .......

Then please back up to General on left side Menu then down to Performance and uncheck use Performance settings, then change the Content Processes down to 2 and try that after rebooting. Also go up higher, lower till find the sweet spot.

Yes see that you are in safe mode when posted this.

Note this % can increase or decrease for every version and any cpu. I have several and some run more than others with Firefox.

Hi, as running a beta anything can and will happen. Please go to Options --> Privacy & Security --> Permissions and put a check mark in the box to Prevent Accessibility Services ....... Then please back up to General on left side Menu then down to Performance and uncheck use Performance settings, then change the Content Processes down to 2 and try that after rebooting. Also go up higher, lower till find the sweet spot. Yes see that you are in safe mode when posted this. Note this % can increase or decrease for every version and any cpu. I have several and some run more than others with Firefox.

Question owner

philipp said

hi, can you try if the following improves the performance problem: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser.

This actually seems to have solved the problem, at least during the past 24h of usage. I tried everything before... how come this one setting draws up so much CPU power ?

''philipp [[#answer-1111333|said]]'' <blockquote> hi, can you try if the following improves the performance problem: go to the firefox ''menu ≡ > options > privacy & security'' panel and under permissions check the setting to '''prevent accessibility services from accessing your browser'''. </blockquote> This actually seems to have solved the problem, at least during the past 24h of usage. I tried everything before... how come this one setting draws up so much CPU power ?
BILLM9 0 solutions 4 answers

Are there any downside risks to checking the box to "prevent..." (as described in earlier posts in this thread)? Any other considerations?

Are there any downside risks to checking the box to "prevent..." (as described in earlier posts in this thread)? Any other considerations?
philipp
  • Top 25 Contributor
  • Moderator
5306 solutions 23424 answers

unless you're vision impaired and depending on screenreaders, braille displays and other assistive technologies there are only upsides.

unless you're vision impaired and depending on screenreaders, braille displays and other assistive technologies there are only upsides.