Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Weird "???" charaters in some webpages (font loading error?)

  • 3 replies
  • 1 has this problem
  • 24 views
  • Last reply by cor-el

more options

Hi everybody, I have just changed from Firefox 56.0.2 to newest version. I install a new blank instance, not an upgraded. But in some webpages, the original text characters are replaced with weird "???" characters. It seems like a font loading error but I'm sure there is no problem with my internet connection. It only happens with some webpages. And all the fonts in my computer are installed correctly and works fine in other applications. I'm using macOS 10.11.6.

Thank you for any help and intructions.

Attached screenshots

Modified by davinmind

Chosen solution

You can check for sandbox security related issues.

You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

You can check for sandbox security related issues.

You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

cor-el said

You can check for sandbox security related issues. You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.
  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.
If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

I set it to "1" and tt works! I think that option will set levels of restriction, "3" will prevent Firefox access to other drives. I installed fonts remotely from different drive (not default folder on macOS drive) so the webpages can't display the text correctly. Is there any other security concerns if I set it to "1" permanently?

Otherwise, do you know what is this preference aiming for? Firefox said it has been modifed but I don't know what is it:

security.sandbox.content.tempDirSuffix

Thanks and all the best.

more options

That pref probably doesn't have a value by default and is automatically set for internal use, so best is to ignore it. You shouldn't modify prefs unless you know what it is about.

See the comments here: