Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to correct: Connection is not secure message on HTTPS site

  • 26 replies
  • 2 have this problem
  • 7688 views
  • Last reply by jscher2000

more options

Nothing on help pages explains how to fix the problem with the orange triangle on the lock on an HTTPS site. How can I secure the connection???

Chosen solution

You can force connection to HTTPS for some things that cause the issue. I forgot when looked at the page I had HTTPS EVERYWHERE running : https://addons.mozilla.org/en-US/firefox/addon/https-everywhere/ The above will force a connection to say google analytics if has been coded with http, or to google fonts or....It can only force a connection if there is a connection to force it to ei a HTTPS address.

Read this answer in context 👍 0

All Replies (6)

more options

Pkshadow said

You can force connection to HTTPS for some things that cause the issue. I forgot when looked at the page I had HTTPS EVERYWHERE running : https://addons.mozilla.org/en-US/firefox/addon/https-everywhere/ The above will force a connection to say google analytics if has been coded with http, or to google fonts or....It can only force a connection if there is a connection to force it to ei a HTTPS address.

Huh??

more options

I am not a web developer. I can't even follow your instructions if I'm not reading them on this page. Thanks wholeheartedly for your effort but you've lost me completely. Might as well be speaking Chinese.

more options

jscher2000 said

Whoops, you need to open the web console in the tab with the site that is giving you the problem, reload the page so the console can gather fresh data, and then check for any mixed content messages.

This is what I get on Web Console on the page in question:

Loading mixed (insecure) display content “http://www.interpreterintelligence.com/assets/logos/customer/interpreter-network-logo.png” on a secure page[Learn More] dashboard Using //@ to indicate sourceURL pragmas is deprecated. Use //# instead[Learn More] dashboard:89 Loading mixed (insecure) display content “http://www.interpreterintelligence.com/assets/logos/customer/interpreter-network-logo.png” on a secure page[Learn More] dashboard Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help http://xhr.spec.whatwg.org/ tPX9VQah7ZiHC4DL7hR3L1lpP41KZo18dP783Ee6NlU.js:8206:6 Using //@ to indicate sourceURL pragmas is deprecated. Use //# instead[Learn More] tPX9VQah7ZiHC4DL7hR3L1lpP41KZo18dP783Ee6NlU.js:37 Using //@ to indicate sourceURL pragmas is deprecated. Use //# instead[Learn More] kXE1bWvBYx7sITGB52EWEr9R825iRtle8uXt6SPHGYf.js:1 Using //@ to indicate sourceURL pragmas is deprecated. Use //# instead[Learn More] tPX9VQah7ZiHC4DL7hR3L1lpP41KZo18dP783Ee6NlU.js:21 Using //@ to indicate sourceURL pragmas is deprecated. Use //# instead[Learn More] M1cJ2vSrZ6YEJ15kJNVSMEqtLrAZxQtsM2XwkfRJYJf.js:17:16 Using //@ to indicate sourceURL pragmas is deprecated. Use //# instead[Learn More] tPX9VQah7ZiHC4DL7hR3L1lpP41KZo18dP783Ee6NlU.js:12 Using //@ to indicate sourceURL pragmas is deprecated. Use //# instead[Learn More] tPX9VQah7ZiHC4DL7hR3L1lpP41KZo18dP783Ee6NlU.js:18 Using //@ to indicate sourceURL pragmas is deprecated. Use //# instead[Learn More] ZcJ5R3GykpycqmRVBaNxYB2yOP1O5RYBlqYpFZkN1Cq.js:6

more options

It's the same logo that's always been there and never caused any problems before. Blocking images does not correct the issue.

more options

Pkshadow said

You can force connection to HTTPS for some things that cause the issue. I forgot when looked at the page I had HTTPS EVERYWHERE running : https://addons.mozilla.org/en-US/firefox/addon/https-everywhere/ The above will force a connection to say google analytics if has been coded with http, or to google fonts or....It can only force a connection if there is a connection to force it to ei a HTTPS address.

Adding HTTPS EVERWHERE and checking the box for "Block all unencrypted requests" has finally got me a green lock again!

Thank you for that... but this seems rigged rather than solved. I suspect that running HTTPS EVERYWHERE is going to surface new issues elsehwere.

more options

rafaellecuona said

Thank you for that... but this seems rigged rather than solved. I suspect that running HTTPS EVERYWHERE is going to surface new issues elsehwere.

Yes, it may occasionally upgrade HTTP connections to HTTPS that Firefox won't actually trust. You can use its toolbar button to manage how the extension works on particular sites. (I think; haven't used it for years.)

  1. 1
  2. 2