Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I get a "secure connection failed" error when trying to get into Yahoo email with Firefox.

  • 5 replies
  • 1 has this problem
  • 19 views
  • Last reply by Shadow110

more options

I get the following error when trying to get into Yahoo mail with Firefox. There is no problem with Chrome so I don't think it's my machine. Any advice I get seems to require very complex programming solutions, but I'm wondering if there's a problem with the way Yahoo email is working with Firefox.


Secure Connection Failed

An error occurred during a connection to mg.mail.yahoo.com. Peer’s Certificate has been revoked. Error code: SEC_ERROR_REVOKED_CERTIFICATE

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

All Replies (5)

more options

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate.

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

http://kb.mozillazine.org/Error_loading_websites


Often, "Secure Connection Failed" means "Connection Failed (trying to load a secure page)". In other words, not a security problem, just a connection problem.

more options

Try this URL if you currently use a specific domain:

more options
more options

Thanks for your timely help but it doesn't solve the problem.

more options

I had that error a couple hours ago and pressed try again and was there.

Can try this : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

If is still there : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.