Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Weather Underground does not load properly.

  • 5 replies
  • 2 have this problem
  • 5611 views
  • Last reply by John767

more options

For the last day the Weather Underground pages will not load properly https://www.wunderground.com/forecast.../KMDSAINT1. They do load properly in Chrome and IE. Firefox safe mode does not help.

Chosen solution

AHAH! Went back and cleared Recent History including Offline Website Data and that solved the problem. Everything is now displaying properly. Thank you VERY much for your help Pkshadow, I really appreciate your persistence.

Read this answer in context 👍 0

All Replies (5)

more options

Hi I would think it is one of the multitude of Extensions you have installed, maybe uBlock Origin Note : each extension use aprox 20megs each give or take.

Please try : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

Please let us know if this solved your issue or if need further assistance.

more options

My first thought, which is why I tried it in Safe mode before asking for help. Same issue in Safe mode with all extensions disabled.

more options

HI, weird I get site to display properly in Private Browsing. Wants to store data on my cpu.

Suggest make sure you are accepting all of it's cookies then clear your Cache then right below that is Site Data, delete anything that is stored.

Please search Win10 for Device Manager then check your Video Card NVIDIA GeForce GTX 1050 Ti driverDate: 10-27-2017 to see if Win10 has replaced the drivers for it with Microsoft's.

Check other devices also for them being replaced.

more options

HI, Yes, that is weird. Updating to the current nVidia driver and/or clearing the cache does not help, nor does clearing the Site Data, but It does display properly in Private Browsing. Unfortunately in order to have Firefox start up with the tabs that were open when it was last shut down and to recall previously closed tabs I need to preserve Browsing History which is not allowed in Private Browsing. For now all I can do is open a separate Private Browsing window for that one website. Can't figure out why Private Browsing would make a difference like that. Must be another workaround.

more options

Chosen Solution

AHAH! Went back and cleared Recent History including Offline Website Data and that solved the problem. Everything is now displaying properly. Thank you VERY much for your help Pkshadow, I really appreciate your persistence.