X
Tap here to go to the mobile version of the site.
Top Contributor Feature will be unavailable for a short amount of time today until further notice.

Support Forum

I want to disable search in the address bar and browser.urlbar.unifiedcomplete is not an option anymore

Posted

As I have written many times before .... having a web browser automatically go to a website based on a word typed in the URL BAR is a security nightmare. There is no way to tell what asinine site you will end up on if you miss spell a word.

I have repeatedly removed the ability to search from the URL BAR from my web browser and FF keeps putting it back. Dammit!! My browser, my choice. Leave it alone!

Now the ability to disable it is gone.

Standard answer given: <quote>

I don't know what version you were using before, but web searching from the address bar goes back many, many years. And the way to disconnect web search from the address bar remains exactly the same:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste keyw and pause while the list is filtered

(3) Double-click the keyword.enabled preference to switch the value from true to false

Now the explanatory line on the drop-down is relatively new; it probably dates back to Firefox 43. That can be hidden but not disabled. And there's really no need to disable it, it just tells you what will happen if you submit the current contents of the address bar.

<end quote> It is set to false. If a misspelled word is typed in the url bar it goes to a website.

browser.urlbar.unifiedcomplete is not an option anymore - it has been removed.

If I type localhst instead of local host i end up on a Chinese site or a site selling me domains. If FF cant find a domain of the name given - say so - don't send me somewhere dangerous or unknown.

As I have written many times before .... having a web browser automatically go to a website based on a word typed in the URL BAR is a security nightmare. There is no way to tell what asinine site you will end up on if you miss spell a word. I have repeatedly removed the ability to search from the URL BAR from my web browser and FF keeps putting it back. Dammit!! My browser, my choice. Leave it alone! Now the ability to disable it is gone. Standard answer given: <quote> I don't know what version you were using before, but web searching from the address bar goes back many, many years. And the way to disconnect web search from the address bar remains exactly the same: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste keyw and pause while the list is filtered (3) Double-click the keyword.enabled preference to switch the value from true to false Now the explanatory line on the drop-down is relatively new; it probably dates back to Firefox 43. That can be hidden but not disabled. And there's really no need to disable it, it just tells you what will happen if you submit the current contents of the address bar. <end quote> It is set to false. If a misspelled word is typed in the url bar it goes to a website. browser.urlbar.unifiedcomplete is not an option anymore - it has been removed. If I type localhst instead of local host i end up on a Chinese site or a site selling me domains. If FF cant find a domain of the name given - say so - don't send me somewhere dangerous or unknown.

Chosen solution

Hi oitconz, setting keyword.enabled to false prevents Firefox from sending your input to your default search engine. However, I don't think what you're describing is a search problem.

Firefox will send input that looks like a valid server URL to your DNS service provider. If you type a word with no dots such as localhst and DNS says it does not exist, by default Firefox will retry with www. before it and .com after it. That is a separate feature you can disable.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) Search: In the search box above the list, type or paste keyw and pause while the list is filtered

(3) Double-click the keyword.enabled preference to switch the value from true to false

(4) Fixup: In the search box above the list, type or paste fix and pause while the list is filtered

(5) Double-click the browser.fixup.alternate.enabled preference to switch the value from true to false

Success?


Some DNS service providers will respond honestly about whether a server exists while others will take the opportunity to present a page of pay-per-click or affiliate advertising links.

If your service provider doesn't trigger Firefox's error page, you could try changing your DNS. For example, to:

  • Google Public DNS

Success?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

More Information

Scribe 694 solutions 3350 answers

Hi, open the 3-bar menu > Options > Search, And deselect 'Show search suggestions in address bar results.'

You might also want to go to Options > Privacy & Security - Address bar, and deselect one or more options.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

Hi, open the 3-bar menu > Options > Search, And deselect 'Show search suggestions in address bar results.' You might also want to go to Options > Privacy & Security - Address bar, and deselect one or more options. ''If your question is resolved by this or another answer, please take a minute to let us know. Thank you!''
cor-el
  • Top 10 Contributor
  • Moderator
16606 solutions 149946 answers
See also: *https://support.mozilla.org/en-US/kb/search-web-address-bar *https://support.mozilla.org/en-US/kb/awesome-bar-search-firefox-bookmarks-history-tabs
jscher2000
  • Top 10 Contributor
7777 solutions 63332 answers

Chosen Solution

Hi oitconz, setting keyword.enabled to false prevents Firefox from sending your input to your default search engine. However, I don't think what you're describing is a search problem.

Firefox will send input that looks like a valid server URL to your DNS service provider. If you type a word with no dots such as localhst and DNS says it does not exist, by default Firefox will retry with www. before it and .com after it. That is a separate feature you can disable.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) Search: In the search box above the list, type or paste keyw and pause while the list is filtered

(3) Double-click the keyword.enabled preference to switch the value from true to false

(4) Fixup: In the search box above the list, type or paste fix and pause while the list is filtered

(5) Double-click the browser.fixup.alternate.enabled preference to switch the value from true to false

Success?


Some DNS service providers will respond honestly about whether a server exists while others will take the opportunity to present a page of pay-per-click or affiliate advertising links.

If your service provider doesn't trigger Firefox's error page, you could try changing your DNS. For example, to:

  • Google Public DNS

Success?

Hi oitconz, setting '''keyword.enabled''' to false prevents Firefox from sending your input to your default search engine. However, I don't think what you're describing is a search problem. Firefox will send input that looks like a valid server URL to your DNS service provider. If you type a word with no dots such as ''localhst'' and DNS says it does not exist, by default Firefox will retry with www. before it and .com after it. That is a separate feature you can disable. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) '''''Search:''''' In the search box above the list, type or paste '''keyw''' and pause while the list is filtered (3) Double-click the '''keyword.enabled''' preference to switch the value from true to false (4) '''''Fixup:''''' In the search box above the list, type or paste '''fix''' and pause while the list is filtered (5) Double-click the '''browser.fixup.alternate.enabled''' preference to switch the value from true to false Success? ---- Some DNS service providers will respond honestly about whether a server exists while others will take the opportunity to present a page of pay-per-click or affiliate advertising links. If your service provider doesn't trigger Firefox's error page, you could try changing your DNS. For example, to: * OpenDNS: https://use.opendns.com/ * Cloudflare: https://blog.cloudflare.com/announcing-1111/ * Google Public DNS Success?

Question owner

Thanks for the reply.

The DNS provider is already google 8.8.8.8 but there are so many cruddy sites who have snarfed possible domains trying to sell them for exhorbitant prices that they can show as proper domains.

The (5) Double-click the browser.fixup.alternate.enabled preference to switch the value from true to false is the option that worked.

I just didn't want it searching from the address bar - either the proper domain or a hey dumb ass, you misspelled that type message.

Hmm... maybe a re-write of mozilla FF with differnt terms Talk like a pirate FF, talk like Red Forman (that 70's show) , Arnie-a-fy your FF. Could be some great alternative messages there.

'You know how i told you I'ld find your web site? I lied. Hasta La 404 baby.'

Thanks for the reply. The DNS provider is already google 8.8.8.8 but there are so many cruddy sites who have snarfed possible domains trying to sell them for exhorbitant prices that they can show as proper domains. '''The (5) Double-click the browser.fixup.alternate.enabled preference to switch the value from true to false is the option that worked.''' I just didn't want it searching from the address bar - either the proper domain or a hey dumb ass, you misspelled that type message. Hmm... maybe a re-write of mozilla FF with differnt terms Talk like a pirate FF, talk like Red Forman (that 70's show) , Arnie-a-fy your FF. Could be some great alternative messages there. 'You know how i told you I'ld find your web site? I lied. Hasta La 404 baby.'