Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Master password disables any trust setting on certificates

  • 4 replies
  • 1 has this problem
  • 2 views
  • Last reply by louis925

more options

Whenever Firefox master password is enable, selecting any CA certificate trust settings in the Firefox Certificate Manager will actually disable them upon next reboot of the computer.

I tried to select the trust setting "This certificate can identify websites." for the "Kaspersky Anti-Virus Personal Root Certificate". However, I noticed the following problem:

1) If I enable master password, the Trust settings for certificates have no effect. They remain disabled. I have tried restarting Firefox or changing the trust setting after I entered the master password in the pop up window but they didn't work. The trust settings can only be changed when master password is disable. You can re-enable master password later. The trust settings will remain working. But...

2) If the trust settings are enabled and work properly with master password off, doing the following steps will actually disable those settings instead of enable them: (i) re-enable the master password (ii) go back to the trust setting (iii) deselect and select the already enabled settings again (iv) click "OK" (v) restart your computer. Now those settings will become unchecked after reboot.

I believe these bugs has already been observed in Firefox 57 but remain unfixed.

Firefox: 59.0.2 OS: Windows 7 Kaspersky: 18.0.0.405 (g)

Attached screenshots

Modified by louis925

All Replies (4)

more options

Have you posted this issue to the Kaspersky support forum? Sounds like a problem with Kaspersky and the Firefox Master Password feature that Kaspersky needs to deal with.

more options

Yes, I did ask Kaspersky support. Part 1 is the problem and workaround that the Kaspersky Technical Support told me. However, problem 2 is in addition to problem 1.

I am not sure if this is specific to Kaspersky. This can also happen to other certificate as long as user want to change the trust setting of the certificate with master password enabled.

more options

This can happen when you set Firefox to import the Windows root certificates.

  • security.enterprise_roots.enabled = true => false

See also:

more options

To cor-el

Thanks for the information but the "security.enterprise_roots.enabled" is already set at false on my Firefox, and the problem remains.

Also, the SEC_ERROR_UNKNOWN_ISSUER problem with Kaspersky have been fixed in earlier updates.