X
Tap here to go to the mobile version of the site.

Support Forum

I need a fix for this "Insecure password warning in Firefox"

Posted

Hello Firefox! somehow you've made it so that my login information isn't held at forums.pelicanparts.com, a web forum that I go to and participate in at least 10 times per day if not 20. I can't keep reentering my username and password, csubmitting and then having to go back to where I am supposed to be. Make a workaround that I can turn your insecure warning system off for this site. I am sure it's a much needed system but also there are a ton of people that are fine with insecure passwords. Please send me a way to fix this ASAP. Thank you!

Hello Firefox! somehow you've made it so that my login information isn't held at forums.pelicanparts.com, a web forum that I go to and participate in at least 10 times per day if not 20. I can't keep reentering my username and password, csubmitting and then having to go back to where I am supposed to be. Make a workaround that I can turn your insecure warning system off for this site. I am sure it's a much needed system but also there are a ton of people that are fine with insecure passwords. Please send me a way to fix this ASAP. Thank you!

Chosen solution

Your bookmark bar address uses HTTPS:// so Firefox fills the form automatically.

If you use an address that only has HTTP://, you need to click in the user name field and then a drop-down should appear where you can click your user name from a little list. Is that not working?

Read this answer in context 0
FredMcD
  • Top 10 Contributor
4255 solutions 59584 answers

I think this is what you mean; https://support.mozilla.org/en-US/kb/insecure-password-warning-firefox There is a hidden preference to turn off the warning on the login form if it really annoys you and you think it will never be of value. Here's how:

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Set;

security.insecure_field_warning.contextual.enabled = False security.insecure_password.ui.enabled = False

I think this is what you mean; https://support.mozilla.org/en-US/kb/insecure-password-warning-firefox There is a hidden preference to turn off the warning on the login form if it really annoys you and you think it will never be of value. Here's how: Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar. Set; '''security.insecure_field_warning.contextual.enabled''' = False '''security.insecure_password.ui.enabled''' = False

Question owner

Thank you Fred, appreciate the quick response and back door. That has turned off the warning but the forum is still not holding my username and password. What config edits do I need to do so my username and password are held when the checkbox Remember Me is checked. I've been a part of this forum since 2001 and this is the first trouble I've had. Just got a new iMac and installed the latest Firefox and here we are.

Thank you Fred, appreciate the quick response and back door. That has turned off the warning but the forum is still not holding my username and password. What config edits do I need to do so my username and password are held when the checkbox Remember Me is checked. I've been a part of this forum since 2001 and this is the first trouble I've had. Just got a new iMac and installed the latest Firefox and here we are.
FredMcD
  • Top 10 Contributor
4255 solutions 59584 answers

Type about:preferences#security<enter> in the address bar. Look under Logins,

Note: For Firefox 56+ its; about:preferences#privacy Look under Forms & Passwords +++++++++++++++++++++++++++++++ Turn on Remember Logins. To check the passwords you have listed, press Saved Logins.

Press the Exceptions button and see what's inside.

Type '''about:preferences#security'''<enter> in the address bar. Look under '''Logins, ''' Note: For Firefox 56+ its; '''about:preferences#privacy''' Look under '''Forms & Passwords ''' +++++++++++++++++++++++++++++++ Turn on '''Remember Logins. ''' To check the passwords you have listed, press '''Saved Logins. ''' Press the '''Exceptions''' button and see what's inside.

Question owner

Have done that. Box was already checked, forum address was saved with correct password. Nothing in exceptions. I wonder if something has to be cleared.

Have done that. Box was already checked, forum address was saved with correct password. Nothing in exceptions. I wonder if something has to be cleared.
FredMcD
  • Top 10 Contributor
4255 solutions 59584 answers

I called for more help.

I called for more help.

Question owner

Thanks Fred. If I click on my bookmark bar, I am logged in as normal. If I then click on a link in a notification email (someone has a new post), the forum recognizes me as logged in. But if I click on that link without being already on the forum, it doesn't recognize me, I am not logged in. 17 years this has worked fine, now it doesn't. Very frustrating.

My bookmark bar. https://forums.pelicanparts.com/porsche-911-used-parts-sale-wanted/

Thanks Fred. If I click on my bookmark bar, I am logged in as normal. If I then click on a link in a notification email (someone has a new post), the forum recognizes me as logged in. But if I click on that link without being already on the forum, it doesn't recognize me, I am not logged in. 17 years this has worked fine, now it doesn't. Very frustrating. My bookmark bar. https://forums.pelicanparts.com/porsche-911-used-parts-sale-wanted/

Question owner

any news here?

any news here?
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Chosen Solution

Your bookmark bar address uses HTTPS:// so Firefox fills the form automatically.

If you use an address that only has HTTP://, you need to click in the user name field and then a drop-down should appear where you can click your user name from a little list. Is that not working?

Your bookmark bar address uses HTTPS:// so Firefox fills the form automatically. If you use an address that only has HTTP://, you need to click in the user name field and then a drop-down should appear where you can click your user name from a little list. Is that not working?

Question owner

Hello! That works but it doesn't work.

Scenario 1: I click on the bookmark bar and go to the forum page link and I'm signed in and all is good.

https://forums.pelicanparts.com/porsche-911-used-parts-sale-wanted/

Scenario 2: I get an email notifying me of a new post on a thread I'm subscribed to on the forum. I click the link in the email and it brings me to that post in the thread. I am not logged in so I can't automatically respond.

Scenario 2A: I scroll to the top of the page and click on the Username box which then autofills with stored information and all is good.

I can't keep jumping to the top of the page to click and sign in again 20 times a day.

I've used this site for 16 years and never had this problem.

Please let me know what I need to select/deselect so I can go back to using the forums the way I was just a week ago.

Thank you!

Hello! That works but it doesn't work. Scenario 1: I click on the bookmark bar and go to the forum page link and I'm signed in and all is good. https://forums.pelicanparts.com/porsche-911-used-parts-sale-wanted/ Scenario 2: I get an email notifying me of a new post on a thread I'm subscribed to on the forum. I click the link in the email and it brings me to that post in the thread. I am not logged in so I can't automatically respond. Scenario 2A: I scroll to the top of the page and click on the Username box which then autofills with stored information and all is good. I can't keep jumping to the top of the page to click and sign in again 20 times a day. I've used this site for 16 years and never had this problem. Please let me know what I need to select/deselect so I can go back to using the forums the way I was just a week ago. Thank you!

Question owner

another thing, unrelated. I don't have a TV but watch the Simpsons on Fox.com and Dr. Who on Amazon. The controls on Fox are missing when you mouseover the bottom of the screen. They work fine with Safari.

another thing, unrelated. I don't have a TV but watch the Simpsons on Fox.com and Dr. Who on Amazon. The controls on Fox are missing when you mouseover the bottom of the screen. They work fine with Safari.
cor-el
  • Top 10 Contributor
  • Moderator
17526 solutions 158458 answers

A detail like a website remembering you (log you in automatically) is stored in a cookie.

You can use these steps to make a website recognize and remember you:

  • you can create an "Allow" exception to keep specific Cookies, especially in case of secure websites and when Cookies expire when Firefox is closed.
  • Options/Preferences -> Privacy & Security -> Cached Web Content: "Clear Now": Exceptions

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the cookies
  • do not clear the Site Preferences
  • clearing "Site Preferences" clears exceptions for Cookies, images, pop-up windows, and software installation and exception for password and other website specific data
  • clearing "cookies" will remove all selected Cookies including Cookies with an "Allow" exception you may want to keep
A detail like a website remembering you (log you in automatically) is stored in a cookie. You can use these steps to make a website recognize and remember you: *you can create an "Allow" exception to keep specific Cookies, especially in case of secure websites and when Cookies expire when Firefox is closed. *Options/Preferences -> Privacy & Security -> Cached Web Content: "Clear Now": Exceptions In case you use "Clear history when Firefox closes" or otherwise clear history. *do not clear the cookies *do not clear the Site Preferences *Options/Preferences -> Privacy & Security -> Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" -> Settings *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox *clearing "Site Preferences" clears exceptions for Cookies, images, pop-up windows, and software installation and exception for password and other website specific data *clearing "cookies" will remove all selected Cookies including Cookies with an "Allow" exception you may want to keep

Question owner

Hi cor-el

Thank you. First, I don't clear history when Firefox closes.

I have no exceptions. Pelican Parts is a Saved Login

I did just clear the Cached Web Content now.

Hi cor-el Thank you. First, I don't clear history when Firefox closes. I have no exceptions. Pelican Parts is a Saved Login I did just clear the Cached Web Content now.

Question owner

Is there not a fix for this? If not, can you send me a link to download an older version of Firefox?

Is there not a fix for this? If not, can you send me a link to download an older version of Firefox?
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

ShaunTru6 said

Is there not a fix for this? If not, can you send me a link to download an older version of Firefox?

Is it working the way I described earlier:

jscher2000 said

Your bookmark bar address uses HTTPS:// so Firefox fills the form automatically. If you use an address that only has HTTP://, you need to click in the user name field and then a drop-down should appear where you can click your user name from a little list. Is that not working?

There actually is a setting to override Firefox's caution and automatically fill login forms on insecure pages. It is not recommended, but you can find it here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste signon and pause while the list is filtered

(3) Check the signon.autofillForms.http preference:

  • false (default) => do not fill login forms on insecure pages
  • true => fill login forms on insecure pages

Was that what you were looking for?

Transmitting a login over HTTP sends it in a visible form that anyone could intercept, although this is most likely if you are on an open wireless connection, for example, at your neighborhood coffee shop. You wouldn't want to do that on a site where it could be damaging to your finances or reputation for someone to take over your account and impersonate you or lock you out.

''ShaunTru6 [[#answer-1100661|said]]'' <blockquote> Is there not a fix for this? If not, can you send me a link to download an older version of Firefox? </blockquote> Is it working the way I described earlier: ''jscher2000 [[#answer-1099502|said]]'' <blockquote> Your bookmark bar address uses HTTPS:// so Firefox fills the form automatically. If you use an address that only has HTTP://, you need to click in the user name field and then a drop-down should appear where you can click your user name from a little list. Is that not working? </blockquote> There actually is a setting to override Firefox's caution and automatically fill login forms on insecure pages. It is not recommended, but you can find it here: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''signon''' and pause while the list is filtered (3) Check the '''signon.autofillForms.http''' preference: * false (default) => do not fill login forms on insecure pages * true => fill login forms on insecure pages Was that what you were looking for? Transmitting a login over HTTP sends it in a visible form that anyone could intercept, although this is most likely if you are on an open wireless connection, for example, at your neighborhood coffee shop. You wouldn't want to do that on a site where it could be damaging to your finances or reputation for someone to take over your account and impersonate you or lock you out.