X
Tap here to go to the mobile version of the site.

Support Forum

Websites taking a long time to "look up" every first time after 59.0.2 update

Posted

Ever since Firefox updated to 59.0.2 I've been having this issue where sites are stuck "looking up (site)" for 5-6 seconds every time I first click on them. After they've loaded for the first time they load just fine for a while, but if I don't visit that site again for the next few minutes or so, they require the long "looking up" process again.

Before the 59.0.2 update pretty much any site would finish loading in only 1 or 2 seconds at most.

I've already tried starting Firefox in safe mode, doesn't change anything. Youtube and Twitch videos still work fine, and my connection to any online games are still the same so I don't think it's a bandwidth issue.

Ever since Firefox updated to 59.0.2 I've been having this issue where sites are stuck "looking up (site)" for 5-6 seconds every time I first click on them. After they've loaded for the first time they load just fine for a while, but if I don't visit that site again for the next few minutes or so, they require the long "looking up" process again. Before the 59.0.2 update pretty much any site would finish loading in only 1 or 2 seconds at most. I've already tried starting Firefox in safe mode, doesn't change anything. Youtube and Twitch videos still work fine, and my connection to any online games are still the same so I don't think it's a bandwidth issue.

Modified by trshbg

Chosen solution

Tested other browsers and Firefox on another computer, also had the same issue, so I'm assuming that my ISP was to blame. Problem appears to have gone away for now.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

More Information

FredMcD
  • Top 10 Contributor
4269 solutions 59841 answers

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Try removing the cache.

Location of the cache/cache2 folder; Windows: *C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\<profile>\ Mac: ~/Library/Caches/Firefox/Profiles/ Linux: ~/.cache/mozilla/firefox/

Close Firefox. Open your file browser to the above, and remove the folder.

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ---------------- Try removing the cache. '''Location of the cache/cache2 folder;''' '''Windows: ''' *C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\<profile>\ '''Mac: ''' ~/Library/Caches/Firefox/Profiles/ '''Linux: ''' ~/.cache/mozilla/firefox/ '''Close Firefox. ''' Open your file browser to the above, and remove the '''folder. '''

Chosen Solution

Tested other browsers and Firefox on another computer, also had the same issue, so I'm assuming that my ISP was to blame. Problem appears to have gone away for now.

Tested other browsers and Firefox on another computer, also had the same issue, so I'm assuming that my ISP was to blame. Problem appears to have gone away for now.
FredMcD
  • Top 10 Contributor
4269 solutions 59841 answers

Good to hear. Have your ISP test your service, and ask if there have been any problems.

Good to hear. Have your ISP test your service, and ask if there have been any problems.