X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

I have Firefox 57.7.2esr, but when I try to download Firefox VPN I get a message saying I only have 57.0. Why?

Posted

Why can't I download Firefox VPN with Firefox browser57.7.2esr?

Why can't I download Firefox VPN with Firefox browser57.7.2esr?

Chosen solution

You have 52.7.2esr. (fifty-two.seven.two)

Firefox 53 (fifty-three) and later does not run on WinXP/Vista.

What VPN are you referring to as there is no Firefox VPN product or service from Mozilla.

If you mean one of the VPN related extensions being hosted at https://addons.mozilla.org/firefox/tag/vpn then many of them are for Firefox 57.0 and newer with current version.

On the extension page scroll down to Version History > See complete version history and scroll down versions till you get one that work with 52.0 in rang of Firefox versions it works with.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 29.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • eMusic DLM 4.1.3.2
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

James
  • Top 25 Contributor
  • Moderator
1602 solutions 11345 answers

Chosen Solution

You have 52.7.2esr. (fifty-two.seven.two)

Firefox 53 (fifty-three) and later does not run on WinXP/Vista.

What VPN are you referring to as there is no Firefox VPN product or service from Mozilla.

If you mean one of the VPN related extensions being hosted at https://addons.mozilla.org/firefox/tag/vpn then many of them are for Firefox 57.0 and newer with current version.

On the extension page scroll down to Version History > See complete version history and scroll down versions till you get one that work with 52.0 in rang of Firefox versions it works with.

You have 5'''2'''.7.2esr. (fifty-two.seven.two) Firefox 5'''3''' (fifty-three) and later does not run on WinXP/Vista. What VPN are you referring to as there is no Firefox VPN product or service from Mozilla. If you mean one of the VPN related extensions being hosted at https://addons.mozilla.org/firefox/tag/vpn then many of them are for Firefox 57.0 and newer with current version. On the extension page scroll down to Version History > See complete version history and scroll down versions till you get one that work with 52.0 in rang of Firefox versions it works with.

Modified by James

Question owner

Thanks for straightening me out StrongLight. My laptop with windows 10 is in the shop so I'm on this old thing for now. Vista wasn't that great to begin with so I've been frustrated. Guess I misread my update. Peace

Thanks for straightening me out StrongLight. My laptop with windows 10 is in the shop so I'm on this old thing for now. Vista wasn't that great to begin with so I've been frustrated. Guess I misread my update. Peace
Shadow110 1072 solutions 14836 answers

Please mark this a solved with the solution that provided the info please.

Please mark this a solved with the solution that provided the info please.