X
Tap here to go to the mobile version of the site.

Support Forum

How can I temporarily disable Firefox so that, when I open Google Earth, Chrome will be used instead?

Posted

Firefox keeps opening. I close it, open Chrome, click on Google Earth, and it opens in Firefox, which isn't very compatible with it. I read that Chrome works it better, but I can't get my computer to cooperate. I'm just afraid that, if I tell Chrome to be my default browser, when I'm done with Google Earth, I won't know how to restore Firefox to the default. Can someone please give me all the steps to go both ways?

Firefox keeps opening. I close it, open Chrome, click on Google Earth, and it opens in Firefox, which isn't very compatible with it. I read that Chrome works it better, but I can't get my computer to cooperate. I'm just afraid that, if I tell Chrome to be my default browser, when I'm done with Google Earth, I won't know how to restore Firefox to the default. Can someone please give me all the steps to go both ways?

Chosen solution

HI, Please Mark the Solution as Solved the issue so others can find it.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 29.0 r0

I don't know about all that - I'm old and that's above my retired pay grade.  ;-D

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:59.0) Gecko/20100101 Firefox/59.0

More Information

Shadow110 1072 solutions 14836 answers

Hi, Google Earth at least what I run runs in it's own window and is not associated to any browser. Please check your add-ons to see if you have a google earth plugin for Firefox. If you do disable/remove it and download and install the full Google Earth. https://www.google.com/earth/download/gep/agree.html

Please let us know if this solved your issue or if need further assistance.

Hi, Google Earth at least what I run runs in it's own window and is not associated to any browser. Please check your add-ons to see if you have a google earth plugin for Firefox. If you do disable/remove it and download and install the full Google Earth. https://www.google.com/earth/download/gep/agree.html Please let us know if this solved your issue or if need further assistance.

Question owner

Hi, Thanks for replying so quickly. I don't choose a way for it to open. When I do things in Google Earth, a popup has come up telling me to open it in Chrome and it'll work better. I don't know how to do the things you've said (I'm 74 and that should tell you a lot). When I look in Plug-ins, Extensions, and Legacy Extensions, there's no Google Earth. Yet it works from my downloading it each time I've upgraded, the most recent being Google Earth Pro (free). What else can I try?

Hi, Thanks for replying so quickly. I don't choose a way for it to open. When I do things in Google Earth, a popup has come up telling me to open it in Chrome and it'll work better. I don't know how to do the things you've said (I'm 74 and that should tell you a lot). When I look in Plug-ins, Extensions, and Legacy Extensions, there's no Google Earth. Yet it works from my downloading it each time I've upgraded, the most recent being Google Earth Pro (free). What else can I try?
Shadow110 1072 solutions 14836 answers

Hi, no you did great and went to the place I wanted you to check :=}

As I mentioned when I start up Google Earth it does not start up in any browser but it's own interface. I have no idea why Google Earth would be starting in Firefox. Have you gone through it's menu.

As you can see here : https://www.google.com/earth/download/gep/agree.html under system requirments it does not mention any browsers. You might want to uninstall and download another version.

You can go to the Chrome Store as I believe there is a Google Earth add-on for them and add it to chrome. How it works I have no idea.

Hi, no you did great and went to the place I wanted you to check :=} As I mentioned when I start up Google Earth it does not start up in any browser but it's own interface. I have no idea why Google Earth would be starting in Firefox. Have you gone through it's menu. As you can see here : https://www.google.com/earth/download/gep/agree.html under system requirments it does not mention any browsers. You might want to uninstall and download another version. You can go to the Chrome Store as I believe there is a Google Earth add-on for them and add it to chrome. How it works I have no idea.

Question owner

When I open Google Earth, I can do it with no browser open. But it apparently opens in Firefox, but would do better in Chrome. At least, that’s what seems to be happening. I don’t know anything about interfaces, assuming that Google Earth requires a browser to link to the Internet.

As to downloading a new copy on Chrome Store, I’ll see if I can find it, and bookmark it. But I won’t download it now – I’ll wait until some night when I can’t sleep; then I can download it between 2am – 8am when I get free data with DishNet.

Meanwhile, If I knew how to disable Firefox, and then enable it, it wouldn’t open! And Chrome might open instead. It’s funny – I’d turn off Firefox, open Chrome, click my Google Earth icon, and Firefox opens instantly. There’s gotta be a way!  ;-D

There's a box to click on for "Needs more information" below where I'm typing. Is that for me to tell others that it's not solved? Or is that for an answerer who needs more info about my computer, perhaps?

When I open Google Earth, I can do it with no browser open. But it apparently opens in Firefox, but would do better in Chrome. At least, that’s what seems to be happening. I don’t know anything about interfaces, assuming that Google Earth requires a browser to link to the Internet. As to downloading a new copy on Chrome Store, I’ll see if I can find it, and bookmark it. But I won’t download it now – I’ll wait until some night when I can’t sleep; then I can download it between 2am – 8am when I get free data with DishNet. Meanwhile, If I knew how to disable Firefox, and then enable it, it wouldn’t open! And Chrome might open instead. It’s funny – I’d turn off Firefox, open Chrome, click my Google Earth icon, and Firefox opens instantly. There’s gotta be a way! ;-D There's a box to click on for "Needs more information" below where I'm typing. Is that for me to tell others that it's not solved? Or is that for an answerer who needs more info about my computer, perhaps?

Question owner

I went to Google Chrome Store but don't see Google Earth. Are you allowed to find it and paste the URL here for me?

I went to Google Chrome Store but don't see Google Earth. Are you allowed to find it and paste the URL here for me?

Question owner

I just went to your previous link and saw 7.3 was offered; I found a way to check mine = 7.3.1.4507. I see no advantage in downloading it again. I still think the only option is to disable Firefox. HOW? and then how to make it my default again?

I just went to your previous link and saw 7.3 was offered; I found a way to check mine = 7.3.1.4507. I see no advantage in downloading it again. I still think the only option is to disable Firefox. HOW? and then how to make it my default again?
Shadow110 1072 solutions 14836 answers

I am still trying to figure out why you think Google Earth is using Firefox to display itself.  ??? Please upload a screenshot. https://support.mozilla.org/en-US/kb/firefox-screenshots

In this pic : https://www.youtube.com/watch?v=xdTQZ4ahY_A (do not need to start video) it shows Google Earth toolbar. Google Earth is not full screen so it shows the Browser tools at the Bottom. Disregard those as a browser is running. If the toolbar looks like the URL then it is not running in a Browser (Firefox) it is a stand Alone Program which Pro is.

There is no need to do anything with browsers.

If you want it to look better then suggest updating you Video Card Drivers if is possible.

In conclusion : Google Earth is not running in Firefox.

I am still trying to figure out why you think Google Earth is using Firefox to display itself. ??? Please upload a screenshot. https://support.mozilla.org/en-US/kb/firefox-screenshots In this pic : https://www.youtube.com/watch?v=xdTQZ4ahY_A (do not need to start video) it shows Google Earth toolbar. Google Earth is not full screen so it shows the Browser tools at the Bottom. Disregard those as a browser is running. If the toolbar looks like the URL then it is not running in a Browser (Firefox) it is a stand Alone Program which Pro is. There is no need to do anything with browsers. If you want it to look better then suggest updating you Video Card Drivers if is possible. In conclusion : Google Earth is not running in Firefox.

Question owner

I just took a screenshot of my desktop before opening it; then I took a screenshot of my desktop with it opened – neither Firefox, nor Chrome, nor Safari opened (as indicated by the lack of dots under the dock icons), which proves you’re right (and as I thought it was before that pop-up appeared last time I used it – weeks ago?). So why did I get the pop-up telling me to open Google Earth in Chrome instead of Firefox? And why did Firefox open every time I tried to open Google Earth in Chrome? I guess it’s something I’ll never know unless it happens again.

I’m copying all our messages to a Word doc. including the URL of our communications page. If it happens again, I’ll post again and this time with an image of the message!  :-D I haven’t been using it much because it’s so slow, and the images are very poor – it was better when the program was smaller and my provider could handle it. Now, it takes forever for things to open, and my favorite pastime, cruising down a road in street view, is nearly impossible. That’s why I finally wanted to “open it in Chrome” because the pop-up said it would work better in Chrome, which surprised me because I thought it worked on its own, as you verified. I guess we won’t know until it happens again. Until then, no one will believe me until I can provide a screenshot. Meanwhile, thank you very much for your time. I appreciate all your work on my behalf.

I just took a screenshot of my desktop before opening it; then I took a screenshot of my desktop with it opened – neither Firefox, nor Chrome, nor Safari opened (as indicated by the lack of dots under the dock icons), which proves you’re right (and as I thought it was before that pop-up appeared last time I used it – weeks ago?). So why did I get the pop-up telling me to open Google Earth in Chrome instead of Firefox? And why did Firefox open every time I tried to open Google Earth in Chrome? I guess it’s something I’ll never know unless it happens again. I’m copying all our messages to a Word doc. including the URL of our communications page. If it happens again, I’ll post again and this time with an image of the message! :-D I haven’t been using it much because it’s so slow, and the images are very poor – it was better when the program was smaller and my provider could handle it. Now, it takes forever for things to open, and my favorite pastime, cruising down a road in street view, is nearly impossible. That’s why I finally wanted to “open it in Chrome” because the pop-up said it would work better in Chrome, which surprised me because I thought it worked on its own, as you verified. I guess we won’t know until it happens again. Until then, no one will believe me until I can provide a screenshot. Meanwhile, thank you very much for your time. I appreciate all your work on my behalf.
jscher2000
  • Top 10 Contributor
8640 solutions 70686 answers

I think in the short run, the best thing would be not to use your Google Earth shortcut, but instead to use your Chrome shortcut to start Chrome, and then load Google Earth from inside Chrome. It sounds like an extra step, but it saves the step of finding yourself in Firefox when you meant to be in Chrome.

I think in the short run, the best thing would be not to use your Google Earth shortcut, but instead to use your Chrome shortcut to start Chrome, and then load Google Earth from inside Chrome. It ''sounds'' like an extra step, but it saves the step of finding yourself in Firefox when you meant to be in Chrome.

Question owner

Hi, How do I get it to open in Chrome when it automatically opens on it's own interface?

Hi, How do I get it to open in Chrome when it automatically opens on it's own interface?
jscher2000
  • Top 10 Contributor
8640 solutions 70686 answers

appookta said

Hi, How do I get it to open in Chrome when it automatically opens on it's own interface?

Here's what I meant:

(1) Open Chrome

(2) In Chrome, search for Google Earth and following the link to the site.

''appookta [[#answer-1092227|said]]'' <blockquote> Hi, How do I get it to open in Chrome when it automatically opens on it's own interface? </blockquote> Here's what I meant: (1) Open Chrome (2) In Chrome, search for Google Earth and following the link to the site.

Question owner

Thank you. I opened Chrome by clicking on the icon in my dock. Then, on a New Tab page, I typed GoogleEarth. Google opened a list of hits. See first attachment “Google results”. I clicked on “Google Earth” toward the lower right (see link turned purple in screenshot) and a page to download the program opened (see 2nd attachment “Download page”). I have this downloaded already. Should I download it again and from this page? If so, should I have deleted my current copy? If not, how can I get this to open in Chrome – where should I have a link to it on my computer? i.e., should I be seeing a link to just open it somewhere? Is there another way to get there in Chrome than via this download page? Why doesn’t the site recognize that I have it on my computer already? So many questions...  ;-)

Thank you. I opened Chrome by clicking on the icon in my dock. Then, on a New Tab page, I typed GoogleEarth. Google opened a list of hits. See first attachment “Google results”. I clicked on “Google Earth” toward the lower right (see link turned purple in screenshot) and a page to download the program opened (see 2nd attachment “Download page”). I have this downloaded already. Should I download it again and from this page? If so, should I have deleted my current copy? If not, how can I get this to open in Chrome – where should I have a link to it on my computer? i.e., should I be seeing a link to just open it somewhere? Is there another way to get there in Chrome than via this download page? Why doesn’t the site recognize that I have it on my computer already? So many questions... ;-)
jscher2000
  • Top 10 Contributor
8640 solutions 70686 answers

I was thinking of the "in browser" view (attached screenshot). Is that not offered on your Mac?

I was thinking of the "in browser" view (attached screenshot). Is that not offered on your Mac?

Question owner

I’ve never seen such a page. Would you paste the URL in your next reply? Let me see if I can open and bookmark it, and access it in Chrome. (This is exciting!) Thanks!

I’ve never seen such a page. Would you paste the URL in your next reply? Let me see if I can open and bookmark it, and access it in Chrome. (This is exciting!) Thanks!
jscher2000
  • Top 10 Contributor
8640 solutions 70686 answers

That's just https://www.google.com/earth/ but perhaps Google changes the page between Windows and Mac??

That's just https://www.google.com/earth/ but perhaps Google changes the page between Windows and Mac??

Question owner

I just opened your previous email/message – you gave me the answer here. I’m now playing with Google Earth in Chrome. That’s what I originally posted a message for, so my question has been answered. I don’t know if it’ll be any faster, and it doesn’t seem to have access to the many addresses I stored in Google Earth Pro from past uses, but I won’t know if it’s any better until I get a chance to “drive around” in street view at night, when DishNet gives me free data.

So thank you “J” for getting me here! It’s greatly appreciated!

I just opened your previous email/message – you gave me the answer here. I’m now playing with Google Earth in Chrome. That’s what I originally posted a message for, so my question has been answered. I don’t know if it’ll be any faster, and it doesn’t seem to have access to the many addresses I stored in Google Earth Pro from past uses, but I won’t know if it’s any better until I get a chance to “drive around” in street view at night, when DishNet gives me free data. So thank you “J” for getting me here! It’s greatly appreciated!
Shadow110 1072 solutions 14836 answers

Chosen Solution

HI, Please Mark the Solution as Solved the issue so others can find it.

HI, Please Mark the Solution as Solved the issue so others can find it.

Modified by Shadow110

Question owner

I just did. Thanks for the reminder to do so.  :-)

I just did. Thanks for the reminder to do so. :-)