X
Tap here to go to the mobile version of the site.

Support Forum

Firefox doesn't show text. How to fix it?

Posted

Ok, this error is really annoying me. Whenever I try to load a page or even google search, the page ends loading and basically just shows the background. The text just doesn't show.

I've tried all the solutions I could google for: clear cache, uninstall/reinstall, set or unset the option to allow sites to use their own fontes, changed the security.sandbox value thing, disable/remove extensions/plugins... Everything.

That's been happening every since my browser updated to Firefox 59.0.1 yesterday morning.

Issue is now showing up when I use Chrome.

I use Windows 8.1, by the way. Not sure if I need to inform any more specification of my computer.

Can anyone help me figure out what's happening?

OBS: the attached image is just an example of what's happening. It's not just this webpage but nearly all the ones I visit, including google search.

Best regards!

Ok, this error is really annoying me. Whenever I try to load a page or even google search, the page ends loading and basically just shows the background. The text just doesn't show. I've tried all the solutions I could google for: clear cache, uninstall/reinstall, set or unset the option to allow sites to use their own fontes, changed the security.sandbox value thing, disable/remove extensions/plugins... Everything. That's been happening every since my browser updated to Firefox 59.0.1 yesterday morning. Issue is now showing up when I use Chrome. I use Windows 8.1, by the way. Not sure if I need to inform any more specification of my computer. Can anyone help me figure out what's happening? OBS: the attached image is just an example of what's happening. It's not just this webpage but nearly all the ones I visit, including google search. Best regards!
Attached screenshots

Chosen solution

See if this is the issue : there appears to be an issue that only affects users who have turned off cleartype font rendering within their windows settings. So a workaround for the moment would either be to turn cleartype back on or disabling hardware acceleration in Firefox: https://support.mozilla.org/en-US/kb/performance-settings

Try : SAFE MODE to see if issue is there or not.

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

More Information

Pkshadow
  • Top 10 Contributor
916 solutions 11973 answers

Chosen Solution

See if this is the issue : there appears to be an issue that only affects users who have turned off cleartype font rendering within their windows settings. So a workaround for the moment would either be to turn cleartype back on or disabling hardware acceleration in Firefox: https://support.mozilla.org/en-US/kb/performance-settings

Try : SAFE MODE to see if issue is there or not.

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST

See if this is the issue : there appears to be an issue that only affects users who have turned off cleartype font rendering within their windows settings. So a workaround for the moment would either be to turn cleartype back on or disabling hardware acceleration in Firefox: https://support.mozilla.org/en-US/kb/performance-settings Try : SAFE MODE to see if issue is there or not. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected TEST
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16394 solutions 147900 answers

Helpful Reply

Does the text appear when you try to zoom the page?

Does text appear when you select it with the mouse in an area where you would expect text?

Did you check the default text color?

  • Options/Preferences -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

Does the text appear when you try to zoom the page? Does text appear when you select it with the mouse in an area where you would expect text? Did you check the default text color? *Options/Preferences -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above" Try "Never" if the default "Only with High Contrast themes" isn't working.
Was this helpful to you? 1
Quote
sarpc 0 solutions 6 answers

Eduardo_Uron1 said

Ok, this error is really annoying me. Whenever I try to load a page or even google search, the page ends loading and basically just shows the background. The text just doesn't show.

I had such a problem. Now everything is fine! see post https://support.mozilla.org/en-US/questions/1209971

''Eduardo_Uron1 [[#question-1210039|said]]'' <blockquote> Ok, this error is really annoying me. Whenever I try to load a page or even google search, the page ends loading and basically just shows the background. The text just doesn't show. </blockquote> I had such a problem. Now everything is fine! see post https://support.mozilla.org/en-US/questions/1209971
Was this helpful to you?
Quote

Question owner

Hello, guys, sorry for the late reply but I was waiting to see whether the issue would show up again or not.

Ok, Cor-el's tip of zooming the page was really helpful and a good workaround.

Tried Pkshadow's suggestion of turning clearype on was the most effective and so far the issue didn't show up again.

Thanks for all the help, everyone!

Hello, guys, sorry for the late reply but I was waiting to see whether the issue would show up again or not. Ok, Cor-el's tip of zooming the page was really helpful and a good workaround. Tried Pkshadow's suggestion of turning clearype on was the most effective and so far the issue didn't show up again. Thanks for all the help, everyone!
Was this helpful to you?
Quote
Happy112 562 solutions 5694 answers

The problem was fixed with the update to Firefox version 59.0.2.

As Pkshadow's suggestion worked for you : would you be so kind as to mark Pkshadow's post as Chosen Solution  ?

Thank you in advance  !

The problem was fixed with the update to Firefox version 59.0.2. As Pkshadow's suggestion worked for you : would you be so kind as to mark Pkshadow's post as Chosen Solution ? Thank you in advance !
Was this helpful to you?
Quote

Question owner

Yes, I can. I wanted to do it last time I posted but for reason I didn't found the solution option. Now, I found it and marked.

Thanks, guys!

Yes, I can. I wanted to do it last time I posted but for reason I didn't found the solution option. Now, I found it and marked. Thanks, guys!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.