X
Tap here to go to the mobile version of the site.

Support Forum

Why is Firefox Using Too Much Memory?

Posted

Been having this problem for a while with firefox, seems like an update last summer and the past upgrade things have changed. Task Manager shows multiple tabs open in firefox, I had two tabs open, one for my homepage and another for a website I was visiting, firefox shows a lot of activity on one tab and thing there's 3 other tabs open.

This causes my computer to lag and be unresponsive, everything application, every function, the task bar, everything lags and slow to respond and responds in a choppy way. This has been going on for sometime and is a real headache, I do my work and use firefox considerably, I open multiple tabs and work on certain websites, Firefox uses 500-1,000+ MB and 80-90% memory, why is that?

Been having this problem for a while with firefox, seems like an update last summer and the past upgrade things have changed. Task Manager shows multiple tabs open in firefox, I had two tabs open, one for my homepage and another for a website I was visiting, firefox shows a lot of activity on one tab and thing there's 3 other tabs open. This causes my computer to lag and be unresponsive, everything application, every function, the task bar, everything lags and slow to respond and responds in a choppy way. This has been going on for sometime and is a real headache, I do my work and use firefox considerably, I open multiple tabs and work on certain websites, Firefox uses 500-1,000+ MB and 80-90% memory, why is that?
Attached screenshots

Chosen solution

You can try to modify multi-process settings to see if this has effect.

  • set number of content processes to 1 if it is currently set to a higher value (4)
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • disable multi-process windows in Firefox

You can disable multi-process windows in Firefox by setting this pref to false on the about:config page.

  • browser.tabs.remote.autostart = false

Note that the previously used opt-in pref browser.tabs.remote.autostart.2 is no longer supported in Firefox 58+. You can reset browser.tabs.remote.autostart.2 via the right-click context menu to the default value to have this this pref removed on the next start.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
16992 solutions 153423 answers

Chosen Solution

You can try to modify multi-process settings to see if this has effect.

  • set number of content processes to 1 if it is currently set to a higher value (4)
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • disable multi-process windows in Firefox

You can disable multi-process windows in Firefox by setting this pref to false on the about:config page.

  • browser.tabs.remote.autostart = false

Note that the previously used opt-in pref browser.tabs.remote.autostart.2 is no longer supported in Firefox 58+. You can reset browser.tabs.remote.autostart.2 via the right-click context menu to the default value to have this this pref removed on the next start.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can try to modify multi-process settings to see if this has effect. *set number of content processes to 1 if it is currently set to a higher value (4)<br>Options/Preferences -> General -> Performance<br>remove checkmark: [ ] "Use recommended performance settings" *disable multi-process windows in Firefox You can disable multi-process windows in Firefox by setting this pref to false on the <b>about:config</b> page. *browser.tabs.remote.autostart = false Note that the previously used opt-in pref browser.tabs.remote.autostart.2 is no longer supported in Firefox 58+. You can reset browser.tabs.remote.autostart.2 via the right-click context menu to the default value to have this this pref removed on the next start. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config *http://www.ghacks.net/2016/07/22/multi-process-firefox/

Question owner

Thanks Cor-el, looks like that worked, not much of a headache anymore.

Thanks Cor-el, looks like that worked, not much of a headache anymore.
driansmith 0 solutions 3 answers

Helpful Reply

Why on earth is the default setting so clunky then? seems absurd that we all have to tweak settings for Firefox to function in an acceptable fashion. :-(

Why on earth is the default setting so clunky then? seems absurd that we all have to tweak settings for Firefox to function in an acceptable fashion. :-(