X
Tap here to go to the mobile version of the site.

Support Forum

parts of emails replaced with question marks

Posted

Starting yesterday, my emails written in Vietnamese (Unicode encoded) are received by all recipients with most characters replaced with question marks. Example: "Chuy???n th??ng 5 kh??ng th??nh r???i". I've observed these few things: 1. This problem happens when I use Thunderbird sending mail thru smtp.mail.yahoo.com 2. This problem does not happen with the same copy of Thunderbird on the same PC sending mail thru smtp.comcast.net 3. This problem does not happen with Outlook on the same PC sending mail thru smtp.mail.yahoo.com 4. A few days ago Yahoo had a problem that Thunderbird and other apps could not access Yahoo Mail. They acknowledged this problem on their Help page at the time and it took them about a day to fix it. My guess is that Yahoo has changed something that makes Thunderbird incompatible (in this aspect) but Outlook still compatible. I contacted Yahoo and of course they said it had nothing to do with their product.

Starting yesterday, my emails written in Vietnamese (Unicode encoded) are received by all recipients with most characters replaced with question marks. Example: "Chuy???n th??ng 5 kh??ng th??nh r???i". I've observed these few things: 1. This problem happens when I use Thunderbird sending mail thru smtp.mail.yahoo.com 2. This problem does not happen with the same copy of Thunderbird on the same PC sending mail thru smtp.comcast.net 3. This problem does not happen with Outlook on the same PC sending mail thru smtp.mail.yahoo.com 4. A few days ago Yahoo had a problem that Thunderbird and other apps could not access Yahoo Mail. They acknowledged this problem on their Help page at the time and it took them about a day to fix it. My guess is that Yahoo has changed something that makes Thunderbird incompatible (in this aspect) but Outlook still compatible. I contacted Yahoo and of course they said it had nothing to do with their product.

Chosen solution

This is caused by bug 1435903. Yahoo!'s SMTP-server doesn't advertise it's capabilities conform the standards.

According to the bug, there's a workadound by setting the preference mail.strictly_mime to true. Go to Tools > Options > Advanced > General > Config Editor and set the pref accordingly.

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

Onno Ekker 114 solutions 428 answers

Chosen Solution

This is caused by bug 1435903. Yahoo!'s SMTP-server doesn't advertise it's capabilities conform the standards.

According to the bug, there's a workadound by setting the preference mail.strictly_mime to true. Go to Tools > Options > Advanced > General > Config Editor and set the pref accordingly.

This is caused by [https://bugzil.la/1435903 bug 1435903]. Yahoo!'s SMTP-server doesn't advertise it's capabilities conform the standards. According to the bug, there's a workadound by setting the preference mail.strictly_mime to true. Go to Tools > Options > Advanced > General > Config Editor and set the pref accordingly.

Helpful Reply

Thank you so much. The workaround by setting the preference mail.strictly_mime to true fixed the problem.

Thank you so much. The workaround by setting the preference mail.strictly_mime to true fixed the problem.
Little_Old_Prof 1 solutions 9 answers

Setting the mime preference to true may have fixed it for me, too.

Setting the mime preference to true may have fixed it for me, too.