X
Tap here to go to the mobile version of the site.

Support Forum

Why does Firefox asks for Master password on startup (for synchronizing) on desktop but not on the Android edition?

Posted

I use a Master password and Firefox Sync on an Android device (58.0.2) and a desktop (ESR 52.6.0). In both setups I have not selected to synchronize my passwords.

On every startup Firefox on Desktop asks for my Master password. As I read in the Mozilla knowledge base [1] and an answer in the Firefox support forum [2] this behavior is intentional as the login used for the Firefox Account is protected by the Master password. Although I find it annoying to deal with the Master password dialog on each startup I recognize the rationale.

It occurred to me that Firefox for Android does not ask for my Master password on every startup, but only in case a password may be entered in a web-site's form. Although Firefox Sync is activated and regularly successfully performed.

I actually have two questions:

A) Is the protection of the Firefox Account login on Firefox for Android less secure than with Firefox for Desktop (presumed a Master password is set in both cases)?

B) Is it possible to adjust the settings of Firefox for Android to behave as the Firefox for Desktop (regarding Firefox Account login protection) and/or vice-versa?

[1] https://support.mozilla.org/en-US/kb/using-master-password-sync

[2] https://support.mozilla.org/en-US/questions/1039575#answer-672996

I use a Master password and Firefox Sync on an Android device (58.0.2) and a desktop (ESR 52.6.0). In both setups I have not selected to synchronize my passwords. On every startup Firefox on Desktop asks for my Master password. As I read in the Mozilla knowledge base [1] and an answer in the Firefox support forum [2] this behavior is intentional as the login used for the Firefox Account is protected by the Master password. Although I find it annoying to deal with the Master password dialog on each startup I recognize the rationale. It occurred to me that Firefox for Android does not ask for my Master password on every startup, but only in case a password may be entered in a web-site's form. Although Firefox Sync is activated and regularly successfully performed. I actually have two questions: A) Is the protection of the Firefox Account login on Firefox for Android less secure than with Firefox for Desktop (presumed a Master password is set in both cases)? B) Is it possible to adjust the settings of Firefox for Android to behave as the Firefox for Desktop (regarding Firefox Account login protection) and/or vice-versa? [1] https://support.mozilla.org/en-US/kb/using-master-password-sync [2] https://support.mozilla.org/en-US/questions/1039575#answer-672996
Attached screenshots

Modified by ringelkrat

Additional System Details

Installed Plug-ins

  • Citrix HDX Plugin (Linux) Version 13.8.0.10299729
  • This plugin provides integration with GNOME Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • The IcedTea-Web Plugin executes Java applets.
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • Firefox 52.6.0
  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
  • Support URL: https://support.mozilla.org/1/firefox/52.6.0/Linux/en-US/

Extensions

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Dict.cc Translation 5.3 (searchdictcc@roughael)
  • Multi-process staged rollout 1.10 (e10srollout@mozilla.org)
  • My Keyboard Navigator 0.8.3 (mykeyboardnavigator@example.org)
  • No Flash 0.5.1 (jid1-cplLTTY501TB2Q@jetpack)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • SoundCloud MP3 Downloader 0.2.0 (jid1-hnmMaq1milpehc6uI@jetpack)
  • uBlock Origin 1.15.6 (uBlock0@raymondhill.net)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile
  • adapterDeviceID: Mesa DRI Intel(R) Sandybridge Mobile
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • crashGuards: []
  • currentAudioBackend: pulse
  • driverDate:
  • driverVersion: 3.0 Mesa 13.0.6
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'description': u'Compositing', u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'description': u'OpenGL Compositing', u'name': u'OPENGL_COMPOSITING'}]}
  • info: {u'ApzWheelInput': 1, u'ApzTouchInput': 1, u'CairoUseXRender': 0, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: No
  • webgl2Renderer: WebGL creation failed: * WebGL 2 requires support for the following features: transform_feedback2 * Exhausted GL driver options.
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4270 solutions 59887 answers

It might be that one system is using the Master Password, but the other is not. Check both their settings.

It might be that one system is using the Master Password, but the other is not. Check both their settings.

Question owner

FredMcD said

It might be that one system is using the Master Password, but the other is not. Check both their settings.

I did double-check the settings and tested the behavior: Both setups ask for the Master password when I browse to a web-site where a password is saved for.

I added screen-shots of the about:config settings filtered to "password" to the original question. Maybe this gives some hint.

''FredMcD [[#answer-1079625|said]]'' <blockquote> It might be that one system is using the Master Password, but the other is not. Check both their settings. </blockquote> I did double-check the settings and tested the behavior: Both setups ask for the Master password when I browse to a web-site where a password is saved for. I added screen-shots of the about:config settings filtered to "password" to the original question. Maybe this gives some hint.