X
Tap here to go to the mobile version of the site.

Support Forum

certificate problem / SSL Error with Firefox 58.0.1 (64-Bit) Kaspersky Internet Security 17.0.0.611 and active FF Master PW

Posted

Since installation of Firefox 58 at Windows 10 I cant access to all SSL / Https pages, also not to Google.com !! Solution is already described by manual updating / deleting and import the Kaspersky certificate (better to edit and simply flag the 3 check boxes of trust setting" for AO Kaspersky Lab).

But: when edit or import the certitificate, always my Master Password for Firefox Password manager is requested. And at next Firefox start the certificate trust setting flag again is blank and previous settings are lost. If no Master Password is set, there is NO Problem. Previous Firefox version had not such problem and works well ! Thanks for your help! All other browser on my PC work well without SSl certificate error!

Since installation of Firefox 58 at Windows 10 I cant access to all SSL / Https pages, also not to Google.com !! Solution is already described by manual updating / deleting and import the Kaspersky certificate (better to edit and simply flag the 3 check boxes of trust setting" for AO Kaspersky Lab). But: when edit or import the certitificate, always my Master Password for Firefox Password manager is requested. And at next Firefox start the certificate trust setting flag again is blank and previous settings are lost. If no Master Password is set, there is NO Problem. Previous Firefox version had not such problem and works well ! Thanks for your help! All other browser on my PC work well without SSl certificate error!

Modified by Robbi-Fox

Chosen solution

This worked for me:

1. In a new Firefox tab, type or paste "about:config" in the address bar and press Enter/Return. Click the button promising to be careful. 2. In the search box above the list, type or paste "roots" and pause while the list is filtered 3. Double-click the "security.enterprise_roots.enabled" preference to switch the value from false to true.

Read this answer in context 32

Additional System Details

Application

  • Firefox 58.0.1
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
  • Support URL: https://support.mozilla.org/1/firefox/58.0.1/WINNT/de/

Extensions

  • Adblock Plus 3.0.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Kaspersky Protection 5.0.141.16d-20171004092029 (light_plugin_F6F079488B53499DB99380A7E11A93F6@kaspersky.com)
  • Video DownloadHelper 7.1.2 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 660
  • adapterDescription2:
  • adapterDeviceID: 0x1185
  • adapterDeviceID2:
  • adapterDrivers: C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_2e7fa54192fe16d0\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_2e7fa54192fe16d0\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_2e7fa54192fe16d0\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_2e7fa54192fe16d0\nvldumdx.dll C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_2e7fa54192fe16d0\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_2e7fa54192fe16d0\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_2e7fa54192fe16d0\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_2e7fa54192fe16d0\nvldumd.dll
  • adapterDrivers2:
  • adapterRAM: 1536
  • adapterRAM2:
  • adapterSubsysID: 28441462
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2,2 Pixel Structure: BGR ClearType Level: 100 Enhanced Contrast: 50
  • crashGuards: []
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.16299.15
  • driverDate: 10-27-2017
  • driverDate2:
  • driverVersion: 23.21.13.8813
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'name': u'HW_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'Direct2D', u'name': u'DIRECT2D', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'GPU Process', u'name': u'GPU_PROCESS', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'unavailable', u'description': u'WebRender', u'name': u'WEBRENDER', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}]}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'name': u'OMTP', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'Advanced Layers', u'name': u'ADVANCED_LAYERS', u'log': [{u'status': u'available', u'type': u'default'}]}]}
  • info: {u'AzureContentBackend (UI Process)': u'skia', u'AzureCanvasBackend (UI Process)': u'skia', u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'AzureFallbackCanvasBackend (UI Process)': u'cairo', u'ApzAutoscrollInput': 1, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'Direct2D 1.1', u'AzureContentBackend': u'Direct2D 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • webgl1DriverExtensions: GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_robust_resource_initialization GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc_srgb GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 660 Direct3D11 vs_5_0 ps_5_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.db3422764a9b)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 00000000000097c3) EGL_VERSION: 1.4 (ANGLE 2.1.0.db3422764a9b) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture_nv12 EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_CHROMIUM_sync_control EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses EGL_ANGLE_display_robust_resource_initialization
  • webgl2DriverExtensions: GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_multiview GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_robust_resource_initialization GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_float GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc_srgb GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_norm16 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_image_external_essl3 GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 660 Direct3D11 vs_5_0 ps_5_0)
  • webgl2Version: OpenGL ES 3.0 (ANGLE 2.1.0.db3422764a9b)
  • webgl2WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 00000000000097c3) EGL_VERSION: 1.4 (ANGLE 2.1.0.db3422764a9b) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture_nv12 EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_CHROMIUM_sync_control EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses EGL_ANGLE_display_robust_resource_initialization
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11
  • windowUsingAdvancedLayers: True

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
James
  • Top 25 Contributor
  • Moderator
1485 solutions 10327 answers
https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER#w_kaspersky ?

Question owner

Thanks for your quick and kindly help !!! But solution did not fix it ! 1) Kaspersky change to <Do no scan encrypted connections> is only a "nice workarround" and then browser works, BUT then unsave SSL connection.

2) Reinstallation of Kaspersky's certificate works well in Kaspersky but Firefox problem still is same

3) my trial / also poor: Fully de-install Firefox and reboot and new clean reinstallation But still same fault. Also after manual import of Kasperski certificate. Always the same problem: When edit and activate the 3 flags of Kaspersky certificate or import the certitificate, always my Master Password for Firefox Password manager is requested. Then it works well until Firefox is closed. At next Firefox start the certificate trust setting flaga all 3 again blank = previous settings are lost. If no Master Password is set, there is NO Problem.

I have now made a new installation of Kasperky and update to Kaspersky Internet Security 18.0.0.405 (f). But still same problem at Firefox. With active FF Master PW the flags at Kaspersky certificate trust alsways removed and blank at next start. I "feel" that this is a BUG at Firefox 58 / 58.0.1 (64-Bit) Looking forward to your further help and maybe real and final Firefox fix. Thanks again!

Thanks for your quick and kindly help !!! But solution did not fix it ! 1) Kaspersky change to <Do no scan encrypted connections> is only a "nice workarround" and then browser works, BUT then unsave SSL connection. 2) Reinstallation of Kaspersky's certificate works well in Kaspersky but Firefox problem still is same 3) my trial / also poor: Fully de-install Firefox and reboot and new clean reinstallation But still same fault. Also after manual import of Kasperski certificate. Always the same problem: When edit and activate the 3 flags of Kaspersky certificate or import the certitificate, always my Master Password for Firefox Password manager is requested. Then it works well until Firefox is closed. At next Firefox start the certificate trust setting flaga all 3 again blank = previous settings are lost. If no Master Password is set, there is NO Problem. I have now made a new installation of Kasperky and update to Kaspersky Internet Security 18.0.0.405 (f). But still same problem at Firefox. With active FF Master PW the flags at Kaspersky certificate trust alsways removed and blank at next start. I "feel" that this is a BUG at Firefox 58 / 58.0.1 (64-Bit) Looking forward to your further help and maybe real and final Firefox fix. Thanks again!

Modified by Robbi-Fox

ysfcry 0 solutions 4 answers

Hi, I have experienced this problem myself. The solution is as follows; Open firefox settings, left side privacy and security, from the bottom show certifications, Find kaspersky certifica, set trust settings.

Hi, I have experienced this problem myself. The solution is as follows; Open firefox settings, left side privacy and security, from the bottom show certifications, Find kaspersky certifica, set trust settings.

Question owner

Hi ysfcry, Thanks for your kindly help and nice screen pictures! But this did not work if at Firefox a Master Pasword is setup for protection all stored passwords in Firefox. >In this case the 3 check marks /flags for certificate trust can be set. > Then FF ask for Master Password input > Then FF works well for this certificate. > BUT: after close Firefox and restart, again the 3 trust flags are blank and certificate error is shown. In case the Master Pasword is removed, the trust flags remain,also at new restart. But with active Master Password it always failed :-((

Hi ysfcry, Thanks for your kindly help and nice screen pictures! But this did not work if at Firefox a Master Pasword is setup for protection all stored passwords in Firefox. >In this case the 3 check marks /flags for certificate trust can be set. > Then FF ask for Master Password input > Then FF works well for this certificate. > BUT: after close Firefox and restart, again the 3 trust flags are blank and certificate error is shown. In case the Master Pasword is removed, the trust flags remain,also at new restart. But with active Master Password it always failed :-((
ysfcry 0 solutions 4 answers

Robbi-Fox dedi ki

Hi ysfcry, Thanks for your kindly help and nice screen pictures! But this did not work if at Firefox a Master Pasword is setup for protection all stored passwords in Firefox. >In this case the 3 check marks /flags for certificate trust can be set. > Then FF ask for Master Password input > Then FF works well for this certificate. > BUT: after close Firefox and restart, again the 3 trust flags are blank and certificate error is shown. In case the Master Pasword is removed, the trust flags remain,also at new restart. But with active Master Password it always failed :-((

Yes now I have noticed. Using Master Password will reset the settings. I guess we have no choice but to wait for an update. :||

''Robbi-Fox [[#answer-1072373|dedi ki]]'' <blockquote> Hi ysfcry, Thanks for your kindly help and nice screen pictures! But this did not work if at Firefox a Master Pasword is setup for protection all stored passwords in Firefox. >In this case the 3 check marks /flags for certificate trust can be set. > Then FF ask for Master Password input > Then FF works well for this certificate. > BUT: after close Firefox and restart, again the 3 trust flags are blank and certificate error is shown. In case the Master Pasword is removed, the trust flags remain,also at new restart. But with active Master Password it always failed :-(( </blockquote> Yes now I have noticed. Using Master Password will reset the settings. I guess we have no choice but to wait for an update. :||
cor-el
  • Top 10 Contributor
  • Moderator
16564 solutions 149546 answers

Try to remove cert8.db and cert9.db and secmode.db and pkcs11.txt to reset the certificate store with Firefox closed.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Try to remove cert8.db and cert9.db and secmode.db and pkcs11.txt to reset the certificate store with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox

Question owner

Hi cor-el, THANKS a lot for your great and kindly help !!! Unfortunatelly your proposal only solved it at the first start after the files had been removed (I did not removed but simpy renamed them for checkin). Seems that after new start FF creates the 3 files new. And then after close and restart, again same issue and the 1 to 3 trust flags at Kaspersky certificate are removed and blank and SSL issue is shown. I still suppose this is a BUG a Firefox 58 :-(( But thanks again to all for your great support. So still waiting for final solution ...

Hi cor-el, THANKS a lot for your great and kindly help !!! Unfortunatelly your proposal only solved it at the first start after the files had been removed (I did not removed but simpy renamed them for checkin). Seems that after new start FF creates the 3 files new. And then after close and restart, again same issue and the 1 to 3 trust flags at Kaspersky certificate are removed and blank and SSL issue is shown. I still suppose this is a '''BUG a Firefox 58''' :-(( But thanks again to all for your great support. So still waiting for final solution ...
philipp
  • Top 25 Contributor
  • Moderator
5114 solutions 22659 answers

hi, i couldn't reproduce the issue myself trying with a kaspersky trial version - could you file a bug for this issue at https://bugzilla.mozilla.org so that mozilla's developers get aware of it? thank you...

hi, i couldn't reproduce the issue myself trying with a kaspersky trial version - could you file a bug for this issue at https://bugzilla.mozilla.org so that mozilla's developers get aware of it? thank you...

Question owner

Hi dear philip, thanks for this advice. I had tried this already initially on 29.01. But I always failed to create a new account at bugzilla and always no mail for registartion was sent. Today same issue .. But after 3 trial in same way sudenly I received a confirmation mail and now I have created a new Bug ID 1434731. Cross my fingers that the developers can solve it. Thanks again for you help!

Hi dear philip, thanks for this advice. I had tried this already initially on 29.01. But I always failed to create a new account at bugzilla and always no mail for registartion was sent. Today same issue .. But after 3 trial in same way sudenly I received a confirmation mail and now I have created a new Bug ID 1434731. Cross my fingers that the developers can solve it. Thanks again for you help!
ysfcry 0 solutions 4 answers

Helpful Reply

Hi everyone, I solved the problem like this. I set the certificate and I set the master password. I entered the profile files. cert8.db, cert9.db, pkcs11.txt, secmode.db right click on files read-only tic. He's no longer making a mistake.

Hi everyone, I solved the problem like this. I set the certificate and I set the master password. I entered the profile files. cert8.db, cert9.db, pkcs11.txt, secmode.db right click on files read-only tic. He's no longer making a mistake.

Question owner

Hi ysfcry, thanks a lot for your ongoing help! Yes I can confirm your proposal to set this files to read-only avoids the SSL issue. So I will use this nice idea temporary. Problem now is: > From FF screen I can not anymore change or remove the Master PW > I'm afraid that no certificates can be updated anymore in future. So I frequnetly will need to remove the read-only flag from this files for any updates.

But this countermeasure also helps and confirms that FF problems seems to be at start-up, not when FF is closed.

So: I feel this is a BUG in FF58. So I will wait for final correction from the developers, as I raised a bugzilla report.

Hi ysfcry, thanks a lot for your ongoing help! Yes I can confirm your proposal to '''set this files to read-only''' ''avoids ''the SSL issue. So I will use this nice idea temporary. Problem now is: > From FF screen I can not anymore change or remove the Master PW > I'm afraid that no certificates can be updated anymore in future. So I frequnetly will need to remove the read-only flag from this files for any updates. But this countermeasure also helps and confirms that FF problems seems to be '''at start-up''', not when FF is closed. So: I feel this is a '''BUG in FF58'''. So I will wait for final correction from the developers, as I raised a bugzilla report.

Modified by Robbi-Fox

ysfcry 0 solutions 4 answers

Robbi-Fox dedi ki

Hi ysfcry, thanks a lot for your ongoing help! Yes I can confirm your proposal to set this files to read-only avoids the SSL issue. So I will use this nice idea temporary. Problem now is: > From FF screen I can not anymore change or remove the Master PW > I'm afraid that no certificates can be updated anymore in future. So I frequnetly will need to remove the read-only flag from this files for any updates. But this countermeasure also helps and confirms that FF problems seems to be at start-up, not when FF is closed. So: I feel this is a BUG in FF58. So I will wait for final correction from the developers, as I raised a bugzilla report.

Let's manage a bit, the mozilla team will solve the problem.

''Robbi-Fox [[#answer-1073059|dedi ki]]'' <blockquote> Hi ysfcry, thanks a lot for your ongoing help! Yes I can confirm your proposal to '''set this files to read-only''' ''avoids ''the SSL issue. So I will use this nice idea temporary. Problem now is: > From FF screen I can not anymore change or remove the Master PW > I'm afraid that no certificates can be updated anymore in future. So I frequnetly will need to remove the read-only flag from this files for any updates. But this countermeasure also helps and confirms that FF problems seems to be '''at start-up''', not when FF is closed. So: I feel this is a '''BUG in FF58'''. So I will wait for final correction from the developers, as I raised a bugzilla report. </blockquote> Let's manage a bit, the mozilla team will solve the problem.
Dulverton 2 solutions 7 answers

Chosen Solution

This worked for me:

1. In a new Firefox tab, type or paste "about:config" in the address bar and press Enter/Return. Click the button promising to be careful. 2. In the search box above the list, type or paste "roots" and pause while the list is filtered 3. Double-click the "security.enterprise_roots.enabled" preference to switch the value from false to true.

This worked for me: 1. In a new Firefox tab, type or paste "about:config" in the address bar and press Enter/Return. Click the button promising to be careful. 2. In the search box above the list, type or paste "roots" and pause while the list is filtered 3. Double-click the "security.enterprise_roots.enabled" preference to switch the value from false to true.

Question owner

Hi Dulverton,

THANKS. While SSL Error in FF I opened "about:config" and set "security.enterprise_roots.enabled" value by double click from false to true. w/o restart the SSL error is gone and all https:/ pages work again OK. solved! BUT: Do you know any negaitive side effects ?? Maybe now the certificate check is unabled and FF security is weak ?? Can you confirm that security is same as before and that this is no risk ?

Hi Dulverton, '''THANKS'''. While SSL Error in FF I opened "about:config" and set "security.enterprise_roots.enabled" value by double click from false to true. w/o restart the SSL error is gone and all https:/ pages work again '''OK. solved! '''BUT: Do you know any negaitive side effects ?? Maybe now the certificate check is unabled and FF security is weak ?? Can you confirm that security is same as before and that this is no risk ?
cor-el
  • Top 10 Contributor
  • Moderator
16564 solutions 149546 answers

A possible risk is that if there are certificates in the Windows certificate store added by malware or certificates that shouldn't be trusted that you get these certificates in Firefox when you toggle this pref to true (it's all or nothing).

A possible risk is that if there are certificates in the Windows certificate store added by malware or certificates that shouldn't be trusted that you get these certificates in Firefox when you toggle this pref to true (it's all or nothing).
Dulverton 2 solutions 7 answers

I'm no expert, but this is the reply I had from Kaspersky:

Dear customer,

Thank you for your reply.

I would like to inform you that these changes don't affect the security of your browser.

Unfortunately we do not have any information yet about the date of the new patch, but you can contact us again when the (g) patch will be released, if you have any issue.

Thank you.

I hope you find this information useful.

I'm no expert, but this is the reply I had from Kaspersky: Dear customer, Thank you for your reply. I would like to inform you that these changes don't affect the security of your browser. Unfortunately we do not have any information yet about the date of the new patch, but you can contact us again when the (g) patch will be released, if you have any issue. Thank you. I hope you find this information useful.