Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

NTLM proxy authentification - no prompt when using a Microsoft Windows account

  • 4 replies
  • 1 has this problem
  • 1 view
  • Last reply by jflize

more options

Hi,

This problem with proxy authentification isn't new and we lived with it for at least the past year or so. Because we get so many support requests about this (I am from the IT department), we have now decided to investigate some more.

So to use our "pac" proxy, students have to configure their OS network settings with "Automatic proxy settings" using our proxy address. We set Firefox to use system proxy settings (problem occur with Firefox own proxy settings too).

Some users don't get the proxy authentication window on websites they are suppose to. To those, we guide them to set "network.automatic-ntlm-auth.allow-proxies" to "False" under the "about:config" menu. Then the authentication window comes up as it should (Windows not trying to pass credentials first). Thing is, it's a pain for our IT department to guide many Firefox users through this process and although we have online documentations that mention the extra steps, many students struggle with the process.

Today, we found more informations about the problem. It appears that users that have this issue are using "Microsoft account" type of login on their machine. If we change their accounts from Microsoft accounts to simple local accounts on their machines, then the proxy authentication window comes up correctly, without changing any Firefox setting ("network.automatic-ntlm-auth.allow-proxies" still to True)

This problem is easily reproduced switch between Microsoft account login to simple local account and vice-versa.

We have done our tests with Windows 10 machines running Firefox 64-bit (version 58.0) and we haven't tested yet if the problem occur with other versions of Windows or Firefox 32-bit. It doesn't seems to matter on what network the machine is connected to.

Other browsers never have issues getting the proxy authentication window to show up, no matter if using a Microsoft account or local account. Also no need to change any settings.

Is this a known Firefox bug ? Can this problem be brought to Mozilla developpers ? Is there an easier workaround ?

Thank you very much in advance !

Jeff

Latest edit : As suggested, removed links from our institution.

Hi, This problem with proxy authentification isn't new and we lived with it for at least the past year or so. Because we get so many support requests about this (I am from the IT department), we have now decided to investigate some more. So to use our "pac" proxy, students have to configure their OS network settings with "Automatic proxy settings" using our proxy address. We set Firefox to use system proxy settings (problem occur with Firefox own proxy settings too). Some users don't get the proxy authentication window on websites they are suppose to. To those, we guide them to set "network.automatic-ntlm-auth.allow-proxies" to "False" under the "about:config" menu. Then the authentication window comes up as it should (Windows not trying to pass credentials first). Thing is, it's a pain for our IT department to guide many Firefox users through this process and although we have online documentations that mention the extra steps, many students struggle with the process. Today, we found more informations about the problem. It appears that users that have this issue are using "Microsoft account" type of login on their machine. If we change their accounts from Microsoft accounts to simple local accounts on their machines, then the proxy authentication window comes up correctly, without changing any Firefox setting ("network.automatic-ntlm-auth.allow-proxies" still to True) This problem is easily reproduced switch between Microsoft account login to simple local account and vice-versa. We have done our tests with Windows 10 machines running Firefox 64-bit (version 58.0) and we haven't tested yet if the problem occur with other versions of Windows or Firefox 32-bit. It doesn't seems to matter on what network the machine is connected to. Other browsers never have issues getting the proxy authentication window to show up, no matter if using a Microsoft account or local account. Also no need to change any settings. Is this a known Firefox bug ? Can this problem be brought to Mozilla developpers ? Is there an easier workaround ? Thank you very much in advance ! Jeff Latest edit : As suggested, removed links from our institution.

Modified by jflize

All Replies (4)

more options

Sorry, but I am advising anyone from downloading any software as that is a security risk for anyone trying to help. At this point you need to contact your College IT for help on the settings.

more options

I am from the IT department... And no need to dowload any software.

Modified by jflize

more options

Clicking on the link http://proxy.umontreal.ca/ - it wants to download to install. Anytime something wants to download install from a link my advice is a big "NO" to clicking on it. Is there a reason why this can't be a pdf for others in the college to read and follow?

more options

Edit : Removed links as suggested.

Modified by jflize