Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 57 clicking on link in a web page opens new tab in new window; I want the tab to open in SAME window

  • 2 replies
  • 8 have this problem
  • 17347 views
  • Last reply by radar

more options

In Firefox 57, when I click on a link on the current tab I want the link to open in a new tab in the SAME window i am currently in; however, currently, the new web page opens in a new WINDOW, instead. How do I get the new tab to open in the SAME window?

Chosen solution

I see from the add-ons list you shared that you have the "Open Link with New Tab" extension. If that is set to open all links in a new tab, I'm not sure what is causing the new window.

Firefox may not be able to open a new tab in certain kinds of pop-up windows. Typically you would recognize these as "dialog" style because most of the toolbar is missing and you do not have a tabs bar.

However, if it's a normal window, perhaps there is a script attached to the link. To force scripts to launch new windows in a new tab, you may need to modify a setting. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste neww and pause while the list is filtered

(3) Adjust the preferences as follows:

(A) browser.link.open_newwindow - for links in Firefox tabs

  • 3 = divert new window to a new tab (default) <= This should already be set; if it's not, right-click > Reset to restore the default
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

  • 0 = apply the setting under (A) to ALL new windows (even script windows) <= Try this one
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

  • -1 = apply the setting under (A) to external links (default) <= this should already be set; if it's not, right-click > Reset to restore the default)
  • 3 = open external links in a new tab in the last active window
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, right-click each "modified" preference and choose Reset.

Does it help with that site?

Read this answer in context 👍 11

All Replies (2)

more options

Chosen Solution

I see from the add-ons list you shared that you have the "Open Link with New Tab" extension. If that is set to open all links in a new tab, I'm not sure what is causing the new window.

Firefox may not be able to open a new tab in certain kinds of pop-up windows. Typically you would recognize these as "dialog" style because most of the toolbar is missing and you do not have a tabs bar.

However, if it's a normal window, perhaps there is a script attached to the link. To force scripts to launch new windows in a new tab, you may need to modify a setting. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste neww and pause while the list is filtered

(3) Adjust the preferences as follows:

(A) browser.link.open_newwindow - for links in Firefox tabs

  • 3 = divert new window to a new tab (default) <= This should already be set; if it's not, right-click > Reset to restore the default
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

  • 0 = apply the setting under (A) to ALL new windows (even script windows) <= Try this one
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

  • -1 = apply the setting under (A) to external links (default) <= this should already be set; if it's not, right-click > Reset to restore the default)
  • 3 = open external links in a new tab in the last active window
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, right-click each "modified" preference and choose Reset.

Does it help with that site?

more options

Thanks, jscher2000. This fixed my problem.