X
Tap here to go to the mobile version of the site.

Support Forum

why is Thunderbird adding strange symbols to my emails, nobody can read them?

Posted

My emails look fine in the Sent box. But nobody can read them when they arrive, and when returned they look horrific. Here is an example:

IV, Page 112.Present� � � � � � � � � � Perfectvituperant� � � � � � � � �coxitcoquit� � � � � � � � � � � �terruitfaciunt� � � � � � � � � � � duxitaudit� � � � � � � � � � � � �vituperaveruntterret � cepitducit� � � � � � � � � � � � laboraveruntlaborant� � � � � � � � � �audivitcapit� � � � � � � � � � � � �fecerunt

This has just started, it's been fine up till now,, and I am at a loss to know what to do. I am using Windows 7, 64 bit, have Norton and Malware Bytes, and the latest Thunderbird version, now set on Western following my reading of your forums, but absolutely nothing is working.

Can you help?

Thanks

My emails look fine in the Sent box. But nobody can read them when they arrive, and when returned they look horrific. Here is an example: IV, Page 112.Present� � � � � � � � � � Perfectvituperant� � � � � � � � �coxitcoquit� � � � � � � � � � � �terruitfaciunt� � � � � � � � � � � duxitaudit� � � � � � � � � � � � �vituperaveruntterret � cepitducit� � � � � � � � � � � � laboraveruntlaborant� � � � � � � � � �audivitcapit� � � � � � � � � � � � �fecerunt This has just started, it's been fine up till now,, and I am at a loss to know what to do. I am using Windows 7, 64 bit, have Norton and Malware Bytes, and the latest Thunderbird version, now set on Western following my reading of your forums, but absolutely nothing is working. Can you help? Thanks

Chosen solution

lets see.

Western is about the worst setting you could choose. UTF or UNICODE is the defacto standard for email and has been for years. Unfortunately some folk insist on using old windows code pages for mail and that ofen causes problems. So do not join them. Unicode unless you just can not get away with it.

Now to this bit, I can only guess because I have no message source, but there are some option.

1. Text copies from a word processing program. Word in particular tends to paste very bad HTML and specifications for fonts that are unrealistic in the real world. Especially for those that do not have the Microsoft office fonts installed (apple, android, Linux etc.)

2. You have specified a font for the message to be composed in that is simply not installed on the recipients device so it has substituted something the machine thinks is similar (for instance is also a san serif font)

3. The outgoing message is corrupted during transmission. Usually the result of anti virus scanning.

4. The incoming message is corrupted by scanning. (particularly common where PDF attachments are concerned)

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Matt
  • Top 10 Contributor
  • Moderator
3232 solutions 22173 answers

Chosen Solution

lets see.

Western is about the worst setting you could choose. UTF or UNICODE is the defacto standard for email and has been for years. Unfortunately some folk insist on using old windows code pages for mail and that ofen causes problems. So do not join them. Unicode unless you just can not get away with it.

Now to this bit, I can only guess because I have no message source, but there are some option.

1. Text copies from a word processing program. Word in particular tends to paste very bad HTML and specifications for fonts that are unrealistic in the real world. Especially for those that do not have the Microsoft office fonts installed (apple, android, Linux etc.)

2. You have specified a font for the message to be composed in that is simply not installed on the recipients device so it has substituted something the machine thinks is similar (for instance is also a san serif font)

3. The outgoing message is corrupted during transmission. Usually the result of anti virus scanning.

4. The incoming message is corrupted by scanning. (particularly common where PDF attachments are concerned)

lets see. Western is about the worst setting you could choose. UTF or UNICODE is the defacto standard for email and has been for years. Unfortunately some folk insist on using old windows code pages for mail and that ofen causes problems. So do not join them. Unicode unless you just can not get away with it. Now to this bit, I can only guess because I have no message source, but there are some option. 1. Text copies from a word processing program. Word in particular tends to paste very bad HTML and specifications for fonts that are unrealistic in the real world. Especially for those that do not have the Microsoft office fonts installed (apple, android, Linux etc.) 2. You have specified a font for the message to be composed in that is simply not installed on the recipients device so it has substituted something the machine thinks is similar (for instance is also a san serif font) 3. The outgoing message is corrupted during transmission. Usually the result of anti virus scanning. 4. The incoming message is corrupted by scanning. (particularly common where PDF attachments are concerned)

Question owner

THANK you, Matt, for your assistance. VERY much appreciated.

This answer will show my ignorance of Thunderbird's workings which I originally changed on advice from an internet help column, but can you please direct me to instructions or tell me how to restore the defaults it came with?

I am assuming it downloaded originally with  UTF or UNICODE?  If not, I  would like to restore it to one of the two you mention,  Ideally I would like to return it to the state it was in originally, it worked fine till I meddled with it.

I had about given up. I teach online and have to respond to hundreds of people, none of whom can read a word, so you can see your help is much needed and appreciated.

THANK you, Matt, for your assistance. VERY much appreciated. This answer will show my ignorance of Thunderbird's workings which I originally changed on advice from an internet help column, but can you please direct me to instructions or tell me how to restore the defaults it came with? I am assuming it downloaded originally with UTF or UNICODE? If not, I would like to restore it to one of the two you mention, Ideally I would like to return it to the state it was in originally, it worked fine till I meddled with it. I had about given up. I teach online and have to respond to hundreds of people, none of whom can read a word, so you can see your help is much needed and appreciated.
Zenos 2265 solutions 12258 answers

Helpful Reply

Try here:

Tools|Options|Display|Formatting

Under Fonts & Colours, click on Advanced.

At the bottom of the next window, under "Text Encoding" you can select the default encoding. Here you can choose "Unicode (UTF-8)".

Let us know if this makes any difference.

Try here: '''Tools|Options|Display|Formatting''' Under '''Fonts & Colours''', click on '''Advanced'''. At the bottom of the next window, under "Text Encoding" you can select the default encoding. Here you can choose "Unicode (UTF-8)". Let us know if this makes any difference.
Onno Ekker 114 solutions 428 answers

Go to Tools > Options > Display > Formatting and click on Advanced… on the right under Fonts & Colors. Now choose Unicode (UTF-8) as text encoding for incoming and outgoing mail.

Go to Tools > Options > Display > Formatting and click on Advanced… on the right under Fonts & Colors. Now choose Unicode (UTF-8) as text encoding for incoming and outgoing mail.

Helpful Reply

THANK you, Zenos and Onno!

From what I have gotten back so far it works!! I wanted to try to test it out and I'm still waiting for a couple more letters to come back, but fingers crossed, so far you seem to have solved it.

This problem has seemed to stump everybody else I've asked and I really appreciate such fast and accurate help!

Many grateful thanks!

M.

THANK you, Zenos and Onno! From what I have gotten back so far it works!! I wanted to try to test it out and I'm still waiting for a couple more letters to come back, but fingers crossed, so far you seem to have solved it. This problem has seemed to stump everybody else I've asked and I really appreciate such fast and accurate help! Many grateful thanks! M.
tsines 0 solutions 1 answers

My problem is similar but only seems to affect mass mailed political messages that I receive. I have incoming and outgoing text encoding set to Unicode, but political messages I receive are always in Western for some reason. No other messages seem to be affected. Not a huge problem, but it bothers me that no settings are effective in forcing these messages to Unicode.


UPDATE: this question is off-topic and I have re-posted it as "Some emails encoded improperly" in SUPPORT FORUM > THUNDERBIRD

My problem is similar but only seems to affect mass mailed political messages that I receive. I have incoming and outgoing text encoding set to Unicode, but political messages I receive are always in Western for some reason. No other messages seem to be affected. Not a huge problem, but it bothers me that no settings are effective in forcing these messages to Unicode. '''UPDATE: this question is off-topic and I have re-posted it as "Some emails encoded improperly" in SUPPORT FORUM > THUNDERBIRD'''

Modified by tsines

Matt
  • Top 10 Contributor
  • Moderator
3232 solutions 22173 answers

@tsines Funny how political parties that claim we should be offering them a chance to run our lives have difficult coping with something as simple as email.

However you problem is not the same as that in the original question here. You problem relates to folk that have not weaned themselves of Microsoft smart quotes. I suggest you ask your own question to further discuss the issue. This is not the place.

@tsines Funny how political parties that claim we should be offering them a chance to run our lives have difficult coping with something as simple as email. However you problem is not the same as that in the original question here. You problem relates to folk that have not weaned themselves of Microsoft smart quotes. I suggest you ask your own question to further discuss the issue. This is not the place.