X
Tap here to go to the mobile version of the site.

Support Forum

Adding custom search engine to Thunderbird

Posted

Hello!

I'm using Thunderbird 52.5.0 (64-bit) on Debian Stretch.

So I am following https://support.mozilla.org/en-US/kb/add-search-engine-open-search to add a custom search engine to Thunderbird. (I want to add DDG as instructed at https://duck.co/help/desktop/thunderbird but for now I am following the support article.)

This is the google.xml https://pastebin.com/yRaXyJXb But I still can't see Google search engine in Preferences -> General -> Default Search Engine list. Am I missing something?

Any pointers will be really helpful.

Thank you!

Hello! I'm using Thunderbird 52.5.0 (64-bit) on Debian Stretch. So I am following https://support.mozilla.org/en-US/kb/add-search-engine-open-search to add a custom search engine to Thunderbird. (I want to add DDG as instructed at https://duck.co/help/desktop/thunderbird but for now I am following the support article.) This is the google.xml https://pastebin.com/yRaXyJXb But I still can't see Google search engine in Preferences -> General -> Default Search Engine list. Am I missing something? Any pointers will be really helpful. Thank you!

Modified by Avinash Sonawane

Chosen solution

1. Create a searchplugins folder in the profile folder, and copy into it the desired xml files such as ddg.xml, google.xml etc. 2. When you launch TB, the added search engines are not visible in Options, as expected. 3. Close TB and rename search.json.mozlz4 in the profile folder to search.json.mozlz4.OLD; a new search.json.mozlz4 is created when TB is launched, and now the added search engines are available in Options.

Read this answer in context 3

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

Zenos 2265 solutions 12258 answers

I used the Google Search add-on. It creates its own searchplugins folder into which you can put the ddg xml file.

I used the Google Search add-on. It creates its own searchplugins folder into which you can put the ddg xml file.

Question owner

Zenos said

I used the Google Search add-on.

Thanks for the addon suggestion. But I really don't want to install yet another addon for the problem which has a direct knowledge base page https://support.mozilla.org/en-US/kb/add-search-engine-open-search

As long as the above mentioned page suggests a particular way I would like to stick to it please! ;)

''Zenos [[#answer-1055400|said]]'' <blockquote> I used the Google Search add-on. </blockquote> Thanks for the addon suggestion. But I really don't want to install yet another addon for the problem which has a direct knowledge base page https://support.mozilla.org/en-US/kb/add-search-engine-open-search As long as the above mentioned page suggests a particular way I would like to stick to it please! ;)
Matt
  • Top 10 Contributor
  • Moderator
3136 solutions 21350 answers

Avinash Sonawane said

Zenos said
I used the Google Search add-on.

Thanks for the addon suggestion. But I really don't want to install yet another addon for the problem which has a direct knowledge base page https://support.mozilla.org/en-US/kb/add-search-engine-open-search

As long as the above mentioned page suggests a particular way I would like to stick to it please! ;)


Then use the XML file it suggests instead of one you like from somewhere else. They are not the same.

Make sure you follow the case of the folder names. UNIX/Linux operating systems use case in folder names unlike windows. searchplugins is not the same as Searchplugins.

Ensure searchplugins is on the same level in your profile as mail and imapmail

Note that setting the default search engine is done in preferences > General. The heart stuff on Duck Duck go is some years old.

''Avinash Sonawane [[#answer-1055403|said]]'' <blockquote> ''Zenos [[#answer-1055400|said]]'' <blockquote> I used the Google Search add-on. </blockquote> Thanks for the addon suggestion. But I really don't want to install yet another addon for the problem which has a direct knowledge base page https://support.mozilla.org/en-US/kb/add-search-engine-open-search As long as the above mentioned page suggests a particular way I would like to stick to it please! ;) </blockquote> Then use the [https://bwinton.latte.ca/Work/google.xml XML file] it suggests instead of one you like from somewhere else. They are not the same. Make sure you follow the case of the folder names. UNIX/Linux operating systems use case in folder names unlike windows. searchplugins is not the same as Searchplugins. Ensure searchplugins is on the same level in your profile as mail and imapmail Note that setting the default search engine is done in preferences > General. The heart stuff on Duck Duck go is some years old.

Question owner

Matt said

Avinash Sonawane said
Zenos said
I used the Google Search add-on.

Thanks for the addon suggestion. But I really don't want to install yet another addon for the problem which has a direct knowledge base page https://support.mozilla.org/en-US/kb/add-search-engine-open-search

As long as the above mentioned page suggests a particular way I would like to stick to it please! ;)


Then use the XML file it suggests instead of one you like from somewhere else. They are not the same.

Yes. They are the same! I don't know why you are saying they aren't. Can you please carefully look at the pastebin link I have provided?

PS - If you are thinking about xmlns attribute then it's there at KB article provided link! Ctrl+U should reveal that!

Matt said

Make sure you follow the case of the folder names. UNIX/Linux operating systems use case in folder names unlike windows. searchplugins is not the same as Searchplugins.

Again, if you would carefully look at that pastebin link you would have noticed it's searchplugins (all lower case) exactly what KB has suggested.

Matt said

Ensure searchplugins is on the same level in your profile as mail and imapmail

Same. Please have a look at the pastebin link.

Matt said

Note that setting the default search engine is done in preferences > General.

Yes, I kinda mentioned that in my original post.

Matt said

The heart stuff on Duck Duck go is some years old.

As I said, not interested in DDG for now. Just following the Knowledge Base article. So it's Google. (For now.)

''Matt [[#answer-1055411|said]]'' <blockquote> ''Avinash Sonawane [[#answer-1055403|said]]'' <blockquote> ''Zenos [[#answer-1055400|said]]'' <blockquote> I used the Google Search add-on. </blockquote> Thanks for the addon suggestion. But I really don't want to install yet another addon for the problem which has a direct knowledge base page https://support.mozilla.org/en-US/kb/add-search-engine-open-search As long as the above mentioned page suggests a particular way I would like to stick to it please! ;) </blockquote> Then use the [https://bwinton.latte.ca/Work/google.xml XML file] it suggests instead of one you like from somewhere else. They are not the same. </blockquote> Yes. They are the '''same'''! I don't know why you are saying they aren't. Can you please carefully look at the pastebin link I have provided? PS - If you are thinking about ''xmlns'' attribute then it's there at KB article provided link! Ctrl+U should reveal that! ''Matt [[#answer-1055411|said]]'' <blockquote> Make sure you follow the case of the folder names. UNIX/Linux operating systems use case in folder names unlike windows. searchplugins is not the same as Searchplugins. </blockquote> Again, if you would carefully look at that pastebin link you would have noticed it's ''searchplugins'' (all lower case) exactly what KB has suggested. ''Matt [[#answer-1055411|said]]'' <blockquote> Ensure searchplugins is on the same level in your profile as mail and imapmail </blockquote> Same. Please have a look at the pastebin link. ''Matt [[#answer-1055411|said]]'' <blockquote> Note that setting the default search engine is done in preferences > General. </blockquote> Yes, I kinda mentioned that in my original post. ''Matt [[#answer-1055411|said]]'' <blockquote> The heart stuff on Duck Duck go is some years old. </blockquote> As I said, not interested in DDG for now. Just following the Knowledge Base article. So it's Google. (For now.)
Matt
  • Top 10 Contributor
  • Moderator
3136 solutions 21350 answers

How stupid of me. Not to realize the orphaned line in the XML file you uploaded was something other than some sort of error.,

This is line 1 of what you posted after to orphan line

<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/">

This is line 1 of the text from bwintons blog. <SearchPlugin>

I do not think I need to go further to identify they are not the same, so this will be last post to this topic.

Did you verify your profile path using the show button in the troubleshooting information on the help menu? Or reading what it says in the profiles.ini file?

Have you restarted Thunderbird so it can read the XML file in the startup of the program? I think I recall that for about 5 years ago when I actually did this.

How stupid of me. Not to realize the orphaned line in the XML file you uploaded was something other than some sort of error., This is line 1 of what you posted after to orphan line <SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/"> This is line 1 of the text from bwintons blog. <SearchPlugin> I do not think I need to go further to identify they are not the same, so this will be last post to this topic. Did you verify your profile path using the show button in the troubleshooting information on the help menu? Or reading what it says in the profiles.ini file? Have you restarted Thunderbird so it can read the XML file in the startup of the program? I think I recall that for about 5 years ago when I actually did this.

Question owner

Matt said

How stupid of me. Not to realize the orphaned line in the XML file you uploaded was something other than some sort of error.,

It's okay. :) Thank you for taking time to helping me out though. :)

Matt said

Did you verify your profile path using the show button in the troubleshooting information on the help menu? Or reading what it says in the profiles.ini file?

Yes, I did. Currently my Thunderbird installation has only one profile. The default one.

Matt said

Have you restarted Thunderbird so it can read the XML file in the startup of the program?

Yes, I did. A couple of times actually. But still can't see Google in search engines' list.

''Matt [[#answer-1055414|said]]'' <blockquote> How stupid of me. Not to realize the orphaned line in the XML file you uploaded was something other than some sort of error., </blockquote> It's okay. :) Thank you for taking time to helping me out though. :) ''Matt [[#answer-1055414|said]]'' <blockquote> Did you verify your profile path using the show button in the troubleshooting information on the help menu? Or reading what it says in the profiles.ini file? </blockquote> Yes, I did. Currently my Thunderbird installation has only one profile. The default one. ''Matt [[#answer-1055414|said]]'' <blockquote> Have you restarted Thunderbird so it can read the XML file in the startup of the program? </blockquote> Yes, I did. A couple of times actually. But still can't see ''Google'' in search engines' list.
sfhowes
  • Top 10 Contributor
1273 solutions 6018 answers

Chosen Solution

1. Create a searchplugins folder in the profile folder, and copy into it the desired xml files such as ddg.xml, google.xml etc. 2. When you launch TB, the added search engines are not visible in Options, as expected. 3. Close TB and rename search.json.mozlz4 in the profile folder to search.json.mozlz4.OLD; a new search.json.mozlz4 is created when TB is launched, and now the added search engines are available in Options.

1. Create a searchplugins folder in the profile folder, and copy into it the desired xml files such as ddg.xml, google.xml etc. 2. When you launch TB, the added search engines are not visible in Options, as expected. 3. Close TB and rename search.json.mozlz4 in the profile folder to search.json.mozlz4.OLD; a new search.json.mozlz4 is created when TB is launched, and now the added search engines are available in Options.

Question owner

That's it! Thank you very much! This solved the issue.

sfhowes said

3. Close TB and rename search.json.mozlz4 in the profile folder to search.json.mozlz4.OLD; a new search.json.mozlz4 is created when TB is launched, and now the added search engines are available in Options.

Can you please let us know how did you figure out this workaround?

That's it! Thank you very much! This solved the issue. ''sfhowes [[#answer-1055508|said]]'' <blockquote> 3. Close TB and rename search.json.mozlz4 in the profile folder to search.json.mozlz4.OLD; a new search.json.mozlz4 is created when TB is launched, and now the added search engines are available in Options. </blockquote> Can you please let us know how did you figure out this workaround?
sfhowes
  • Top 10 Contributor
1273 solutions 6018 answers

Helpful Reply

Avinash Sonawane said

Can you please let us know how did you figure out this workaround?

The question came up a few months ago in the mozilla.support.thunderbird newsgroup, and when I realized the old instructions didn't work after TB 45, I searched and found the key tip on this site.

''Avinash Sonawane [[#answer-1055523|said]]'' <blockquote> Can you please let us know how did you figure out this workaround? </blockquote> The question came up a few months ago in the mozilla.support.thunderbird newsgroup, and when I realized the old instructions didn't work after TB 45, I searched and found the key tip on [https://gist.github.com/mpapis/d884086dd95be7718fe0895fafce7c30 this site].

Question owner

BTW clearly this is not how we want user to set the custom search engine. So I thought of filing a bug report but found an existing one instead. https://bugzilla.mozilla.org/show_bug.cgi?id=1427093

I have left comment linking this Mozilla Support Forum question. I hope the bug gets resolved soon!

BTW clearly this is not how we want user to set the custom search engine. So I thought of filing a bug report but found an existing one instead. https://bugzilla.mozilla.org/show_bug.cgi?id=1427093 I have left comment linking this Mozilla Support Forum question. I hope the bug gets resolved soon!
StirkRK 0 solutions 2 answers

Avinash Sonawane said

BTW clearly this is not how we want user to set the custom search engine. So I thought of filing a bug report but found an existing one instead. https://bugzilla.mozilla.org/show_bug.cgi?id=1427093 I have left comment linking this Mozilla Support Forum question. I hope the bug gets resolved soon!
''Avinash Sonawane [[#answer-1055675|said]]'' <blockquote> BTW clearly this is not how we want user to set the custom search engine. So I thought of filing a bug report but found an existing one instead. https://bugzilla.mozilla.org/show_bug.cgi?id=1427093 I have left comment linking this Mozilla Support Forum question. I hope the bug gets resolved soon! </blockquote>
StirkRK 0 solutions 2 answers

Nothing above worked for me until I commented out the first line in the XML file:

<$ cat ~/.thunderbird/m422kcn9.default/searchplugins/google.xml
Nothing above worked for me until I commented out the first line in the XML file: <$ cat ~/.thunderbird/m422kcn9.default/searchplugins/google.xml