X
Tap here to go to the mobile version of the site.

Support Forum

Put bookmarks in bookmarks menu by default

Posted

Before firefox quantum, when pressing Ctrl+D, the created bookmark was put in the bookmarks menu by default (unlike clicking the star bookmark button, which defaulted to unsorted bookmarks). After updating to quantum, the default location is "Other bookmarks" - the same as pressing the star button.

How do I restore the old behaviour?

Before firefox quantum, when pressing Ctrl+D, the created bookmark was put in the bookmarks menu by default (unlike clicking the star bookmark button, which defaulted to unsorted bookmarks). After updating to quantum, the default location is "Other bookmarks" - the same as pressing the star button. How do I restore the old behaviour?
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5235 solutions 38688 answers

Unsorted Bookmarks was renamed to Other Bookmarks back in the Firefox 56 or 55 version, so they are essentially the same thing although some users may see both those folders with different bookmarks in each. I had that happen with one of my Profiles, but not the other one.

Unsorted Bookmarks was renamed to Other Bookmarks back in the Firefox 56 or 55 version, so they are essentially the same thing although some users may see both those folders with different bookmarks in each. I had that happen with one of my Profiles, but not the other one.
Was this helpful to you? 3
Quote

Question owner

the-edmeister said

Unsorted Bookmarks was renamed to Other Bookmarks back in the Firefox 56 or 55 version, so they are essentially the same thing although some users may see both those folders with different bookmarks in each. I had that happen with one of my Profiles, but not the other one.

I understand that Other bookmarks is what unsorted bookmarks were. My question was how to make bookmarks menu the default location again.

''the-edmeister [[#answer-1051875|said]]'' <blockquote> Unsorted Bookmarks was renamed to Other Bookmarks back in the Firefox 56 or 55 version, so they are essentially the same thing although some users may see both those folders with different bookmarks in each. I had that happen with one of my Profiles, but not the other one. </blockquote> I understand that Other bookmarks is what unsorted bookmarks were. My question was how to make '''bookmarks menu''' the default location again.
Was this helpful to you? 29
Quote
Pkshadow
  • Top 10 Contributor
744 solutions 9058 answers

Not run Beta Versions is a place to start.

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer

Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer https://www.mozilla.org/firefox/all/

Please let us know if this solved your issue or if need further assistance.

Not run Beta Versions is a place to start. uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16230 solutions 146518 answers

Chosen Solution

See also Default Bookmark Folder: * https://addons.mozilla.org/firefox/addon/default-bookmark-folder/
Was this helpful to you? 22
Quote

Question owner

The behaviour is consistent across profiles, but is only in version (beta) 58 for linux. Assuming it is intentional, the Default Bookmark Folder addon does allow you to use the old Ctrl+D behaviour.

The behaviour is consistent across profiles, but is only in version (beta) 58 for linux. Assuming it is intentional, the Default Bookmark Folder addon does allow you to use the old Ctrl+D behaviour.

Modified by sekander94

Was this helpful to you? 3
Quote
stakeouttoo 0 solutions 4 answers

Helpful Reply

have the very same problem.. why would Mozilla change such a thing.. change for the sake of change ..wow just doesn't make any sense.. tried the above solution with the new add-on-- Default Bookmark Folder-- works perfectly.. many thanx

have the very same problem.. why would Mozilla change such a thing.. change for the sake of change ..wow just doesn't make any sense.. tried the above solution with the new add-on-- Default Bookmark Folder-- works perfectly.. many thanx

Modified by stakeouttoo

Was this helpful to you? 25
Quote
pasildan 1 solutions 7 answers

cor-el dijo

See also Default Bookmark Folder:

It worked, thanks for that add-on good sir.

''cor-el [[#answer-1051905|dijo]]'' <blockquote> See also Default Bookmark Folder: * https://addons.mozilla.org/firefox/addon/default-bookmark-folder/ </blockquote> It worked, thanks for that add-on good sir.
Was this helpful to you? 3
Quote
Acloys 1 solutions 8 answers

Helpful Reply

Pkshadow said

Not run Beta Versions is a place to start. uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance.

It's now 27 Jan 2018, and Firefox 58 is no longer beta. It's the standard release (at least on Mac), so advice to avoid using a beta version is not helpful.

I don't ordinarily update right away to the latest release, but decided to this time because of the news reports about the Meltdown (and Spectre) security vulnerability.

The suggestion to fix the problem with an addon doesn't help those of us who don't want another addon, with its own potential side effects.

Is there a known way to fix the problem by adjusting (hidden) settings, such as in about:config?

''Pkshadow [[#answer-1051899|said]]'' <blockquote> Not run Beta Versions is a place to start. uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance. </blockquote> It's now 27 Jan 2018, and Firefox 58 is no longer beta. It's the standard release (at least on Mac), so advice to avoid using a beta version is not helpful. I don't ordinarily update right away to the latest release, but decided to this time because of the news reports about the Meltdown (and Spectre) security vulnerability. The suggestion to fix the problem with an addon doesn't help those of us who don't want another addon, with its own potential side effects. Is there a known way to fix the problem by adjusting (hidden) settings, such as in about:config?

Modified by Acloys

Was this helpful to you? 37
Quote
the-edmeister
  • Top 25 Contributor
  • Moderator
5235 solutions 38688 answers

Acloys said

It's now 27 Jan 2018, and Firefox 58 is no longer beta. It's the standard release (at least on Mac), so advice to avoid using a beta version is not helpful. The suggestion to fix the problem with an addon doesn't help those of us who don't want another addon, with its own potential side effects. Is there a known way to fix the problem by adjusting (hidden) settings, such as in about:config?
  1. Start your own thread rather than posting in an older thread that was solved for the "Owner".
  2. That is a fix which is currently available. May change in the future, but I doubt it.
  3. If there was a hidden preference for that it wouldn't be necessary for a developer to create an extension for that "simple" extension. And cor-el would have mentioned such a pref.
''Acloys [[#answer-1070645|said]]'' <blockquote> It's now 27 Jan 2018, and Firefox 58 is no longer beta. It's the standard release (at least on Mac), so advice to avoid using a beta version is not helpful. The suggestion to fix the problem with an addon doesn't help those of us who don't want another addon, with its own potential side effects. Is there a known way to fix the problem by adjusting (hidden) settings, such as in about:config? </blockquote> # Start your own thread rather than posting in an older thread that was solved for the "Owner". # That is a fix which is currently available. ''May change in the future, but I doubt it.'' # '''If''' there was a hidden preference for that it wouldn't be necessary for a developer to create an extension for that "simple" extension. And cor-el would have mentioned such a pref.
Was this helpful to you? 4
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.