Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 57 won't play streaming ".m3u" files in vlc

  • 21 replies
  • 7 have this problem
  • 495 views
  • Last reply by Tony

more options

Prior to v57 I could click on a link like http://freezone.iinet.net.au/include/radio/playlists/2.m3u and tell Firefox to always open it in VLC, after which I would be able to listen to these sorts of streaming music stations in VLC with a simple click in Firefox. It did open a blank tab as well, but no big deal.

Now when I click such a link, a new blank tab still opens but it just sits there in a "loading" state with a status bar message "Connecting to iinet.net.au...". Eventually it times out.

This has occurred on 2 different machines running Linux Mint (with Firefox Sync active) but also on a Windows 7 machine which does not have FF Sync enabled.

The problem persists even in Safe Mode (i.e., with extensions disabled).

There are ways around this for me - like loading the URL directly into VLC, though that is clumsier; I'm at a bit of a loss as to why/how this change has occurred. But it seems like Firefox wants to play mp3 audio in its own (html5?) builtin player, but that it doesn't support m3u.

The reason I would prefer to listen to streams in VLC is so that if I close Firefox after starting a music stream, then VLC can still keep playing the music.

Chosen solution

Pkshadow said

Before 57 VLC was integrated into Firefox and the codecs for it were in Addons/Pluggins and that was why VLC could play what ever. Now that VLC is locked out it can no longer do that

HI Pkshadow, thank you for that. Strange though that Quantum does actually play via VLC when I install it, but stops doing so a little while after I set up Firefox Sync on my devices.

Also strange is that it works perfectly if I right-click the streaming link and choose "Open link in New Private Window". (Thanks to cor-el for suggesting this).

So that last method is what I will use as my workaround (assuming it continues to work)

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Pkshadow said

Before 57 VLC was integrated into Firefox and the codecs for it were in Addons/Pluggins and that was why VLC could play what ever. Now that VLC is locked out it can no longer do that

HI Pkshadow, thank you for that. Strange though that Quantum does actually play via VLC when I install it, but stops doing so a little while after I set up Firefox Sync on my devices.

Also strange is that it works perfectly if I right-click the streaming link and choose "Open link in New Private Window". (Thanks to cor-el for suggesting this).

So that last method is what I will use as my workaround (assuming it continues to work)

  1. 1
  2. 2