Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 57 won't play streaming ".m3u" files in vlc

  • 21 replies
  • 7 have this problem
  • 458 views
  • Last reply by Tony

more options

Prior to v57 I could click on a link like http://freezone.iinet.net.au/include/radio/playlists/2.m3u and tell Firefox to always open it in VLC, after which I would be able to listen to these sorts of streaming music stations in VLC with a simple click in Firefox. It did open a blank tab as well, but no big deal.

Now when I click such a link, a new blank tab still opens but it just sits there in a "loading" state with a status bar message "Connecting to iinet.net.au...". Eventually it times out.

This has occurred on 2 different machines running Linux Mint (with Firefox Sync active) but also on a Windows 7 machine which does not have FF Sync enabled.

The problem persists even in Safe Mode (i.e., with extensions disabled).

There are ways around this for me - like loading the URL directly into VLC, though that is clumsier; I'm at a bit of a loss as to why/how this change has occurred. But it seems like Firefox wants to play mp3 audio in its own (html5?) builtin player, but that it doesn't support m3u.

The reason I would prefer to listen to streams in VLC is so that if I close Firefox after starting a music stream, then VLC can still keep playing the music.

Chosen solution

Pkshadow said

Before 57 VLC was integrated into Firefox and the codecs for it were in Addons/Pluggins and that was why VLC could play what ever. Now that VLC is locked out it can no longer do that

HI Pkshadow, thank you for that. Strange though that Quantum does actually play via VLC when I install it, but stops doing so a little while after I set up Firefox Sync on my devices.

Also strange is that it works perfectly if I right-click the streaming link and choose "Open link in New Private Window". (Thanks to cor-el for suggesting this).

So that last method is what I will use as my workaround (assuming it continues to work)

Read this answer in context 👍 0

All Replies (20)

more options

OK, let's ignore the Windows machine, as its not my own machine anyway.

I just uninstalled Firefox on one of my Linux Mint PCs and deleted the entire profile from the disk. Then reinstalled it but have NOT activated Firefox Sync. Clicked on one of my .m3u links, and was prompted for what to do, selected "Open with VLC" and "always use this action", and it works fine. And doesn't open a blank tab any more.

I'm thinking something in the cloud profile stored at Firefox Sync was causing this. So I am going to delete the Sync account and set up a fresh one and see what happens. And will update this post shortly.

more options

I should add that I saved my key3.db and logins.json files from local profile before uninstalling Firefox and copied them back after reinstallation, so I still have all my saved passwords.

I will now un install FF on the other machine, and sync it to the fresh account and see if there are any issues.

more options

Reinstalled a few extensions I like, both machines seem to be fine. Looks like something stored in the old F/F Sync account was causing the problem with playing m3u links.

I'm unsure whether just creating a new Sync account would have fixed it, or whether reinstallation of Firefox was also necessary, but douing both certainly seems to have resolved the issue.

Modified by Tony

more options

And a few days later the problem is back again on each machine. Got me baffled.

more options

It looks that this is currently a payed service as I hear no sound and opening the links from the m3u file in a tab doesn't work as well (external players show a forbidden message), so I can't check this.

more options

cor-el said

It looks that this is currently a payed service as I hear no sound and opening the links from the m3u file in a tab doesn't work as well (external players show a forbidden message), so I can't check this.

Thanks for the feedback. It is streamed by my ISP and is available only to customers (eg me). Sorry, I should have said that upfront.

more options

So, what happens if you open such a link? Do you only get a blank tab?

Can you open the link in the m3u file directly in the player?

more options

Hello cor-el, thanks for your input.

Yes I can open these .m3u links in VLC directly and they play just fine.

But if I click on the link in Firefox, a new tab appears, and it sits there for ages, with a status bar message "connecting to freezone.iinet.net.au". Eventually it times out.

If I change Firefox's preferences for MP3 Audio (streamed), from VLC Media Player to "Always ask", it still presents the same blank tab and status bar message - it does not ask me how to open the link.

I can open these links in Firefox on a clean build of a machine, but it seems like using Firefox Sync causes a problem after a few days? I deleted my Sync account the other day and recreated it and all was fine for a few days, then media streams stopped working again.

I have Firefox 57.0.1 installed on 2 Linux Mint desktops & 1 Mint laptop, plus on my Samsung android tablet and my android phone.

Just now I closed FF and deleted the profile on my main PC, then opened FF and clicked on a m3u link and it played OK. I have now enabled Firefox Sync again and the links are still playing ok. Over the next week I will see if the problem recurs ....

more options

Try : https://addons.mozilla.org/en-US/firefox/addon/open-in-vlc/

Please let us know if this solved your issue or if need further assistance.

more options

Newly refreshed Firefox just reverted to refusing to play /m3u streams!

Pkshadow: I'll have a look at that addon shortly, thanks.

more options

OK, I installed open-in-vlc addon on my main Linux Mint PC. It works on the test link http://www.w3schools.com/html/html5_video.asp on the author's page but the right-click menu does not appear when I click on any .m3u or .pls links (as they are text files pointing to a stream, I guess).

I normally play these streams from a custom "intranet" page on my network, that has a collection of streams I like. The reason I prefer to play them in VLC is that if I close my browser, the music keeps playing (in VLC). I'll keep toying with Firefox to see if I can figure out what is happening.

more options

I notice a similar curious behaviour when I paste an mp3 link to a (public) radio stream: http://s9.viastreaming.net:9620/;stream.mp3

First time I do that, it plays the stream from within Firefox.

Then I close that tab, open a new tab and paste the same link. Nothing plays, the tab is blank and "hangs" trying to connect.

Then I clear Firefox's cache, and try again, and the music plays once more.

Yes I repeated this scenario several times to make sure I wasn't imagining it.

I could probably get around all this by 'downgrading' to Firefox Extended Support Release (ESR) on all my devices, but am not about to rush into that.

Modified by Tony

more options

When have time see about other formats like pls No idea other than change the name I would guess........prob not. http://www.web3.lu/playlists-m3u-and-pls/

more options

@ozwrecke

I can replicate this with the link you posted. This looks like a problem with the cache and Firefox may not try to contact the server, but wants to play content in the cache.

It works all the time if I have the developer toolbox open and disable the HTTP cache in the toolbox settings. See "Disable HTTP Cache":

more options

Pkshadow said

When have time see about other formats like pls No idea other than change the name I would guess........prob not. http://www.web3.lu/playlists-m3u-and-pls/

Thanks, but same problem happens with .pls links

more options

cor-el said

@ozwrecke I can replicate this with the link you posted. This looks like a problem with the cache and Firefox may not try to contact the server, but wants to play content in the cache. It works all the time if I have the developer toolbox open and disable the HTTP cache in the toolbox settings. See "Disable HTTP Cache":

Yes I can see the same behaviour. Unfortunately, having that setting on doesn't allow the .m3u or .pls file to launch VLC and play.

I may save my passwords and bookmarks, delete the Sync account (again,) uninstall Firefox from all my devices, wipe their profiles, and start again to see if that resolves my issues.

more options

If Firefox assumes that there is valid data in the disk cache and insists in trying to use this then reinstalling Firefox or setting up Sync again won't have any effect.

Does it have any effect if you use a New Private Window to open the links and if necessary close and reopen this window?

more options

cor-el said

If Firefox assumes that there is valid data in the disk cache and insists in trying to use this then reinstalling Firefox or setting up Sync again won't have any effect. Does it have any effect if you use a New Private Window to open the links and if necessary close and reopen this window?

Yes using a New Private Window does allow the stream to play in the browser.

However my objective is to get VLC to play the streams via Firefox again.

So I wiped the data/profile for Firefox on all 5 devices, restored bookmarks and passwords to one machine and enabled FF Sync on all 5. So far FF on all machines is playing my .m3u or .pls stream links in VLC the way it always used to.

I just need to hope that it stays that way over coming days. Have my fingers crossed! Thank you for your contribution.

more options

Bah! The same old problem has occurred again. Opening .m3u links isn't opening VLC.

But if I open the link in a New Private Window, it does launch VLC and play OK. So that's a workaround that will do me for now.

Thank you cor-el for suggesting the private window idea.

I have to assume that something in FF Quantum handles these things differently to the older versions of Firefox. I might look at logging a bug report if I can find where to do that ...

more options

ozwrecker said

Prior to v57 I could click on a link like http://freezone.iinet.net.au/include/radio/playlists/2.m3u and tell Firefox to always open it in VLC, after which I would be able to listen to these sorts of streaming music stations in VLC with a simple click in Firefox. It did open a blank tab as well, but no big deal. Now when I click such a link, a new blank tab still opens but it just sits there in a "loading" state with a status bar message "Connecting to iinet.net.au...". Eventually it times out. This has occurred on 2 different machines running Linux Mint (with Firefox Sync active) but also on a Windows 7 machine which does not have FF Sync enabled. The problem persists even in Safe Mode (i.e., with extensions disabled). There are ways around this for me - like loading the URL directly into VLC, though that is clumsier; I'm at a bit of a loss as to why/how this change has occurred. But it seems like Firefox wants to play mp3 audio in its own (html5?) builtin player, but that it doesn't support m3u. The reason I would prefer to listen to streams in VLC is so that if I close Firefox after starting a music stream, then VLC can still keep playing the music.

Think finally got your answer as sitting here trying to digest..... Missed the word Prior or would have said this long ago. ..... Before 57 VLC was integrated into Firefox and the codecs for it were in Addons/Pluggins and that was why VLC could play what ever. Now that VLC is locked out it can no longer do that which to me is a shame as VLC codecs are safe and can play anything and never crashed me.

So with that being said there is no option to play anything except what the plugin/Extension now offers unless you jail break it and I no longer think that is possible.

What ever you play has to use the H264 by Cisco http://www.openh264.org/ and the Widevine by Google http://www.widevine.com/ and they are both Video Codecs. Neither address is worth a ...

So the Solution is not what you we wanted.

Modified by Shadow110

  1. 1
  2. 2