Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Stop firefox from forcing https://

  • 3 replies
  • 1 has this problem
  • 13 views
  • Last reply by cor-el

more options

When I request Firefox to open a webpage on my own website using the http:// protocol Firefox still uses the https:// protocol. This is on my own website so I have control over the redirect/rewrite settings.

If I use a private window, the page opens with the http:// protocol, no problem. However if I try open in the main window, I get a "Your connection is not secure" page that I cannot add an exception to.

I have tried changing the following values in about:config

  "browser.urlbar.autoFill": false,
  "browser.urlbar.trimURLs": false,
  "browser.urlbar.autoFill.typed": false,
  "browser.urlbar.autocomplete.enabled": false,

I have tried opening the Library dialog to my history, right-clicking the history entry for the site and "Forget About This Site".

SiteSecurityServiceState.txt does not have the site listed.

All Replies (3)

more options

FF doesn't control that you need to contact your the hosting company about that setting. As you already mentioned: I have control over the redirect/rewrite settings. That would says as well FF has no control what your hosting company does as well.

more options

I am the one hosting it from a dedicated server. I also mentioned: If I use a private window, the page opens with the http:// protocol, no problem. meaning that FF opens the non-https site and has nothing to do with host settings.

Does this mean that I am forced to open this site only through private browsing?

more options

You can check SiteSecurityServiceState.txt file to see if there are entries for your script and remove these lines.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.