X
Tap here to go to the mobile version of the site.

Support Forum

Master password? I've never used one, but...

Posted

I've just upgraded to Firefox 57 and all of a sudden I'm being asked for a master password all the time. So I look in preferences and the box is checked, seemingly by default. Strange, as it never was before. So I try to uncheck it – but I can't because it keeps asking me for a master password I don't actually have... Catch 22.

Stuff still works even if I click on "Cancel" at the prompt, but now my computer-remembered log-ins don't appear and I'm having trouble remembering them myself.

How do I either get out of this situation or revert to the previous version of Firefox?

I've just upgraded to Firefox 57 and all of a sudden I'm being asked for a master password all the time. So I look in preferences and the box is checked, seemingly by default. Strange, as it never was before. So I try to uncheck it – but I can't because it keeps asking me for a master password I don't actually have... Catch 22. Stuff still works even if I click on "Cancel" at the prompt, but now my computer-remembered log-ins don't appear and I'm having trouble remembering them myself. How do I either get out of this situation or revert to the previous version of Firefox?

Chosen solution

I've solved my immediate problem. What I did was this: I remembered that I had Firefox 56 installed on my older Macbook. So I opened it on that and made sure that master password was not enabled (it never had been). Then I quit it. Following that I navigated to the profile on that computer and copied it to a USB drive.

After that it was easy to delete the profile on my main computer (a Macbook Pro) and replace it with the one from my USB drive. On opening Firefox again, hey presto, Master Password is unchecked as it should have been all the time.

I was fortunate that I had another computer from which to copy the folder and thus accomplish this workaround. Other people with the same problem might not be so lucky. The conclusion I draw is that seemingly the requirement for a master password is checked by default in the new version's preferences, leading to the problem I experienced, and if that is the case it needs to be corrected as a bug fix or something.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • Firefox 57.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0
  • Support URL: https://support.mozilla.org/1/firefox/57.0.1/Darwin/en-GB/

Extensions

  • Adblock Plus 3.0.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • eBay for Firefox 5.3.0 ({62760FD6-B943-48C9-AB09-F99C6FE96088})
  • Looking Glass 1.0.3 (pug.experience@shield.mozilla.org)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x6760
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}]}
  • info: {u'TileHeight': 512, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 512, u'AzureCanvasAccelerated': 1, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
  • webgl1Renderer: ATI Technologies Inc. -- AMD Radeon HD 6490M OpenGL Engine
  • webgl1Version: 4.1 ATI-1.51.8
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc
  • webgl2Renderer: ATI Technologies Inc. -- AMD Radeon HD 6490M OpenGL Engine
  • webgl2Version: 4.1 ATI-1.51.8
  • webgl2WSIInfo: CGL
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Shadow110 1072 solutions 14836 answers

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Do the Mac equivalent. Do not delete Profile. Then restart system. Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer

Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer https://www.mozilla.org/firefox/all/

After reinstall if still have issue, it is in your Profile : https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles Create a New Profile.

Please let us know if this solved your issue or if need further assistance.

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Do the Mac equivalent. Do not delete Profile. Then restart system. Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer https://www.mozilla.org/firefox/all/ After reinstall if still have issue, it is in your Profile : https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles Create a New Profile. Please let us know if this solved your issue or if need further assistance.

Question owner

I've done everything as instructed and installed 57.0.2 but the problem persists. I'm reluctant to delete my profile and create a new one because of all the information in it, including passwords, AdBlocker Plus and the rest of it. What can I do?

I've done everything as instructed and installed 57.0.2 but the problem persists. I'm reluctant to delete my profile and create a new one because of all the information in it, including passwords, AdBlocker Plus and the rest of it. What can I do?

Question owner

Duplicate post – please ignore.

Duplicate post – please ignore.

Modified by Tony474

Shadow110 1072 solutions 14836 answers

Helpful Reply

https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer

https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data Copy the Profile Folder out.

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles Make a new Profile and Test.

Master Pass has their own Support. Firefox tries to Help if it interferes with Firefox Running. This is not the case. The ultimate responsibility lays with the Developers to provide Support. Try their Forum : http://help.masterpasswordapp.com/

Please let us know if this solved your issue or if need further assistance.

https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data Copy the Profile Folder out. https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles Make a new Profile and Test. Master Pass has their own Support. Firefox tries to Help if it interferes with Firefox Running. This is not the case. The ultimate responsibility lays with the Developers to provide Support. Try their Forum : http://help.masterpasswordapp.com/ Please let us know if this solved your issue or if need further assistance.
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159841 answers

Are you using Sync?

Are you using Sync?

Question owner

No. I'm not even sure what Sync is.

Edited to add: I've found out what it is and what it does, but I have no other devices with which to sync.

No. I'm not even sure what Sync is. Edited to add: I've found out what it is and what it does, but I have no other devices with which to sync.

Modified by Tony474

Chosen Solution

I've solved my immediate problem. What I did was this: I remembered that I had Firefox 56 installed on my older Macbook. So I opened it on that and made sure that master password was not enabled (it never had been). Then I quit it. Following that I navigated to the profile on that computer and copied it to a USB drive.

After that it was easy to delete the profile on my main computer (a Macbook Pro) and replace it with the one from my USB drive. On opening Firefox again, hey presto, Master Password is unchecked as it should have been all the time.

I was fortunate that I had another computer from which to copy the folder and thus accomplish this workaround. Other people with the same problem might not be so lucky. The conclusion I draw is that seemingly the requirement for a master password is checked by default in the new version's preferences, leading to the problem I experienced, and if that is the case it needs to be corrected as a bug fix or something.

I've solved my immediate problem. What I did was this: I remembered that I had Firefox 56 installed on my older Macbook. So I opened it on that and made sure that master password was not enabled (it never had been). Then I quit it. Following that I navigated to the profile on that computer and copied it to a USB drive. After that it was easy to delete the profile on my main computer (a Macbook Pro) and replace it with the one from my USB drive. On opening Firefox again, hey presto, Master Password is unchecked as it should have been all the time. I was fortunate that I had another computer from which to copy the folder and thus accomplish this workaround. Other people with the same problem might not be so lucky. The conclusion I draw is that seemingly the requirement for a master password is checked by default in the new version's preferences, leading to the problem I experienced, and if that is the case it needs to be corrected as a bug fix or something.
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159841 answers

Helpful Reply

Note that you can remove the logins.json and key3.db files in the profile folder to recover from such master password issues.

If that still gives issues then remove secmode.db as well.

Note that you can remove the logins.json and key3.db files in the profile folder to recover from such master password issues. If that still gives issues then remove secmode.db as well.

Modified by cor-el

Question owner

Thank you for that. As I said, my problem is now resolved, but that is useful to know if another occasion arises.

Thank you for that. As I said, my problem is now resolved, but that is useful to know if another occasion arises.
Shadow110 1072 solutions 14836 answers

Good for you. Glad to hear that your problem has been resolved. If you haven't already, *Please select the answer that solves the problem* YOURS. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Good for you. Glad to hear that your problem has been resolved. If you haven't already, *Please select the answer that solves the problem* YOURS. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.
FredMcD
  • Top 10 Contributor
4300 solutions 60395 answers

In the event that the passwords information is lost, you should record all information in a separate text file somewhere else on your hard drive, or written down. You can easily copy and paste if you need to do so. If you are concerned about someone else looking at that file, you can compress it using a password.

In the event that the passwords information is lost, you should record all information in a separate text file somewhere else on your hard drive, or written down. You can easily copy and paste if you need to do so. If you are concerned about someone else looking at that file, you can compress it using a password.

Question owner

Thanks, Fred – that is good advice.

Thanks, Fred – that is good advice.
FredMcD
  • Top 10 Contributor
4300 solutions 60395 answers

You're welcome. I tell this to everyone having password issues.

You're welcome. I tell this to everyone having password issues.