X
Tap here to go to the mobile version of the site.

Support Forum

Open new windows in a new tab instead doesn't work

AT
Posted

In the newest version of FireFox, when I click on links that would have opened a tab are now opening a new window. This started happening after installing the latest version and performing a refresh. I have "Open new windows in a new tab instead" selected. I have tried turning it on and off several times and it doesn't seem to have any affect on this issue. How do I get new tab to be in my current window and not opening up new windows.

UPDATE: It isn't "links" that are an issue, it is menu items and action buttons on web sites that use to open in a new tab that are now opening in a new window.

In the newest version of FireFox, when I click on links that would have opened a tab are now opening a new window. This started happening after installing the latest version and performing a refresh. I have "Open new windows in a new tab instead" selected. I have tried turning it on and off several times and it doesn't seem to have any affect on this issue. How do I get new tab to be in my current window and not opening up new windows. UPDATE: It isn't "links" that are an issue, it is menu items and action buttons on web sites that use to open in a new tab that are now opening in a new window.

Modified by AT

Chosen solution

Hi AT, the "Open new windows in a new tab instead" should control buttons in websites as well as links. However, if the site specifies features of the new window such as its side or selection of toolbars, then Firefox will allow it to be a window, on the theory that it may be a dialog or something that only makes sense when viewed in front of the page. You can override that to see whether it helps. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste neww and pause while the list is filtered

(3) Adjust the preferences as follows:

(A) browser.link.open_newwindow - for links in Firefox tabs

  • 3 = divert new window to a new tab (default) <= This should already be set; if it's not, right-click > Reset to restore the default
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

  • 0 = apply the setting under (A) to ALL new windows (even script windows) <= Try this one
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

  • -1 = apply the setting under (A) to external links (default) (this should already be set; if it's not, right-click > Reset to restore the default
  • 3 = open external links in a new tab in the last active window <= Try this one
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, right-click each "modified" preference and choose Reset.

Does it help with that site?

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Question owner

I am using version: 57.0.1 (64-bit)

I am using version: 57.0.1 (64-bit)
Mkll 314 solutions 1978 answers

Right click >> Open link in new tab.

Right click >> Open link in new tab.

Question owner

That doesn't work with buttons and menus. Normally I would use Ctrl click on links to do that.

I should have been better at describing the issue. It isn't specifically a "Link" that is the issue. They are menu options and action buttons on web sites that use to open in a new tab in the same FF window that now open in a new window.

That doesn't work with buttons and menus. Normally I would use Ctrl click on links to do that. I should have been better at describing the issue. It isn't specifically a "Link" that is the issue. They are menu options and action buttons on web sites that use to open in a new tab in the same FF window that now open in a new window.

Modified by AT

Mkll 314 solutions 1978 answers
Try this add-on: https://addons.mozilla.org/en-US/firefox/addon/open-in-new-tab-domain/
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Chosen Solution

Hi AT, the "Open new windows in a new tab instead" should control buttons in websites as well as links. However, if the site specifies features of the new window such as its side or selection of toolbars, then Firefox will allow it to be a window, on the theory that it may be a dialog or something that only makes sense when viewed in front of the page. You can override that to see whether it helps. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste neww and pause while the list is filtered

(3) Adjust the preferences as follows:

(A) browser.link.open_newwindow - for links in Firefox tabs

  • 3 = divert new window to a new tab (default) <= This should already be set; if it's not, right-click > Reset to restore the default
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

  • 0 = apply the setting under (A) to ALL new windows (even script windows) <= Try this one
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

  • -1 = apply the setting under (A) to external links (default) (this should already be set; if it's not, right-click > Reset to restore the default
  • 3 = open external links in a new tab in the last active window <= Try this one
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, right-click each "modified" preference and choose Reset.

Does it help with that site?

Hi AT, the "Open new windows in a new tab instead" should control buttons in websites as well as links. However, if the site specifies features of the new window such as its side or selection of toolbars, then Firefox will allow it to be a window, on the theory that it may be a dialog or something that only makes sense when viewed in front of the page. You can override that to see whether it helps. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''neww''' and pause while the list is filtered (3) Adjust the preferences as follows: (A) '''browser.link.open_newwindow''' - ''for links in Firefox tabs'' * '''3 = divert new window to a new tab (default)''' <= This should already be set; if it's not, right-click > Reset to restore the default * 2 = allow link to open a new window * 1 = force new window into same tab (B) '''browser.link.open_newwindow.<u>restriction</u>''' - for links in Firefox tabs * '''0 = apply the setting under (A) to ALL new windows''' (even script windows) <= Try this one * 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default) * 1 = override the setting under (A) and always use new windows (C) '''browser.link.open_newwindow.override.<u>external</u>''' - for links in other programs * -1 = apply the setting under (A) to external links (default) (this should already be set; if it's not, right-click > Reset to restore the default * '''3 = open external links in a new tab in the last active window''' <= Try this one * 2 = open external links in a new window * 1 = open external links in the last active tab replacing the current page To return to normal if things go haywire, right-click each "modified" preference and choose Reset. Does it help with that site?

Question owner

Thank you jscher2000, that seems to have done it. I tried this on a couple sites where I had noticed the change and it is now working as before.

Thank you jscher2000, that seems to have done it. I tried this on a couple sites where I had noticed the change and it is now working as before.