X
Tap here to go to the mobile version of the site.

Support Forum

Why do my sent messages magically add "�" at the end of my sentences?

Posted

The emails that I send with Thunderbird are clean and very professional when I send them. When my clients respond, their emails are also very clean and professional. However, the string of emails includes "�" after my sentences. These unusual characters also magically appear at the end of sentences in other individuals' emails in the earlier string of emails.

My clients tell me that the characters "�" appear in the email that they receive from me. I would like to know how to eliminate the unwanted addition of these characters.

The emails that I send with Thunderbird are clean and very professional when I send them. When my clients respond, their emails are also very clean and professional. However, the string of emails includes "�" after my sentences. These unusual characters also magically appear at the end of sentences in other individuals' emails in the earlier string of emails. My clients tell me that the characters "�" appear in the email that they receive from me. I would like to know how to eliminate the unwanted addition of these characters.

Chosen solution

You took me to a good place. I tried a variety of options and found that when I checked the checkbox 'When possible use the default text encoding in replies,' the problem went away. Thanks for getting me to the right place.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Toad-Hall
  • Top 10 Contributor
1683 solutions 11186 answers

Try this: 'Menu icon' <> 'Options' > 'Options' > 'Display' > 'Formatting' tab click on 'Advanced' button

Text Encoding: Q: Are you using 'Western (ISO-8859-1)' for outgoing and incoming mail ? If yes, uncheck the checkbox : 'When possible use the default text encoding in replies' click on OK

click on OK

Please report back on results.

Try this: 'Menu icon' <> 'Options' > 'Options' > 'Display' > 'Formatting' tab click on 'Advanced' button Text Encoding: '''Q: '''Are you using 'Western (ISO-8859-1)' for outgoing and incoming mail ? If yes, uncheck the checkbox : 'When possible use the default text encoding in replies' click on OK click on OK Please report back on results.

Question owner

Thanks for your interest and help. My outgoing mail was using 'Unicode (UTF-8)' so I changed it to 'Western (ISO-8859-1).' The checkbox 'When possible use the default text encoding in replies' was already unchecked, so I did not change anything there. I clicked on OK, restarted my machine, retested and still have the '�' characters.

Do you have any other ideas? Thanks again.

Thanks for your interest and help. My outgoing mail was using 'Unicode (UTF-8)' so I changed it to 'Western (ISO-8859-1).' The checkbox 'When possible use the default text encoding in replies' was already unchecked, so I did not change anything there. I clicked on OK, restarted my machine, retested and still have the '�' characters. Do you have any other ideas? Thanks again.

Chosen Solution

You took me to a good place. I tried a variety of options and found that when I checked the checkbox 'When possible use the default text encoding in replies,' the problem went away. Thanks for getting me to the right place.

You took me to a good place. I tried a variety of options and found that when I checked the checkbox 'When possible use the default text encoding in replies,' the problem went away. Thanks for getting me to the right place.
davidgrubb 0 solutions 2 answers

This appears to be a bug. The "�" is inserted when there are two or more consecutive spaces. It is trying to convert a space to a non-breaking space, but is using the wrong character encoding. Avoid putting two spaces after a sentence to avoid the problem. Here is a test message I sent to myself that shows the problem:


Test again.� Test. test.

no period� no period no period

three spaces�� two spaces� one space x


The problem occurs regardless of whether the checkbox is checked or not, and it occurs when the outbound encoding is UTF-8 or ISO 8859-1. the characters are hex codes EF, BF, BD, which in UTF-8 happens to be the Unicode "replacement" character to be used when the receiver does not understand the encoding.

This appears to be a bug. The "�" is inserted when there are two or more consecutive spaces. It is trying to convert a space to a non-breaking space, but is using the wrong character encoding. Avoid putting two spaces after a sentence to avoid the problem. Here is a test message I sent to myself that shows the problem: ------------------------------------- Test again.� Test. test. no period� no period no period three spaces�� two spaces� one space x ------------------------------------------------------ The problem occurs regardless of whether the checkbox is checked or not, and it occurs when the outbound encoding is UTF-8 or ISO 8859-1. the characters are hex codes EF, BF, BD, which in UTF-8 happens to be the Unicode "replacement" character to be used when the receiver does not understand the encoding.

Question owner

Thanks for your continued help.

Thanks for your continued help.
Sskills 0 solutions 1 answers

Helpful Reply

I have had this problem for a couple of weeks. Finally found the right combination of settings: Tools/Options/Display/Advanced Set Unicode on both Outgoing and Incoming Check box "When possible, use the default text encoding in replies" Hope this helps others.

I have had this problem for a couple of weeks. Finally found the right combination of settings: Tools/Options/Display/Advanced Set Unicode on both Outgoing and Incoming Check box "When possible, use the default text encoding in replies" Hope this helps others.
davidgrubb 0 solutions 2 answers

This is definitely a bug in Thunderbird.

Thunderbird is trying to convert consecutive spaces to non-breaking spaces, but getting it wrong. It is placing c2 hex in front of the hex 20 space, giving c220. It should be replacing the 20 with a0, to get c2a0, the UTF-8 non-breaking space.

C220 is one of the 11184 characters in the Hangul Syllables Unicode subset.

This is definitely a bug in Thunderbird. Thunderbird is trying to convert consecutive spaces to non-breaking spaces, but getting it wrong. It is placing c2 hex in front of the hex 20 space, giving c220. It should be replacing the 20 with a0, to get c2a0, the UTF-8 non-breaking space. C220 is one of the 11184 characters in the Hangul Syllables Unicode subset.
jimbir 3 solutions 56 answers

Toad-Hall said

Try this: 'Menu icon' <> 'Options' > 'Options' > 'Display' > 'Formatting' tab click on 'Advanced' button Text Encoding: Q: Are you using 'Western (ISO-8859-1)' for outgoing and incoming mail ? If yes, uncheck the checkbox : 'When possible use the default text encoding in replies' click on OK click on OK Please report back on results.

This did not work for me

''Toad-Hall [[#answer-1046622|said]]'' <blockquote> Try this: 'Menu icon' <> 'Options' > 'Options' > 'Display' > 'Formatting' tab click on 'Advanced' button Text Encoding: '''Q: '''Are you using 'Western (ISO-8859-1)' for outgoing and incoming mail ? If yes, uncheck the checkbox : 'When possible use the default text encoding in replies' click on OK click on OK Please report back on results. </blockquote> This did not work for me
jimbir 3 solutions 56 answers

Helpful Reply

Sskills said

I have had this problem for a couple of weeks. Finally found the right combination of settings: Tools/Options/Display/Advanced Set Unicode on both Outgoing and Incoming Check box "When possible, use the default text encoding in replies" Hope this helps others.

This is the solution that worked for me.

''Sskills [[#answer-1055743|said]]'' <blockquote> I have had this problem for a couple of weeks. Finally found the right combination of settings: Tools/Options/Display/Advanced Set Unicode on both Outgoing and Incoming Check box "When possible, use the default text encoding in replies" Hope this helps others. </blockquote> This is the solution that worked for me.
Jorg K 17 solutions 78 answers

There is NO bug in Thunderbird. Sadly some US ISP's like AT&T and Bellsouth have started *corrupting* their customers' e-mail.

If the customer sends in windows-1252 and includes for example special punctuation characters or a non-break space xA0, the ISP doesn't correctly interpret the the message as windows-1252 but as UTF-8. In UTF-8, xA0 is not valid and gets replaced by the so-called replacement character, � (0xEF 0xBF 0xBD).

Since the e-mail is still windows-1252 encoded, the recipient's client displays �.

See: https://bugzilla.mozilla.org/show_bug.cgi?id=1427636 https://bugzilla.mozilla.org/show_bug.cgi?id=1435536

Affected users should complain heavily to their mail providers. As a workaround, they need to send all messages as UTF-8.

There is NO bug in Thunderbird. Sadly some US ISP's like AT&T and Bellsouth have started *corrupting* their customers' e-mail. If the customer sends in windows-1252 and includes for example special punctuation characters or a non-break space xA0, the ISP doesn't correctly interpret the the message as windows-1252 but as UTF-8. In UTF-8, xA0 is not valid and gets replaced by the so-called replacement character, � (0xEF 0xBF 0xBD). Since the e-mail is still windows-1252 encoded, the recipient's client displays �. See: https://bugzilla.mozilla.org/show_bug.cgi?id=1427636 https://bugzilla.mozilla.org/show_bug.cgi?id=1435536 Affected users should complain heavily to their mail providers. As a workaround, they need to send all messages as UTF-8.
Jorg K 17 solutions 78 answers
Further reading: https://bugzilla.mozilla.org/show_bug.cgi?id=1435903 https://forums.yahoo.net/t5/Sending/Yahoo-SMTP-server-advertising-8bit-capability-incorrectly-and/m-p/449275
PeteLech 0 solutions 7 answers

Frustrating to know it is yahoo/ATT, as they are totally non-reponsive.

Frustrating to know it is yahoo/ATT, as they are totally non-reponsive.

Modified by PeteLech

Jorg K 17 solutions 78 answers

Workarounds:

Set preference mail.strictly_mime to true.

Or setup to send in UTF-8 always: Tools > Options, Display, Fonts & Colors, Advanced, Text Encoding.

Select UTF-8 for outgoing mail and clear "When possible, ..."

Workarounds: Set preference mail.strictly_mime to true. Or setup to send in UTF-8 always: Tools > Options, Display, Fonts & Colors, Advanced, Text Encoding. Select UTF-8 for outgoing mail and clear "When possible, ..."