Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to enable TLS 1.2 in firefox quantum 57.0 (64-bit)

  • 1 reply
  • 1 has this problem
  • 15 views
  • Last reply by TyDraniu

more options

I'm getting this error when trying to use a link send to my email

Sorry! Unsupported Browser Page

We no longer support your browser's security features, but no worries, we have a solution! To continue, just upgrade to the latest version of your browser. If you're already using the latest version, please be sure your browser's TLS 1.2 security features are turned on. and then I search for a solution to enable Firefox TLS 1.2 can't find it.

All Replies (1)

more options

Firefox 57 supports TLS 1.2 and even 1.3

Enter about:config in the URL bar and check if

  • security.tls.version.max = 3 or 4
  • security.tls.version.min = 1

This is the test: https://www.ssllabs.com/ssltest/viewMyClient.html