Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search box suggestions not working after upgrading to Quantum

  • 13 replies
  • 4 have this problem
  • 283 views
  • Last reply by aFunkyBass

more options

Hello there, I'm using Firefox 57 on Ubuntu Linux 16.04. After upgrading to the new version, I don't get any suggestions typing on the search box. (see attached image). Obviously I've been going through the preference page and made sure I had the search suggestion option enabled on the search tab.

I don't use private browsing, although I have disabled third part cookies. Has it anything to do with that? Is there any other option preventing search suggestions to come up?

Any help appreciated.

Attached screenshots

Chosen solution

Thanks for you help guys. The problem has been fixed in the last DEB package upgrade.

Please update your system by typing: sudo apt-get update sudo apt-get upgrade

Read this answer in context 👍 0

All Replies (13)

more options

Anyone having this issue?? :(

more options

No problem here.

In Prefs > Search verify that Provide search suggestions is selected.

more options

I am also having this exact same issue on Ubuntu 16.04 LTS. Yes, in "Preferences => Search" all check-boxes are on, and I've tried every solution mentioned on this support forum including clearing google's cookies to deleting the search.json. None helped. Switching to DuckDuckGo as a search engine for the time being.

Modified by Prahlad Yeri

more options

Do you have any anti-tracking extensions that might be blocking background requests to Google?

If you can't think of anything like that, and if your Firefox is repackaged by your distribution, perhaps your Google search plugin doesn't include suggestions. Apologies about how obscure this is, but investigating that will take a bit of work. I would like you to look inside a compressed file to see whether your Google search plugin includes the suggestions URL. Here's how:

(1) Open this decompressor page on my website:

https://www.jeffersonscher.com/res/searchjson.html

(2) Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, next to Profile Folder, click the "Open Directory" button (on other OS, "Open Folder" or "Show in Finder").

Make sure you can see the white box on the decompressor page behind the file viewer.

(3) In the profile folder, find search.json.mozlz4 and drag it to the decompressor page and drop it there

(4) Assuming all goes well, the page should enable the Save Uncompressed JSON (search.json) button. Click that and either save the file or open it directly into Firefox. If you save the file, then open it in Firefox.

(5) Firefox should show the raw data for a couple moments than show a structured view. (If you use NoScript, you need to enable scripting in local files.)

(6) Use Find to look for google.com and in particular, the part of the file that looks like the attached screenshot. Does your Google search plugin include that section?

Modified by jscher2000

more options

Hey jscher2000, thanks! The only extensions I use are Ublock-Origin and TamperMonkey and none were causing such issues before v57 upgrade. Also, when I tested with other search engines like DuckDuckGo and Bing, they did showed the suggestions.

I did the decompression process as you mentioned and found that Google.com search URL is indeed present there (see attached screen). Do you think this could be a goof-up with Ubuntu and not Mozilla?

- Prahlad

more options

Hi Prahlad, it was reported by three Ubuntu users today, so that is a clue! Clearly it is customized, since it refers to client as ubuntu rather than Firefox. However, I'm not sure exactly what the problem is.

Under "metadata:" there is no order property, so it may be "unchecked" in the big box on the Preferences page, Search panel. By any chance, is there a different Google search plugin elsewhere in the file that is selected instead?

more options

There isn't any order property for any of the search engines, not just Google, and I've triple checked and verified that both the check-boxes in the Preferences=>Search panel are on. As for the JSON data, there is only one "Google" in the list and its "_urls" section appears to be no different than others:


"_urls":[{"template":"https://www.google.com/complete/search?client=ubuntu&q={searchTerms}","rels":[],"resultDomain":"google.com","type":"application/x-suggestions+json","params":[]},{"template":"https://www.google.com/search","rels":["searchform"],"resultDomain":"google.com","params":[{"name":"client","value":"ubuntu"},{"name":"channel","value":"fs"},{"name":"q","value":"{searchTerms}"},{"name":"ie","value":"utf-8"},{"name":"oe","value":"utf-8"}]}],"queryCharset":"UTF-8"},{"_name":"Yahoo","_shortName":"yahoo","_loadPath":"jar:[app]/omni.ja!browser/yahoo.xml","description":"Yahoo Search","__searchForm":null,"_iconURL":"resource://search-plugins/images/yahoo.ico","_metaData":{},"_urls":[{"template":"https://search.yahoo.com/sugg/ff","rels":[],"resultDomain":"search.yahoo.com","type":"application/x-suggestions+json","params":[{"name":"output","value":"fxjson"},{"name":"appid","value":"ffd"},{"name":"command","value":"{searchTerms}"}]},{"template":"https://search.yahoo.com/yhs/search","rels":["searchform"],"resultDomain":"yahoo.com","params":[{"name":"p","value":"{searchTerms}"},{"name":"ei","value":"UTF-8"},{"name":"hspart","value":"mozilla"},{"name":"hsimp","value":"yhs-001","purpose":"searchbar"},{"name":"hsimp","value":"yhs-002","purpose":"keyword"},{"name":"hsimp","value":"yhs-003","purpose":"homepage"},{"name":"hsimp","value":"yhs-004","purpose":"newtab"},{"name":"hsimp","value":"yhs-005","purpose":"contextmenu"},{"name":"hsimp","value":"yhs-007","purpose":"system"}]}],"queryCharset":"UTF-8"},{"_name":"Bing","_shortName":"bing","_loadPath":"jar:[app]/omni.ja!browser/bing.xml","description":"Bing. Search by Microsoft.","__searchForm":null,"_iconURL"


Would you be able to find something if I send the entire JSON?

Modified by Prahlad Yeri

more options

The main thing I notice is that the Google search plugin is located in a folder under [distribution] while the others are in the compressed program file omni.ja:

"_name":"Google","_shortName":"google", "_loadPath":"[distribution]/searchplugins/locale/en-US/google.xml"

"_name":"Yahoo","_shortName":"yahoo", "_loadPath":"jar:[app]/omni.ja!browser/yahoo.xml"

"_name":"Bing","_shortName":"bing", "_loadPath":"jar:[app]/omni.ja!browser/bing.xml"

I don't know what significance that might have in Firefox 57 that it didn't have before.

more options

As a workaround, you could try installing a custom Google search plugin from http://mycroftproject.com/google-search-plugins.html

more options

Thanks, as a workaround, I've already switched to DuckDuckGo. In any case, I wanted to try that search engine since long time. I'll wait for this to get fixed in the meanwhile.

more options

Okay, this should be fixed Monday according to:

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1733970

But I don't know exactly what that means for when it will hit your system. Does Ubuntu do its own hotfix releases of Firefox on its own schedule?

more options

Thanks for the link. Yep, the distros usually provide these fixes as security updates. All the user has to do is run something like sudo apt-get update && sudo apt-get dist-upgrade, or use a GUI that does pretty much the same thing on debian based distros. This is a standard process for just about any package, not just firefox.

more options

Chosen Solution

Thanks for you help guys. The problem has been fixed in the last DEB package upgrade.

Please update your system by typing: sudo apt-get update sudo apt-get upgrade