X
Tap here to go to the mobile version of the site.

Support Forum

Lagging Badly

Posted

The Latest update(57 stable) was horrible, Every time it lags for 2-3 minutes whenever I start typing URL, literally I can't even work at cloudflare.com it lags and I need to close firefox through Taskmanager I tried to reinstall several times, even new beta had the same issue. Previously I was using Nighty 57* which was awesome and smooth, I made mistake by uninstalling it and installing 57 stable version. Someone, please share me a link where I can download that Previous NIghtly version.

The Latest update(57 stable) was horrible, Every time it lags for 2-3 minutes whenever I start typing URL, literally I can't even work at cloudflare.com it lags and I need to close firefox through Taskmanager I tried to reinstall several times, even new beta had the same issue. Previously I was using Nighty 57* which was awesome and smooth, I made mistake by uninstalling it and installing 57 stable version. Someone, please share me a link where I can download that Previous NIghtly version.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Shadow110 1072 solutions 14836 answers

You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Hardware Acceleration might have also been a issue so turn it off. Run it later and see as you turn things back on and test it, and again. Restart Firefox after making these changes please.

Please let us know if this solved your issue or if need further assistance.

You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Hardware Acceleration might have also been a issue so turn it off. Run it later and see as you turn things back on and test it, and again. Restart Firefox after making these changes please. Please let us know if this solved your issue or if need further assistance.
safemanusa 5 solutions 76 answers

Helpful Reply

Pkshadow said

You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Hardware Acceleration might have also been a issue so turn it off. Run it later and see as you turn things back on and test it, and again. Restart Firefox after making these changes please. Please let us know if this solved your issue or if need further assistance.

This solution is AWESOME! I now have added this solution with the one you suggested in the following thread. For me I seem to have needed to do BOTH solutions. Not sure if this will help other people.

https://support.mozilla.org/en-US/questions/1184207

''Pkshadow [[#answer-1034622|said]]'' <blockquote> You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Hardware Acceleration might have also been a issue so turn it off. Run it later and see as you turn things back on and test it, and again. Restart Firefox after making these changes please. Please let us know if this solved your issue or if need further assistance. </blockquote> This solution is AWESOME! I now have added this solution with the one you suggested in the following thread. For me I seem to have needed to do BOTH solutions. Not sure if this will help other people. https://support.mozilla.org/en-US/questions/1184207

Question owner

Pkshadow said

You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Hardware Acceleration might have also been a issue so turn it off. Run it later and see as you turn things back on and test it, and again. Restart Firefox after making these changes please. Please let us know if this solved your issue or if need further assistance.

I am done with this thing. Still, I had a problem. It works fine after unchecking prevent accessibility services, but still sometimes laptop stops while using Firefox 57 (and fx-8800p). browser not responds when I use some website

I was Back to Firefox Nightly which works very well. Please Do something to this stable version...

''Pkshadow [[#answer-1034622|said]]'' <blockquote> You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Hardware Acceleration might have also been a issue so turn it off. Run it later and see as you turn things back on and test it, and again. Restart Firefox after making these changes please. Please let us know if this solved your issue or if need further assistance. </blockquote> I am done with this thing. Still, I had a problem. It works fine after unchecking prevent accessibility services, but still sometimes laptop stops while using Firefox 57 (and fx-8800p). browser not responds when I use some website I was Back to Firefox Nightly which works very well. Please Do something to this stable version...

Question owner

safemanusa said

Pkshadow said
You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Hardware Acceleration might have also been a issue so turn it off. Run it later and see as you turn things back on and test it, and again. Restart Firefox after making these changes please. Please let us know if this solved your issue or if need further assistance.

This solution is AWESOME! I now have added this solution with the one you suggested in the following thread. For me I seem to have needed to do BOTH solutions. Not sure if this will help other people.

https://support.mozilla.org/en-US/questions/1184207

Not Works for me having 8gb ram(amd fx-8800p) still had a bad experience with Firefox 57, for now i am sticking with Nightly..

''safemanusa [[#answer-1034667|said]]'' <blockquote> ''Pkshadow [[#answer-1034622|said]]'' <blockquote> You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Hardware Acceleration might have also been a issue so turn it off. Run it later and see as you turn things back on and test it, and again. Restart Firefox after making these changes please. Please let us know if this solved your issue or if need further assistance. </blockquote> This solution is AWESOME! I now have added this solution with the one you suggested in the following thread. For me I seem to have needed to do BOTH solutions. Not sure if this will help other people. https://support.mozilla.org/en-US/questions/1184207 </blockquote> Not Works for me having 8gb ram(amd fx-8800p) still had a bad experience with Firefox 57, for now i am sticking with Nightly..
Shadow110 1072 solutions 14836 answers

You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 0 = No Multi-proccesor = slow again. Hardware Acceleration might have also been a issue so turn it off. Run it later and see as you turn things back on and test it, and again.

So recommend do not go to 0 but maybe 1 and test.

Need I say Update your Video Card Drivers.

Restart Firefox after making these changes please.

Can also try the Developers Edition https://www.mozilla.org/en-US/firefox/developer do not have to use the Tools. It has a Compatibility Mode at end of the install so can run 2 versions at same time.

If you are now running 2 versions it is possible that what ever is tried will not work.

Please let us know if this solved your issue or if need further assistance.

You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 0 = No Multi-proccesor = slow again. Hardware Acceleration might have also been a issue so turn it off. Run it later and see as you turn things back on and test it, and again. So recommend do not go to 0 but maybe 1 and test. Need I say Update your Video Card Drivers. Restart Firefox after making these changes please. Can also try the Developers Edition https://www.mozilla.org/en-US/firefox/developer do not have to use the Tools. It has a Compatibility Mode at end of the install so can run 2 versions at same time. If you are now running 2 versions it is possible that what ever is tried will not work. Please let us know if this solved your issue or if need further assistance.

Question owner

Pkshadow said

You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 0 = No Multi-proccesor = slow again. Hardware Acceleration might have also been a issue so turn it off. Run it later and see as you turn things back on and test it, and again. So recommend do not go to 0 but maybe 1 and test. Need I say Update your Video Card Drivers. Restart Firefox after making these changes please. Can also try the Developers Edition https://www.mozilla.org/en-US/firefox/developer do not have to use the Tools. It has a Compatibility Mode at end of the install so can run 2 versions at same time. If you are now running 2 versions it is possible that what ever is tried will not work. Please let us know if this solved your issue or if need further assistance.

The newest update is awesome, solved all the issue now its like blazing fast. thanks

''Pkshadow [[#answer-1045176|said]]'' <blockquote> You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 0 = No Multi-proccesor = slow again. Hardware Acceleration might have also been a issue so turn it off. Run it later and see as you turn things back on and test it, and again. So recommend do not go to 0 but maybe 1 and test. Need I say Update your Video Card Drivers. Restart Firefox after making these changes please. Can also try the Developers Edition https://www.mozilla.org/en-US/firefox/developer do not have to use the Tools. It has a Compatibility Mode at end of the install so can run 2 versions at same time. If you are now running 2 versions it is possible that what ever is tried will not work. Please let us know if this solved your issue or if need further assistance. </blockquote> The newest update is awesome, solved all the issue now its like blazing fast. thanks